You are not logged in.

#1 2012-12-08 14:40:23

ernetas
Member
Registered: 2011-03-13
Posts: 77

Running on 800 mHz, even though 2 cores are on 100%

Running on ondemand cpufreq governor with 800 Mhz, even though 2 cores are on 100% load. What could be the problem?
/proc/cpuinfo shows 1000 Mhz for 2 cores (out of 4) and cpupower somehow shows only 800 Mhz for all of them.

Last edited by ernetas (2012-12-08 14:41:38)

Offline

#2 2012-12-08 20:07:17

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Running on 800 mHz, even though 2 cores are on 100%

If you have and Intel i3/i5/i7 CPU install and run i7z

Uninstall, cpufreq it is not needed for new CPU's. Intel SpeedStep and Intel Turbo Boost handles all CPU frequency changing.

Then try compiling some software and report back what MHz i7z reports.

Last edited by hunterthomson (2012-12-08 20:10:29)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#3 2012-12-08 20:22:16

ernetas
Member
Registered: 2011-03-13
Posts: 77

Re: Running on 800 mHz, even though 2 cores are on 100%

hunterthomson wrote:

If you have and Intel i3/i5/i7 CPU install and run i7z

Uninstall, cpufreq it is not needed for new CPU's. Intel SpeedStep and Intel Turbo Boost handles all CPU frequency changing.

Then try compiling some software and report back what MHz i7z reports.

Oh, this is a bug for sure. There is absolutely no need to check whether real frequency is normal, because I only noticed this because of slow ogv encoding.

i7z reports true frequency of 2293 MHz (which is normal for my 2410M) and current frequency only 800 MHz.

And also - a month ago /proc/cpuinfo was reporting the real frequency unless it was using Turbo to boost it above the nominal one. Now it just shows 1000 MHz.
If try to compile stuff, run mathematical calculations or simply do "cat /dev/urandom", it gives me very poor performance, which is unlikely as the temperature of CPU is low and it cannot be that cpufreq (which is in kernel) would lower the frequency just to cool it down. Probably a bug.
Should I report this to ArchLinux or kernel's bug tracker?

Last edited by ernetas (2012-12-08 20:23:21)

Offline

#4 2012-12-09 01:06:57

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Running on 800 mHz, even though 2 cores are on 100%

Well, go ahead and configure cpufreq and try the different options.

Then uninstall that sucker, and see what happens.

Also, go and check out what BIOS options are available to you. I know Thinkpads have like every option you could think of, and some of them will slow down the system.

My best guess would be cpufreq is causeing the problems, becuase I am sure you would remember changing BIOS settings.

... sure... hum... well you could also try installing the LTS Kernel, but I think most driver stuff gets backported to that anyway upstream.

Or, check in your /var/cache/pacman/pkg  for Older Kernels that you could try. Then see if you still have the same problem. Before trying any other kernel uninstall cpufreq.

Last edited by hunterthomson (2012-12-09 01:08:24)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#5 2012-12-09 10:47:30

ernetas
Member
Registered: 2011-03-13
Posts: 77

Re: Running on 800 mHz, even though 2 cores are on 100%

hunterthomson wrote:

Well, go ahead and configure cpufreq and try the different options.

Then uninstall that sucker, and see what happens.

Also, go and check out what BIOS options are available to you. I know Thinkpads have like every option you could think of, and some of them will slow down the system.

My best guess would be cpufreq is causeing the problems, becuase I am sure you would remember changing BIOS settings.

... sure... hum... well you could also try installing the LTS Kernel, but I think most driver stuff gets backported to that anyway upstream.

Or, check in your /var/cache/pacman/pkg  for Older Kernels that you could try. Then see if you still have the same problem. Before trying any other kernel uninstall cpufreq.

It can't be cpufreq, because I only installed it after the issue occurred, just to check what it says. + it is ONLY an interface for /sys/devices/system/cpu/cpu*/cpufreq/, so it does not affect anything, unless I use it, which I don't.

Yeah, I would bet on BIOS, but I didn't change anything and I wouldn't really have been able to do so, because as far as I remember - my laptop's BIOS is very little flexible - I can't play with frequencies, for sure.

I always clean the cache.

Today, after a reboot the problem disappeared. Should I still report this to the upstream? What further investigation could I do?

Offline

#6 2012-12-10 07:21:27

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Running on 800 mHz, even though 2 cores are on 100%

Well, to be clear if the cpufreq daemon process is running it uses the ondemand governor by default and makes a best guess on the freq's. BUT, yes okay you had the problem before it was installed.

Well, as for reporting it... I guess you could but you would need to be able to reproduce the problem. I can't see how the kernel could be at fault though, provided you are not running any daemons like cpufreq, Intel i5 CPU's do all the frequency scaling all on there own. I don't know for sure, but I would not even think that ACPI has anything to do with it. I would think that it is all done in the CPU microcode and BIOS.

The main thing is that it is working now. Keep an eye on it with i7z and post again if the problem comes back.

Last edited by hunterthomson (2012-12-10 07:23:22)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#7 2012-12-10 07:58:14

ernetas
Member
Registered: 2011-03-13
Posts: 77

Re: Running on 800 mHz, even though 2 cores are on 100%

hunterthomson wrote:

Well, to be clear if the cpufreq daemon process is running it uses the ondemand governor by default and makes a best guess on the freq's. BUT, yes okay you had the problem before it was installed.

Well, as for reporting it... I guess you could but you would need to be able to reproduce the problem. I can't see how the kernel could be at fault though, provided you are not running any daemons like cpufreq, Intel i5 CPU's do all the frequency scaling all on there own. I don't know for sure, but I would not even think that ACPI has anything to do with it. I would think that it is all done in the CPU microcode and BIOS.

The main thing is that it is working now. Keep an eye on it with i7z and post again if the problem comes back.

cpufreq is integrated into kernel and it runs even without cpufreq package with a default governor "ondemand", which you can control via /sys and /proc, just like anything else that comes from kernel. Turbo Boost only works when it needs more than nominal frequency and the temperature allows overclocking and yes, it is done by the CPU microcode and BIOS. As for SpeedStep, it is a technology which... "allow the clock speed of the processor to be dynamically changed (to different P-states) by software" (from Wikipedia), so it has nothing to do with my case as turning it off would lead to nominal frequency of 2.4 GHz.
As for ACPI, I agree - it should not have anything to do with that. Or at least I hope so, because using an ACPI-based battery monitor causes trouble: i. e. touchpad may sometimes stop working (and this is a known bug in the Arch community - it's not just my hardware).

Offline

#8 2012-12-11 11:11:21

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Running on 800 mHz, even though 2 cores are on 100%

Well as it turns out ACPI is used.

[user@archbox:~]% sudo lsmod |grep cpufreq
[sudo] password for user: 
acpi_cpufreq            6854  1 
mperf                   2124  1 acpi_cpufreq
processor              27916  1 acpi_cpufreq

https://wiki.archlinux.org/index.php/Cp … ncy_driver

From what I understand System76 probaly ships the best BIOS's, but I don't like the look of their laptops. Thinkpads have always worked well for me though. I assume it is becuase a lot of Linux dev's have Thinkpads. I know other laptops Lenovo ships have junk BIOS's like all the rest. Or, maybe IBM put them on the right track back in the day.

Last edited by hunterthomson (2012-12-11 11:50:35)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

Board footer

Powered by FluxBB