You are not logged in.

#1 2012-12-07 19:56:13

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

[SOLVED]Dell Vostro 3560

Hi everyone,

Just got a brand new Vostro 3560 with a i5 3210M and a discrete graphics system with a AMD 7670M and a IntelHD4000.

Got Arch up and running, everything seems to be alright, with the exception of the hybrid grahics system, but its a well known problem.

My problem is not related to that, is there any guide for these 3rd generation Intel CPU's related to power balance management, I'm asking this because with my Vostro I can't get more than 2h of battery, and on the same model with Windowz my colleagues get about 3/4 hrs of battery, I already followed the instalation guide for the Laptop utils, just wondering if there is any more info related with IvyBridge laptops from ArchLinux.

Thanks in advance

Last edited by pedronoliveira (2012-12-10 10:36:57)

Offline

#2 2012-12-08 09:24:51

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: [SOLVED]Dell Vostro 3560

Hi,

Have you tried laptop-mode-tools from [community]? With this service enabled I can get 4.5 hours instead of 2 on a HP Probook with i5-2350M.

Offline

#3 2012-12-10 08:21:29

dito
Member
Registered: 2011-11-07
Posts: 10

Re: [SOLVED]Dell Vostro 3560

Hi pedronoliveira

I have exactly the same laptop as you. Is your radeon card turned off using that vgaswitcheroo thing? With that in place (only that, no laptop-mode-tools), my battery life is around 3 hours.

Offline

#4 2012-12-10 09:28:41

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

Re: [SOLVED]Dell Vostro 3560

dito wrote:

Hi pedronoliveira

I have exactly the same laptop as you. Is your radeon card turned off using that vgaswitcheroo thing? With that in place (only that, no laptop-mode-tools), my battery life is around 3 hours.

dito did you followed this, I've already done this, but how can I tell that vgaswitcheroo is working?

Thanks in advance.

Last edited by pedronoliveira (2012-12-10 09:29:36)

Offline

#5 2012-12-10 09:49:56

dito
Member
Registered: 2011-11-07
Posts: 10

Re: [SOLVED]Dell Vostro 3560

Type the following command:

cat /sys/kernel/debug/vgaswitcheroo/switch 

The output of this should be something like that:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0

If the second line is NOT set to "Off", your ati graphic card is still enabled. In this case, try the systemd-vgaswitcheroo-units package from AUR. This will install a systemd service, which automatically enables the radeon module and switches off the external card. If you have problems with the shutdown, try to comment the ExecStop line in /usr/lib/systemd/system/vgaswitcheroo.service:

[Unit]
Description=Deactivate the discrete graphic

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/vgaswitcheroo_start.sh
#ExecStop=/usr/bin/vgaswitcheroo_stop.sh

[Install]
WantedBy=multi-user.target

Hope this works :-)

Offline

#6 2012-12-10 09:55:18

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

Re: [SOLVED]Dell Vostro 3560

dito wrote:

Type the following command:

cat /sys/kernel/debug/vgaswitcheroo/switch 

The output of this should be something like that:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0

If the second line is NOT set to "Off", your ati graphic card is still enabled. In this case, try the systemd-vgaswitcheroo-units package from AUR. This will install a systemd service, which automatically enables the radeon module and switches off the external card. If you have problems with the shutdown, try to comment the ExecStop line in /usr/lib/systemd/system/vgaswitcheroo.service:

[Unit]
Description=Deactivate the discrete graphic

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/vgaswitcheroo_start.sh
#ExecStop=/usr/bin/vgaswitcheroo_stop.sh

[Install]
WantedBy=multi-user.target

Hope this works :-)

Unfortunately I don't have the directory mentioned in here:

cat /sys/kernel/debug/vgaswitcheroo/switch 

I sincerely I don't understand what I'm doing wrong!

Thanks in advance!

Offline

#7 2012-12-10 09:58:56

dito
Member
Registered: 2011-11-07
Posts: 10

Re: [SOLVED]Dell Vostro 3560

Add this to your fstab:

none            /sys/kernel/debug debugfs defaults 0 0

then try again.

Offline

#8 2012-12-10 10:07:48

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

Re: [SOLVED]Dell Vostro 3560

dito wrote:

Add this to your fstab:

none            /sys/kernel/debug debugfs defaults 0 0

then try again.

Already have that in fstab.

When I have the radeon and i915 declare on MODULES section in the mkinitcpio.conf the system won't boot, but in the guide said that you had to have KMS enabled for both graphics, what I doing wrong here?

Thanks in advance

Offline

#9 2012-12-10 10:18:33

dito
Member
Registered: 2011-11-07
Posts: 10

Re: [SOLVED]Dell Vostro 3560

KMS should be enabled by default for both cards, so you don't have to bother with that. Your system won't boot if the radeon module is loaded at boot-time (blacklist it). To disable the ati card, you must enable the radeon module after booting your system.

Remove radeon from your MODULES array and start your system. Then modprobe radeon and vgaswitcheroo should be accessible.


By the way: Are you still using initscripts?

Last edited by dito (2012-12-10 10:20:38)

Offline

#10 2012-12-10 10:20:08

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

Re: [SOLVED]Dell Vostro 3560

dito wrote:

KMS should be enabled by default for both cards, so you don't have to bother with that. Your system won't boot if the radeon module is loaded at boot-time. To disable the ati card, you must enable the radeon module after booting your system.

Remove radeon from your MODULES array and start your system. Then modprobe radeon and vgaswitcheroo should be accessible.


By the way: Are you still using initscripts?

I'm using systemd so do I leave the MODULES array in blank or leave the i915 module in there?

Offline

#11 2012-12-10 10:27:10

dito
Member
Registered: 2011-11-07
Posts: 10

Re: [SOLVED]Dell Vostro 3560

Actually you shouldn't use MODULES at all (see https://wiki.archlinux.org/index.php/In … nf#Modules). Remove both entries and add a file called radeon.conf (or whatever you like) to /etc/modprobe.d/ with the following content:

# blacklist radeon module. xserver will not start otherwise.
blacklist radeon

Then restart your system, modprobe radeon and try to access vgaswitcheroo.

Last edited by dito (2012-12-10 10:27:27)

Offline

#12 2012-12-10 10:36:27

pedronoliveira
Member
From: Portugal
Registered: 2012-07-15
Posts: 8

Re: [SOLVED]Dell Vostro 3560

dito wrote:

Actually you shouldn't use MODULES at all (see https://wiki.archlinux.org/index.php/In … nf#Modules). Remove both entries and add a file called radeon.conf (or whatever you like) to /etc/modprobe.d/ with the following content:

# blacklist radeon module. xserver will not start otherwise.
blacklist radeon

Then restart your system, modprobe radeon and try to access vgaswitcheroo.

Thanks for all your help, it's working now, the output cat /sys/kernel/debug/vgaswitcheroo/switch is correct now and the battery life has increased as you mentioned!

Once again thank you for all your help.

Offline

Board footer

Powered by FluxBB