You are not logged in.

#1 2012-12-10 14:24:53

Terseus
Member
Registered: 2007-04-26
Posts: 9

[Solved] leptonica - broken dependency

I just updated my system and get this message:

error: failed to prepare transaction (could not satisfy dependencies)
:: leptonica: requires libwebp=0.2.0

The package libwebp have been updated to 0.2.1 but leptonica it's not prepared for it.

Currently using mirror http://mir1.archlinux.fr/archlinux/
Some info about the packages changes:

$ pacman -Ss libwebp 
extra/libwebp 0.2.1-1 [installed: 0.2.0-1]

$ pacman -Ss leptonica 
community/leptonica 1.69-4 [installed]

Edit: Fixed right now with the -5 update of leptonica.

Last edited by Terseus (2012-12-10 16:10:54)

Offline

#2 2012-12-10 23:31:55

Nikus
Member
Registered: 2012-12-10
Posts: 8

Re: [Solved] leptonica - broken dependency

I get the same problem, but I don't understand how you solved it.
Could you explain me what is the «-5 update of leptonica» ?

Offline

#3 2012-12-11 10:30:13

Terseus
Member
Registered: 2007-04-26
Posts: 9

Re: [Solved] leptonica - broken dependency

@Nikus the latest update of the package "leptonica" with version 1.69-5 is compatible with the version 0.2.1-1 of the pacakge "libwebp", just do a pacman -Syu and, if you mirror is sync'd, you will update with no problems smile

Offline

#4 2012-12-11 15:13:11

Nikus
Member
Registered: 2012-12-10
Posts: 8

Re: [Solved] leptonica - broken dependency

Thanks Terseus, I just update the whole system, as you wrote, and it worked.
I like the problems that are solved themselves wink

Offline

#5 2013-04-03 19:09:07

HermesT
Member
From: Spain
Registered: 2008-09-06
Posts: 27

Re: [Solved] leptonica - broken dependency

Hi everybody.

I have a new issue with leptonica (I think):

sudo pacman -Syu
[sudo] password for fran: 
:: Sincronizando las bases de datos de paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: leptonica: necesita libwebp=0.2.1

Installed versions: 

 
sudo pacman -Qs leptonica
local/leptonica 1.69-5
    Software that is broadly useful for image processing and image analysis applications
 sudo pacman -Qs libwebp
local/libwebp 0.2.1-1
    WebP library and conversion tools

New libwebp version available:

 
[fran@HermesT pacman.d]$ sudo pacman -Ss libwebp
extra/libwebp 0.3.0-1 [instalado: 0.2.1-1]
    WebP library and conversion tools

Which do you think is the best option?

1.- Wait for a new update of leptonica, with new libwebp version updated.
2.- Force system update
3.- uninstall  leptonica, and remove tesseract, and remove tesseract-xxx and ....  and reinstall tesseract and so on.... That laziness!   
4.- System update avoiding  libweb update (how?)


I apologize about pacman output in spanish, but I think they are clear enough....

Thanks.

Offline

#6 2013-04-03 19:31:16

HermesT
Member
From: Spain
Registered: 2008-09-06
Posts: 27

Re: [Solved] leptonica - broken dependency

.... 5.- Try other mirrors....

Hi guys.
Please forget the question. Is a issue of out of sync mirrors   (thanks Terseus).
Spanish mirrors are now disabled in mirrorlist , and french ones are enabled.

A few months ago I have had a similar problem with (I suspect) the same cause.

Thanks.

Last edited by HermesT (2013-04-03 19:33:28)

Offline

#7 2013-04-04 13:35:43

Terseus
Member
Registered: 2007-04-26
Posts: 9

Re: [Solved] leptonica - broken dependency

Hi HermesT.

You can execute a command with the standard english output prepending "LC_MESSAGES=C" to the command, like this:

terseus@terseus-desktop:~$ pacman
error: no se especificó una operación (utilice -h para ayuda)
terseus@terseus-desktop:~$ LC_MESSAGES=C pacman
error: no operation specified (use -h for help)

Very useful for posting error messages or finding solutions wink

Offline

Board footer

Powered by FluxBB