You are not logged in.

#1 2012-09-11 18:00:11

sray
Member
Registered: 2010-03-06
Posts: 4

e17 and hicolor-icon-theme

hi all
i am new to e17, and have met some problems with icons

many apps dependes on hicolor-icon-theme (such like firefox).
but it seems that e17 can not find the icons in a icon theme
(can not find firefox.png in /usr/share/icon/hicolor/48x48/apps/firefox.png)

i have searched and the google says icon theme can be choosed in [ settings > setting panel > look > icon theme ]
but there is no icon theme

so how can i use hicolor icon themes in e17 without change the icon section in .desktop file

thanks

Offline

#2 2012-09-12 03:14:41

Azriel
Member
Registered: 2008-01-23
Posts: 58

Re: e17 and hicolor-icon-theme

Hi,

There is an icon theme option if you go to Settings panel > look > application theme, and then choose "icons" on the upper side of the window, does that work ?

Offline

#3 2012-09-12 03:35:30

sray
Member
Registered: 2010-03-06
Posts: 4

Re: e17 and hicolor-icon-theme

hi azriel
i have also tried that, but there is nothing as well.

Offline

#4 2012-09-12 04:10:38

Azriel
Member
Registered: 2008-01-23
Posts: 58

Re: e17 and hicolor-icon-theme

Well I don't use the e17 packages provided by Arch, because they seem to lack a few modules that I use, but you could try to download easy_e17.sh (either get the package, or just download it from the source using google), and then compile e17 yourself straight from the source.

If you do so, you should note that the script hasn't been updated in a while, so I had to add engage manually in the e_modules_extra part of the script (and remove the modules it replaces, whose name I forgot...)

I also remember having the same trouble a long time ago, and fixing it by creating a .gtkrc-2.0 file in my home containing the following:

gtk-icon-theme-name="Tango"
include ".gtkrc-2.0-gnome-color-chooser" 

Obviously changing Tango to hicolor-icon-theme. Can't tell if it'll work though, I can't exactly remember why I had to do this, and it might be severely deprecated (my /home partition is quite old, as I never reformat it)

Lastly, some things can be a pain to configure through e17 settings panel, and are actually system-wide settings (not just e17 specific), so a solution would be to install the kdebase metapackage, and launch the KDE settings panel using systemsettings in the terminal. From here you can set the icon theme by going to Application Appearance -> Icons.

Last edited by Azriel (2012-09-12 04:11:45)

Offline

#5 2012-12-11 09:23:33

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

this problem still persists with latest beta packages. hicolor-icon-theme doesn't appear in the settings dialog. I tried lxappearance, too....so there might be some package missing? I guess this is a bug?
half of my applications doesn't have an icon

Offline

#6 2012-12-11 17:10:53

mike_r
Member
Registered: 2009-01-22
Posts: 114

Re: e17 and hicolor-icon-theme

Today's gamma release has the comment about lots of new icons. Maybe this will fix your issue when it becomes available?


Linux User #353 - SLS -> Slackware -> Red Hat -> Mandrake -> Fedora -> Arch

Offline

#7 2012-12-12 00:53:41

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

mike_r wrote:

Today's gamma release has the comment about lots of new icons. Maybe this will fix your issue when it becomes available?

didn't solve, it's not an E17 icons problem anyways
All application icons show in /usr/share/applications, so they all got an icon, half of them simply don't show up in the menu/IBar

Offline

#8 2012-12-12 15:12:31

AsA
Member
From: Milan - Italy
Registered: 2008-10-05
Posts: 40

Re: e17 and hicolor-icon-theme

it just happened I solved the same problem... unfortunately I'm not sure this is what I really did to solve -.-
Just try this:
run efreet_icon_cache_dump it may end with with an error;
that pointed me to empty the folder  .cache/efreet.
after a E17 restart the icons were there (not all, but most of them, I have replaced the others by hand) and also icon theme selector works.


WINDOS - Windos Is Not a Decent Operating System

Help me improve my english!
If you notice bad grammar in my posts, please correct me! Thanks!

Offline

#9 2012-12-13 00:54:43

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

I have the hicolor icons too now.
but there are still a lot of programs without icons. But I found out the problem. All icons which are not showing have *.svg icons

Offline

#10 2012-12-13 01:04:21

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

capoeira wrote:

but there are still a lot of programs without icons. But I found out the problem. All icons which are not showing have *.svg icons


solved this installing "evas_generic_loaders"

now I got them all....YESSSS

Offline

#11 2012-12-13 01:04:39

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,894

Re: e17 and hicolor-icon-theme

capoeira, do you have evas_generic_loaders installed? This is where svg support comes from.

Edit: ok, you beat me to it. Glad you got it solved.

Last edited by Scimmia (2012-12-13 01:05:22)

Offline

#12 2012-12-13 01:07:40

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

Scimmia wrote:

capoeira, do you have evas_generic_loaders installed? This is where svg support comes from.

Edit: ok, you beat me to it. Glad you got it solved.

thanks for trying to help.


why isn't this dependency of E17?

Offline

#13 2012-12-13 01:10:16

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,894

Re: e17 and hicolor-icon-theme

The generic loaders have always been considered optional, e17 works just fine without them. It was the third party apps you have installed that needed them, and then only for optional features like icons.

As such, it's an optional dependency of Evas.

Last edited by Scimmia (2012-12-13 01:11:31)

Offline

#14 2012-12-13 01:51:26

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 447

Re: e17 and hicolor-icon-theme

Scimmia wrote:

The generic loaders have always been considered optional, e17 works just fine without them. It was the third party apps you have installed that needed them, and then only for optional features like icons.

As such, it's an optional dependency of Evas.


hmmmmm. even libre office uses icons like this, but ok......

Offline

Board footer

Powered by FluxBB