You are not logged in.

#1 2012-12-12 07:31:39

endor43
Member
Registered: 2012-11-04
Posts: 21

IBUS SCIM fctix all cause crashing gtk apps

Hey all,

Continued from https://bbs.archlinux.org/viewtopic.php … 5#p1205035 because subject has changed.

Any IME (Ibus, scim, fcitx), when installed, all cause the gedit crash and segmentation fault error, in fact, this seems to not just be limited to gedit but many gtk applications.
When they IMEs are not installed, gedit etc. work fine.

http://ubuntuforums.org/archive/index.php/t-423521.html
http://forum.vectorlinux.com/index.php? … 420.0;wap2

Does this have something to do GTK_IM_MODULE and xim?
Basically no IME's will work at the moment (all cause gtk apps to segfault), which makes it very unusable for me....
I really need chinese support, anyone have any ideas on how to fix this?
Also, by the way, why does AUR no longer have scim-bridge?

Thank you very much.

Last edited by endor43 (2012-12-12 07:33:21)

Offline

#2 2012-12-12 22:50:58

csslayer
Member
Registered: 2009-03-05
Posts: 84

Re: IBUS SCIM fctix all cause crashing gtk apps

what's your gtk3 glib2 version?

If all of non-xim im module cause gedit crash, I think the most possible reason is some related library version mistmatch, maybe you installed some custom gtk3 / glib2 ?

Offline

#3 2012-12-13 00:22:39

endor43
Member
Registered: 2012-11-04
Posts: 21

Re: IBUS SCIM fctix all cause crashing gtk apps

I was thinking something similar, but both are up to date and from arch repositories.
At any rate, I woke up this morning and it is no longer happening. I honestly have idea why, its nice to not have a problem, but disappointing to not understand.
It may come back tomorrow, so I'll keep trying to figure out whats going on and post results.
Thank you for enveryone's help.

Offline

#4 2012-12-13 01:22:07

endor43
Member
Registered: 2012-11-04
Posts: 21

Re: IBUS SCIM fctix all cause crashing gtk apps

Ah, so apparently  when i innocently cleared some stuff from my ~/.bashrc file last night, I ended up deleting this line:

 
export GTK_IM_MODULE_FILE=/etc/gtk-2.0/gtk.immodules

which causes the seegmentation faults on gtk app with all the IME's

So no segmentation faults, but......

The above line is neccessary for the IME (in my case SCIM) to work on many gtk apps. So without it i cant type Chinese in gedit etc.

So there must be a way to allow IME's to type in gtk apps without the segfault.

In fact one of our very own here on the Arch Forum chenxiaolong who is notable for his Arch Unity work, has posted what I think is a solution on another site. But I dont understand what to do.

https://github.com/chenxiaolong/Unity-for-Arch/issues/7

According to his post, this has soemthign to do with gtk and the path of gtk.immodules. I tried these things:

1. copying gtk.immodules to /usr/lib/gtk-2.0/2.10.0/, and then no export in bashrc. Result=no ime in gtk apps
2. Modifying the export path in bashrc to fit the path above. Result= segfaulting
3. replacing gtk2 with gtk2-ubuntu, no exporting. Result=no ime in gtk apps
4. replacing gtk2 with gtk2-ubuntu,  exporting in bashrc. Result=segfaultin

In the link he's saying something about a patch that gets gtk to recognize the new path but I am unsure of how to utilize this info.

Any help would be much appreciated.

Thank you.

Last edited by endor43 (2012-12-13 02:28:22)

Offline

Board footer

Powered by FluxBB