You are not logged in.

#1 2012-12-09 01:56:59

Silvo
Member
Registered: 2011-12-18
Posts: 10

Twinview xorg.conf help

Hi,

I'm having trouble setting up my monitors for twinview. I've got a difficult monitor (a hi-res no-name brand, Yamakasi Catleap Q270) that doesn't want to play nice, and a normal lower-res LG monitor. I'm trying to get them working with twinview on my Nvidia card.

The Catleap has some configuration difficulties, in that it does not get set up correctly automatically. I have to manually edit xorg.conf, following instructions given here: http://ubuntuforums.org/showpost.php?p= … ostcount=4 otherwise it just shows a black screen.

I think those changes are causing a problem with my LG, specifically, the line:

Modeline "2560x1440" 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync

This allows the Catleap to work at its native resolution (2560x1440), but seems to prevent the LG from being detected/setup correctly; specifically, nvidia-settings usually lets me pick from a whole bunch of different resolutions for it, right up to its native size of 1680x1050, but when this line is included, the only options for it become auto (which gives 800x600) and 2560x1440, which is too high and results in a black screen on the LG instead. Just to be clear, that line is included in the Monitor section of the xorg.conf file for the Catleap, not the LG.

I have working xorg.conf files for each monitor individually, LG and Catleap, and here is my attempt at combining them with twinview. Note especially line 41 of the latter file:

Option         "metamodes" "DFP-0: 2560x1440_60 +0 +0, DFP-1: 1680x1050 +2560+0"

which sets each monitor to its correct resolution, but does not seem to work for the LG, which instead gets disabled.

I think what is needed to fix this is some sort of config option for the LG that specifies what resolutions it can handle, but my xorg skills are pretty terrible so I don't know how to fix this.

I've tried using nvidia-xconfig and nvidia-settings, to no avail. They can't handle the Catleap unless I add in that Modeline, and doing so wrecks the LG.

If you have any ideas what to do, your help is greatly appreciated.

Thank you!

Offline

#2 2012-12-14 23:35:18

Silvo
Member
Registered: 2011-12-18
Posts: 10

Re: Twinview xorg.conf help

I should also add that I've tried setting them up with separate X session, which also does not work (both screens go black).

Offline

#3 2012-12-14 23:48:16

Gusar
Member
Registered: 2009-08-25
Posts: 3,399

Re: Twinview xorg.conf help

Try this, it's the xrandr1.2 way of doing things, but theoretically the nvidia driver should be able to understand it (one day I really should test if the theory works in practice smile):

Section "Monitor"
    Identifier  "DVI-0"
    Modeline    "2560x1440" 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync
    Option      "PreferredMode" "2560x1440"
    Option      "Primary" "true"
EndSection

Section "Monitor"
    Identifier  "DVI-1"
    Option      "RightOf" "DVI-0"
EndSection

This assumes Catleap is DVI-0, and LG is DVI-1. Adjust the identifiers accordingly if that's not the case (Xorg.0.log should give you the names).

Offline

#4 2012-12-15 00:36:42

Silvo
Member
Registered: 2011-12-18
Posts: 10

Re: Twinview xorg.conf help

Thanks for your help! But unfortunately, that didn't work. The Catleap went black, I think because those extra lines I need have not been added (the Modeline line).

When I looked through Xorg.0.log I did see this:

[  2921.758] (**) NVIDIA(0): Option "UseEdidFreqs" "False"
[...]
[  2921.758] (**) NVIDIA(0): Option "UseEdidDpi" "False"
[  2921.758] (**) NVIDIA(0): Option "UseEDID" "False"
[...]
[  2921.758] (**) NVIDIA(0): Ignoring EDIDs
[  2922.558] (II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
[  2922.591] (II) NVIDIA(GPU-0): Not probing EDID on DFP-1.

(I changed DVI- to DFP- in your example)

I think this means it's ignoring EDID for both monitors, rather than just for the Catleap (the Catleap EDID is the problem I believe, I think disabling it is what makes the monitor work) which might be why the LG's resolution is not set properly. I then tried to put those lines in each monitor's section, enabling EDID for the LG but disabling it for the Catleap:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Shimian"
    ModelName      "QHD270"
    HorizSync      88.8
    VertRefresh    59.5
    Option         "DPMS"
    Option         "UseEDID" "False"
    Option         "UseEDIDDPI" "False"
    Option         "UseEDIDFreqs" "False"
    Modeline       "2560x1440" 241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
    DisplaySize    597 336
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2252"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "UseEDID" "True"
    Option         "UseEDIDDPI" "True"
    Option         "UseEDIDFreqs" "True"
    Option         "DPMS"
EndSection

But the same thing happened in the Xorg log. Is there some way I can turn EDID on for the LG but off for the Catleap?

Offline

#5 2012-12-15 01:06:44

Gusar
Member
Registered: 2009-08-25
Posts: 3,399

Re: Twinview xorg.conf help

My config doesn't specify any edid options, so it's impossible to get that log if you used it. Use exactly the config I gave, and try to figure out what DVI names your displays have, because I don't know if xrandr understands the Nvidia DFP- names.

Offline

#6 2012-12-15 04:30:07

Silvo
Member
Registered: 2011-12-18
Posts: 10

Re: Twinview xorg.conf help

You're quite right. I deleted the log and tried again, and that EDID stuff didn't appear, so I don't know what happened last time I tried. I tried it with both DFP- and DVI-. How would I find out the DVI equivalents? I just assumed that DVI-0 refers to DFP-0 and same for -1, but perhaps that may not be the case? And as far as xrandr is concerned, do I need to do anything special? It is installed, but i'm not sure how to get xorg to use it instead of nvidia.

Offline

#7 2013-02-22 05:08:44

xadin
Member
Registered: 2012-09-28
Posts: 1

Re: Twinview xorg.conf help

I am having the exact same problem as you described in the first post but have yet to find a solution. Did you have any luck?

Offline

#8 2013-02-22 05:19:06

Silvo
Member
Registered: 2011-12-18
Posts: 10

Re: Twinview xorg.conf help

I managed to solve my problem, albeit in a very long and complicated way. I had to create an EDID file for my smaller LG monitor manually using Windows, and I used an EDID file for the Catleap that I found off the net.

I helped someone out on the Ubuntu forums and stepped him through what I did. It might help you too: http://ubuntuforums.org/showthread.php?t=2038997&page=2 starting from post #15.

Good luck!

Offline

Board footer

Powered by FluxBB