You are not logged in.

#1 2012-12-17 19:13:00

beardedlinuxgeek
Member
Registered: 2012-09-17
Posts: 25
Website

JavaFX broken after JDK 7.10 update. AUR version updated prematurely?

JavaFX never worked correctly with OpenJDK with Icedtea so I used the JDK 7.9 from the AUR. After the latest update from JDK 7.9 to 7.10, I noticed JavaFX applications were no longer working in firefox or chrome (browser plugins were clearly updated, path variables set, restarted, ect).

When you go to launch a JavaFX demo from Oracle they send you to the Java download page (http://java.com/en/download/manual.jsp? … cale=en_US) where is says "Recommended Version 7 Update 9." This makes me think the AUR version of the JDK was updated to 7.10 prematurely. Just because 7.10 is the latest version for Windows, doesn't mean it's the latest version for Linux.

Does someone running the JDK from the AUR mind checking these Oracle JavaFX samples (http://www.oracle.com/technetwork/java/ … index.html) to see if they run correctly?

Offline

#2 2012-12-18 00:30:48

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,577
Website

Re: JavaFX broken after JDK 7.10 update. AUR version updated prematurely?

The Ensemble one doesn't work for me, but the second one -- with the charts -- does.


Matt

"It is very difficult to educate the educated."

Offline

#3 2012-12-18 02:47:36

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: JavaFX broken after JDK 7.10 update. AUR version updated prematurely?

The Java download site now "recommends" Update 10, so that was probably just a little slow to change.

Offline

#4 2012-12-27 21:05:03

greengold
Member
Registered: 2010-01-30
Posts: 186

Re: JavaFX broken after JDK 7.10 update. AUR version updated prematurely?

I have installed jdk7-openjdk but it seems Im missing javaFx SDK. Is it included? Is there some post configuration that should allow NetBeans to work with javaFx?

Offline

Board footer

Powered by FluxBB