You are not logged in.

#1 2012-12-17 22:45:32

alexduf
Member
Registered: 2012-12-16
Posts: 14

Flash lags on fullscreen with intel HD4000

Hello !

I just bought a lenovo X1 carbon, and I'm having issues on video playback. It's working great with totem, but as soon as I try to read a video on youtube (with flash) the video lags.
It only lags in fullscreen, not in window view.

Here are some random info that may be usefull :
I'm using gnome-shell
xf86-video-intel is installed

[alex@calculon ~]$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
[alex@calculon ~]$ glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_multisample, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_OML_swap_method, 
    GLX_SGI_swap_control, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_INTEL_swap_event
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_create_context_robustness, GLX_ARB_get_proc_address, 
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_create_context_es2_profile, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control, 
    GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap, GLX_INTEL_swap_event
[alex@calculon ~]$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
EndSection

any idea ? that would begreat smile

Offline

#2 2012-12-18 15:51:04

xpixelz
Member
From: Tunisia
Registered: 2012-02-29
Posts: 47
Website

Re: Flash lags on fullscreen with intel HD4000

Do you experience same lagging on youtube when using google-chrome?

Offline

#3 2012-12-18 16:24:37

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: Flash lags on fullscreen with intel HD4000

In /etc/adobe/mms.conf you should have OverrideGPUValidation=true

Though I've read this supposedly doesn't work in the newest flash versions anymore, but I have no lags here on Ironlake (Intel HD graphics).

Offline

#4 2012-12-18 21:04:50

alexduf
Member
Registered: 2012-12-16
Posts: 14

Re: Flash lags on fullscreen with intel HD4000

Gusar : I just tested all combinations possible with OverrideGPUValidation and EnableLinuxHWVideoDecode, but it's still lagging

xpixelz : I Tried with google-chrome from AUR, and yes it works finely ! What is the difference between the google embedded plugin and the system's one that firefox uses ?

[edit]BTW, thanks for your answers big_smile [/edit]

Last edited by alexduf (2012-12-18 21:05:23)

Offline

#5 2012-12-19 02:18:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: Flash lags on fullscreen with intel HD4000

alexduf wrote:

What is the difference between the google embedded plugin and the system's one that firefox uses ?

I think Google uses pepper, not flashplugin.
http://en.wikipedia.org/wiki/Google_Nat … ent#Pepper

Offline

#6 2012-12-19 08:41:59

xpixelz
Member
From: Tunisia
Registered: 2012-02-29
Posts: 47
Website

Re: Flash lags on fullscreen with intel HD4000

I can't tell the difference but I find animations, heavy javascript-ing and videos smoother under google-chrome anyway smile

Offline

#7 2012-12-19 21:26:45

alexduf
Member
Registered: 2012-12-16
Posts: 14

Re: Flash lags on fullscreen with intel HD4000

Okay, so as far as I understand it, Firefox and Chrome use a different connector, but my gut tells me that the problem reside between flash and my graphic card, so I'll keep searching.
(I must not be the only one with Firefox on an HD4000 trying to play a flash video)

If I find something I'll post it here !

Offline

#8 2012-12-19 21:36:09

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: Flash lags on fullscreen with intel HD4000

Offline

#9 2012-12-19 22:46:22

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: Flash lags on fullscreen with intel HD4000

There's no gallium driver for HD4000. Only for i915/i945.

Offline

#10 2012-12-20 09:08:10

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,432

Re: Flash lags on fullscreen with intel HD4000

Ops, sorry.
Still, maybe using flash 10 would help with firefox.

Offline

#11 2012-12-20 10:10:54

alexduf
Member
Registered: 2012-12-16
Posts: 14

Re: Flash lags on fullscreen with intel HD4000

But still, now I know that Flash 10 could work. (even if it's an old version).
And that explain why OverrideGPUValidation had no effect when I was modifying it !

Offline

Board footer

Powered by FluxBB