You are not logged in.

#1 2012-10-25 07:53:12

From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

KDE: NTP Configuration


I've got NTP configured according to wiki.
My /etc/ntp.conf:

# With the default settings below, ntpd will only synchronize your clock.
# For details, see:
# - the ntp.conf man page
# -
# - … col_daemon

# Associate to public NTP pool servers; see

# Only allow read-only access from localhost
restrict default noquery nopeer
restrict ::1

# Location of drift and log files
driftfile /var/lib/ntp/ntp.drift
logfile /var/log/ntp.log

# NOTE: If you run dhcpcd and have lines like 'restrict' and 'fudge' appearing
# here, be sure to add '-Y -N' to the dhcpcd_ethX variables in /etc/conf.d/net

It apparently works:

$ ntpq -np
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================     3 u   46   64    1   47.672   -1.318   0.000      2 u   47   64    1   41.993   -0.320   0.000  .GPS.            1 u   48   64    1   98.900    0.403   0.000   2 u   48   64    1   50.181    8.957   0.000
$ date
Thu Oct 25 11:36:24 MSK 2012

I can't convince KDE Configure Date and Time Settings to take the setting, though. Before I started the NTP service the Set date and time automatically checkbox used to be grayed out, which makes sense. It recognizes my time zone (Europe/Moscow (MMT)), but I can't apply the settings:

Unable to connect to time server:

Where is the catch? KDE taskbar clock keeps on showing, say, 07:36 AM UTC; even the Adjust Date and Time... dialog itself shows the right time!

Last edited by Llama (2012-10-25 07:58:43)


#2 2012-12-22 04:05:27

Registered: 2005-08-14
Posts: 30

Re: KDE: NTP Configuration

I just ran into this problem on my system.  At least for me, it looks like KDE does not cooperate with a running ntpd. See:

Disabling ntpd with "systemctl disable ntpd" got rid of my errors.  I assume KDE sporadically updates the time, so I am assuming running the daemon in the background is unnecessary.


#3 2012-12-22 04:39:54

Registered: 2009-07-28
Posts: 25

Re: KDE: NTP Configuration

Which version of KDE are you running? I have got ntpd up and running und I do not have any problems with kde time settings. In fact, iirc, I had to fire up ntpd to make it work (but I'm not sure, has been some time). Greying out can also mean that there some rights issues... have you tried running systemsettings with sudo?

Oh btw: if time and date shows the correct time, but clock doesn't, it's often because the clock isn't updated instantaneously. Wait a bit or remove and add the clock again


Board footer

Powered by FluxBB