You are not logged in.

#1 2012-12-20 13:07:27

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 150

[Solved]Problem changing default SAVE path in LibreOffice

I am having problem changing the default save path in LibreOffice Version 3.6.4.3 (Build ID: 3.6.4.3 Arch Linux build-1).

I have a separate DATA-ext4 partiton and I don't use /home. I just change the default save paths in the respective applications to save in my /run/media/Data partition/folder. My Data partition is not auto-mounted at boot, I mount it manually after entering my user password. Also I don't have it entered it my /etc/fstab.

And this is a common, shared partiton between Arch and Ubuntu.  I have no issues in Ubuntu-Quantal. Arch-Libreoffice however is not letting me change the default save path. I  use Libreoffice>Tools>options>LibreOffice>Paths>My Documents/ default save path-  to set my default save folder. (I have recently Fresh installed my Arch-64-gnome. I did not have this issue before with my previous Arch).

I can change and set default save paths in other applications, however. For instance, 'Uget' saves all my downloads in /run/media/Data Partition/ My Downloads.

I request the forum to guide me to a proper solution and help me change the default save path in Libreoffice.

Thanks...

Last edited by fantab (2012-12-25 08:13:33)


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#2 2012-12-21 14:38:07

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 150

Re: [Solved]Problem changing default SAVE path in LibreOffice

Can someone PLEASE check with your copy of Libreoffice 3.6.4.3 and see if you can change the default save path? Try changing it to, for instance, /home/user/pictures.  I have just updated Libreoffice to 3.6.4.3 build-2 and the problem persists. I suspect its a bug but just want to make sure if this issue affects multiple users.

Also, if its a bug where can I file a bug report?

Thanks...


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#3 2012-12-21 15:15:17

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,119

Re: [Solved]Problem changing default SAVE path in LibreOffice

Nope, no problem here but I did notice if I just typed in the path and then selected it, it didn't work.  I had to chose the folder from the folder selection below--like a file manager--and then select it and it stuck.  If you think that's a bug read here:  https://wiki.archlinux.org/index.php/Re … Guidelines


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#4 2012-12-23 08:53:33

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 150

Re: [Solved]Problem changing default SAVE path in LibreOffice

Thanks bgc1954 for the confirmation. However, more confirmations will be very helpfulf, especially from those who have installed ARCH from November install media (full systemd) because I have done so and as such I have not carried forward any pervious .config files. It may not be nothing but its my hunch.

I have uninstalled Libreoffice, deleted ~/.config/libreoffice and reinstalled LO all over again but the issue with default/save/path (/home/user/Documents) continues... I am unable to change it any other folder but the default and to  /home/user.

I am able to save whereever I want while saving the document from within the application, however.

Also I am not really sure if its a bug or some thing at my end.  (I hope I am being clear enough in describing my issue).

Any guidance from the forum will be much appreciated..


Thanks...


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#5 2012-12-23 13:11:58

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: [Solved]Problem changing default SAVE path in LibreOffice

I cannot change the default save path either.  My default path comes up as my user's $HOME.

I suspected ~/.config/user-dirs.dirs was the configuration file causing the problem; see https://wiki.archlinux.org/index.php/Xd … irectories.  I have this line in my user-dirs.dirs:

XDG_DOCUMENTS_DIR="$HOME"

After each step, I logged out and then logged back in:

  • Removing ~/.config/libreoffice did not work.

  • Removing ~/.config/libreoffice and ~/.config/user-dirs.dirs did not work.

  • Removing ~/.config/libreoffice, ~/.config/user-dirs.dirs, removing and reinstalling Libreoffice did not work.

  • Creating a ~/Documents directory and removing ~/.config/libreoffice, ~/.config/user-dirs.dirs and reinstalling Libreoffice did not work.

  • Creating a ~/My\ Documents directory and removing ~/.config/libreoffice, ~/.config/user-dirs.dirs and reinstalling Libreoffice did not work.

I'm using Openbox as a WM, no DE.  I started LibreOffice with either '/usr/bin/soffice --calc' or '/usr/bin/soffice --writer' from my Openbox menu.  From there, I would attempt to change the default through the 'Tools > Options' dialog box.  I also am using jre7-openjdk and the Libreoffice extensions pdfimport and presentation-minimizer.

Offline

#6 2012-12-23 15:03:52

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,167

Re: [Solved]Problem changing default SAVE path in LibreOffice

No problem changing save path here , but i am not using gnome.
xdg-user-dirs is not installed on my system, and there's no ~/.config/user-dirs.dirs present.

apart from the user-specific ~/.config/user-dirs.dirs there's also /etc/xdg/user-dirs.defaults (neither are present on my system) .

Try removing xdg-user-dirs to verify that is causing the problem.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2012-12-24 00:20:25

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: [Solved]Problem changing default SAVE path in LibreOffice

OK, I am now able to change the default 'My Documents' path.

I removed java and Libreoffice once again.  Instead of the overloaded Libreoffice group, I only installed what I need.  Libreoffice no longer has my gtk theme, but everything I need works .

I found that I am not able to change the default save directory when these packages are installed:

libreoffice-base
libreoffice-draw
libreoffice-gnome
libreoffice-kde4
libreoffice-postgresql-connector
jre7-openjdk-headless
jre7-openjdk
jdk7-openjdk
ca-certificates-java
hsqldb-java
libreoffice-sdk
libreoffice-sdk-doc

I won't be able to test which of these is the guilty package until next Saturday, maybe.

Offline

#8 2012-12-24 14:35:15

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: [Solved]Problem changing default SAVE path in LibreOffice

I found some time to explore further.

I removed libreoffice and java completely with 'pacman -Rs' and removed ~/.config/libreoffice.  I reinstalled what I needed with no plugins using:

pacman -S libreoffice-{common,en-US,calc,gnome,impress,math,writer}

Libreoffice is back to my basic setup sans plugins and with my gtk theme used.

But from the "Tools > Options > Paths" option, I was unable to change the "My Documents" directory.  It will bring up a gtk file-selection window, but no selection has any effect.

Removing libreoffice-gnome cures this.  It made no difference whether xdg-utils was installed or not ('pacman -Rdd xdg-utils').

Note: I do not have a lot of the Gnome utility programs or libraries installed.  I have not installed: gnome-vfs, gvfs, libbonobo, libgnome-data,  libsecret, udisks2, or libgnome.

Last edited by thisoldman (2012-12-24 14:35:35)

Offline

#9 2012-12-25 05:15:38

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 150

Re: [Solved]Problem changing default SAVE path in LibreOffice

Thanks a lot thisoldman for taking the time to explore. You've nailed the problem. The issue does lie with 'libreoffice-gnome-3.6.4-3'.

Taking the cue from your post I removed 'libreoffice-gnome' and ~/.config/libreoffice. As a consequence I lost my gtk-theme on Libreoffice and instead got an 'ugly' looking LO-writer. I then SUCCESSFULLY changed the Default Save Path to my liking. Then I reinstalled 'libreoffice-gnome-3.6.4-3'. I not only got my gtk-theme working on LO but the CHANGED default save path stuck. smile
I only hope it survives reboots. It survives

So, clearly the problem lies with 'libreoffice-gnome-3.6.4-3' package. I will check this libreoffice-gnome-3.6.4-3 with a couple other distros and decide if this issue shoud be reported to Upstream or to Arch.

Thanks again.
Merry Christmas...

EDIT: I checked with Ubuntu 12.10. Since its has libreoffice-gnome 3.6.2 it wasn't much help. I will check Fedora and confirm later.

Last edited by fantab (2012-12-25 08:13:06)


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#10 2013-02-01 08:06:14

enumaelis
Member
Registered: 2013-02-01
Posts: 9

Re: [Solved]Problem changing default SAVE path in LibreOffice

fantab wrote:

So, clearly the problem lies with 'libreoffice-gnome-3.6.4-3' package. I will check this libreoffice-gnome-3.6.4-3 with a couple other distros and decide if this issue shoud be reported to Upstream or to Arch.

Thanks again.
Merry Christmas...

EDIT: I checked with Ubuntu 12.10. Since its has libreoffice-gnome 3.6.2 it wasn't much help. I will check Fedora and confirm later.

I can confirm that the problem is libreoffice-gnome and persists also in libreoffice 3.6.5.2 in archlinux. Simply removing libreoffice-gnome, setting the Document's path (or whatever path you need to set) and then reinstalling libreoffice-gnome does the job.
This is confirmed also by the fact that if  you try to set the path again after you modified it and libreoffice-gnome is already reinstalled, your Document's path will be set to your home again.

EnumaElis

Last edited by enumaelis (2013-02-01 08:07:38)

Offline

#11 2013-02-01 08:54:46

demaio
Member
From: Germany
Registered: 2012-09-02
Posts: 62
Website

Re: [Solved]Problem changing default SAVE path in LibreOffice

Upstream bug report: https://www.libreoffice.org/bugzilla/sh … i?id=55323

There is a workaround even if libreoffice-gnome is installed (so at least the GTK theme can be used): LibreOffice => General -> Open/Save dialogs -> [X] Use LibreOffice dialogs

Offline

Board footer

Powered by FluxBB