You are not logged in.

#1 2012-11-15 07:26:58

vkumar
Member
Registered: 2008-10-06
Posts: 166

Latest update to autojump causes some problems

After updating autojump today (1), zsh complains that "autojump.zsh" cannot be found, the "j" command seems to have disappeared from my system, and the "autojump" program no longer cd's into directories.

I searched my disk for "autojump.zsh", but found that it had disappeared. So I'm sourcing "/usr/etc/profile.d/autojump.sh" in my .zshrc as an alternative. I also aliased "j" to "autojump". This makes the errors go away, but when I run "j <foo>", autojump merely prints out the name of the directory it should cd to instead of actually cd'ing there.

Any tips :-)?

(1) [2012-11-14 16:13] upgraded autojump (20-2 -> 21.0.3-1)


div curl F = 0

Offline

#2 2012-11-15 11:12:11

macioosch
Member
From: Netherlands
Registered: 2011-08-14
Posts: 2

Re: Latest update to autojump causes some problems

I have same issue with bash.

AFAIK autojump is enabled by sourcing /usr/etc/profile.d/autojump.sh - this script then tries to source:
~/.autojump/etc/profile.d/autojump.bash or /etc/profile.d/autojump.bash
or if you use zsh:
~/.autojump/etc/profile.d/autojump.zsh or /etc/profile.d/autojump.zsh

On my pc the .bash file autojump is looking for is in: /usr/etc/profile.d/autojump.bash

So I think that either "/usr" should be added to paths in /usr/etc/profile.d/autojump.sh, or autojump's files should be moved from /usr/etc/profile.d/ to /etc/profile.d/.

The second option seems much more likely for me, because only files I have in /usr/etc/ are autojump's files - it probably is a bug.

edit: it's already reported: https://bugs.archlinux.org/task/32669

Last edited by macioosch (2012-11-15 11:18:25)

Offline

#3 2012-12-24 11:04:40

daGrevis
Member
From: Riga, Latvia
Registered: 2011-10-16
Posts: 81
Website

Re: Latest update to autojump causes some problems

Are there any plans to fix it? I'm using 20-2 and running `-Syu --ignore autojump` to upgrade.

Should I use autojump-git from AUR? Will it work then (that means that on GitHub it's fixed and Arch hasn't upgraded it's packages, why)?

Can I tell pacman to always ignore autojump and use current version as it is forever?

Offline

#4 2012-12-24 11:53:26

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,317

Re: Latest update to autojump causes some problems

daGrevis wrote:

Can I tell pacman to always ignore autojump and use current version as it is forever?

You can do that by using the IgnorePKg option of pacman.conf , check it's manpage for details.
using this however means you will be doing partial upgrades forever, so i'd use it as a TEMPORARY workaround.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2012-12-24 12:04:43

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

Re: Latest update to autojump causes some problems

autojump has been fixed upstream for a little while now, not sure why the package hasn't been updated. Anyhow, you can either use autojump-git from the AUR, or just make a PKGBUILD for yourself (e.g. I use this one).

Offline

#6 2012-12-24 22:28:36

daGrevis
Member
From: Riga, Latvia
Registered: 2011-10-16
Posts: 81
Website

Re: Latest update to autojump causes some problems

The problem w/ using packages from AUR is that it won't be upgraded automatically and I, as any other programmer, am lazy and will forget to upgrade it.

Offline

#7 2012-12-24 22:46:38

jjacky
Member
Registered: 2011-11-09
Posts: 321
Website

Re: Latest update to autojump causes some problems

Well, you could create a package yourself to get the latest version installed, but use the same name (autojump). That way once a new version will be out in the repo, the upgrade will happen as usual. Nothing to forget then.

Offline

Board footer

Powered by FluxBB