You are not logged in.

#1 2012-10-29 23:20:06

baldzhang
Member
Registered: 2004-04-10
Posts: 10

[SOLVED] XPS15z system hang up in 2/3 times

I have a Dell XPS 15z, running with Slackware 14.0 i486 & Archlinux x86_64

Slackware 14.0 working well, but Arch will hang when loading i915 module, about only one time success in three booting.
I had read wiki, and try acpi=noirq, pcie_aspm=force, no any change

finally, I re-compile kernel 2.6.3 with slackware's config file, then everything is working well until now.

So, is there any BIG different between Arch's config and Slackware's ?

__________________________________________________________________________________________________________________


for Archlinux x86_64 run on a XPS 15z

1) add "nox2apic" kernel parameter to avoid booting hang, this is caused by CONFIG_X86_X2APIC=y in kernel config.

2) add "acpi=noirq" parameter to make sure cpufreq working, this is removed in wiki page but still need in my system.

hope this is helpful for others.

Last edited by baldzhang (2012-11-10 19:32:25)

Offline

#2 2012-10-30 13:58:21

vitor
Member
Registered: 2010-11-29
Posts: 16

Re: [SOLVED] XPS15z system hang up in 2/3 times

I'm having this same problem. Your trackpad works? What do you use in the kernel line?

Offline

#3 2012-10-30 19:19:08

baldzhang
Member
Registered: 2004-04-10
Posts: 10

Re: [SOLVED] XPS15z system hang up in 2/3 times

my trackpad worked as a normal mouse, edge scroll is ok, but NO two-finger actions support

the kernel line is

[root@arch-x86_64 ~]# cat /proc/cmdline 
root=/dev/sda6 ro BOOT_IMAGE=/3.6.3-15z.64-1/bzImage 

novueau module also loaded, and can do echo OFF > /sys/kernel/debug/vgaswitcheroo/switch, but i never test Bumblebee

Offline

#4 2012-11-03 00:57:38

baldzhang
Member
Registered: 2004-04-10
Posts: 10

Re: [SOLVED] XPS15z system hang up in 2/3 times

after today's pacman -Syu, kernel 3.6.5 still hang in one boot sad
3.6.3 with slackware config working well until now though...

I build my kernel with vanilla kernel source and slackware x86_64 config for 3.6.0-rc4 from their testing,
remove some unused modules, add ext3 to vmlinuz to avoid an initramfs.

already do some compare between the config files, but no idea what cause this different.
If someone intresting with this, I can provide the kernel config file.

BTW another problem with arch kernel is after the screen blank, the system is hang in 1/3 boot success... in console mode, no X.

Offline

#5 2012-11-07 00:50:50

baldzhang
Member
Registered: 2004-04-10
Posts: 10

Re: [SOLVED] XPS15z system hang up in 2/3 times

get angry... mad

compare the config files and re-compile the kernel for 12 times, finally found the problem...
it's CONFIG_X86_X2APIC, if this option disabled, then the world goto peace.

check kernel parameters and found "nox2apic", add this to kernel cmdline and boot a Arch stocked kernel(3.6.6-1-ARCH), success in twice.

some other informations:

[Kernel:HEAD:ACPI] Dell XPS 15z needs "nox2apic" to boot
https://bugzilla.novell.com/show_bug.cgi?id=758166

slackware's config without this, should Arch remove this ???

Offline

#6 2012-12-25 11:04:31

grimpy
Member
Registered: 2012-10-14
Posts: 4

Re: [SOLVED] XPS15z system hang up in 2/3 times

Thanks man i've been suffering with this problem since a long while now adding the kernel parameter helped!
I've added this to the wiki page https://wiki.archlinux.org/index.php/De … gs_on_boot

Offline

Board footer

Powered by FluxBB