You are not logged in.

#1 2012-12-25 04:08:45

Narga
Member
From: Hải Phòng, Việt Nam
Registered: 2011-10-06
Posts: 56
Website

Ethernet not dectect link, despite NIC link light

My ethernet card is:

# ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  Not reported
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pg
	Wake-on: d
	Current message level: 0x0000003f (63)
			       drv probe link timer ifdown ifup
	Link detected: no

Sometime, when I plug the link, it's not detect the LAN has been linked despite NIC link light. I must reboot the system to reenable it.

# dhcpcd eth0 
dhcpcd[15257]: version 5.6.3 starting
dhcpcd[15257]: eth0: waiting for carrier

I've tried restart Networkmanager and Dbus services but it't not detect the link.
can you help me how to fix it?

Offline

#2 2012-12-25 11:23:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,166

Re: Ethernet not dectect link, despite NIC link light

could be a driver problem, please post the output of

$ lspci -k

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2012-12-25 14:48:10

Narga
Member
From: Hải Phòng, Việt Nam
Registered: 2011-10-06
Posts: 56
Website

Re: Ethernet not dectect link, despite NIC link light

Here is mine

lspci -k
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 0260
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: uhci_hcd
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: uhci_hcd
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: ehci_hcd
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
	Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
	Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: lpc_ich
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: i801_smbus
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 0260
04:00.0 Network controller: Intel Corporation WiFi Link 5100
	Subsystem: Intel Corporation WiFi Link 5100 AGN
	Kernel driver in use: iwlwifi
05:00.0 Ethernet controller: Atheros Communications Inc. AR8131 Gigabit Ethernet (rev c0)
	Subsystem: Acer Incorporated [ALI] Device 0260
	Kernel driver in use: atl1c

Offline

#4 2012-12-26 07:30:41

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Ethernet not dectect link, despite NIC link light

Could be the cable

Owe also, try installing dhclient I find that sometimes it works and dhcpcd dose not, and sometimes the other way around.

Last edited by hunterthomson (2012-12-26 12:52:04)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#5 2012-12-26 13:08:01

Narga
Member
From: Hải Phòng, Việt Nam
Registered: 2011-10-06
Posts: 56
Website

Re: Ethernet not dectect link, despite NIC link light

If I still plug the cable then restart the system, it's working well. I guess the problem is driver or config because it's occured when arch linux upgrade to systemd

Offline

#6 2012-12-26 23:15:01

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,166

Re: Ethernet not dectect link, despite NIC link light

Narga, is this a dual-boot system that also has windows installed ?

next time you get the problem, do a lsmod |grep atl1c to check if the module for your card has been loaded.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2012-12-27 01:07:33

Narga
Member
From: Hải Phòng, Việt Nam
Registered: 2011-10-06
Posts: 56
Website

Re: Ethernet not dectect link, despite NIC link light

Yes, I', dual boot with Windows 8, when I got the problem, I've check the status of the ethernet card, it's tell me that the link is not detected and sometimes the system tell me the ethernet card has been turned off.
I turn off and on the Wake on Lan feature through windows but still happened again

Offline

#8 2012-12-27 14:00:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,166

Re: Ethernet not dectect link, despite NIC link light

Ok, in windows you'll have to check the low level driver settings.
They used to be accessible from device manager, select device > properties > details .
Look for the power related options, there's one of them that if enabled allows the computer to power down the network card when it's not in use.

With that option enabled, windows tells the pc to power down the network card when a shutdown/reboot is issued.
If you boot in windows again, the windows driver wakes up the network card.
Afaik as i know this is is a WINDOWS-ONLY setting, and linux doesn't support it at all.
So when you boot into linux, the network card is still powered down and not detected.
Disable that setting and you'll be fine.

Not all brands of network cards have that option, but realtek is one of them.
It's one of those things that to some is a bug, to others it's a feature.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB