You are not logged in.

#1 2012-12-27 12:36:46

89c51
Member
Registered: 2012-06-05
Posts: 648

[Solved]Enlightenment E17 questions.

Installed it today -on actual HW- and have a couple of questions.

1) The cursor in Firefox changes from the E17 cursor to X generic. Is there a way to fix this?

2) The mixer module doesnt seem to work. Right click on the speaker icon >>Mixer >> settings >> Any action kills the desktop. It also doesn't change the volume from the sliders (click on it) but if i launch the mixer the master channel volume works flawlessly.

3) Is there a way to make the startup applications start on a specific workspace?


Thanks in advance.

Last edited by 89c51 (2013-01-01 13:30:29)

Offline

#2 2012-12-27 13:46:37

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Also is there a way to lock the screen after it blanks?

Offline

#3 2012-12-27 14:20:18

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [Solved]Enlightenment E17 questions.

1. I am not sure about your mouse problem

2. The new update for some reason switches the channel. You will have to click on the speaker icon at the bottom and go into settings and change it to the front speaker, also make sure the lock sliders is checked.

3. I have not found a way to do this, but you can have different launchers start on each desktop here are two resources for more tweaks

http://pclosmag.com/html/Issues/201012/page10.html

http://www.bodhilinux.com/e17guide/e17g … ktops.html

I have been using e17 for almost 6 months now. it takes some tweaking to make it feel like a solid desktop, but I believe that e17 is a solid desktop. It is fast and easy to use.


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#4 2012-12-27 14:22:40

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [Solved]Enlightenment E17 questions.

Haha, I just noticed the firefox cursor does change. That is most likely a bug. I use chromium for everything, since it plays flash without problem.  And the cursor does not change with it. smile


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#5 2012-12-27 14:38:30

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Its impossible to change anything in the Mixer Settings if i select something and click apply it takes the whole E down.

QCoPds.png


I use pulseaudio.

I had gnome installed so could it be something from there affecting it?

Last edited by 89c51 (2012-12-27 14:40:20)

Offline

#6 2012-12-27 14:41:35

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,700
Website

Re: [Solved]Enlightenment E17 questions.

Firefox likely sets the cursor to "None" which uses the root window cursor.  Most WMs will use or set the root window cursor, but it sounds like E17 doesn't.  You can add an xsetroot command to your xinitrc or other startup file to set a good default cursor (which firefox will then use).  Try the following:

xsetroot -cursor_name left_ptr

InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#7 2012-12-27 15:05:12

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [Solved]Enlightenment E17 questions.

@89c51
Don't right click, left click then you will see a wrench at the bottom of the slider window.

Last edited by mich04 (2012-12-27 15:06:06)


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#8 2012-12-27 15:24:47

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

mich04 wrote:

@89c51
Don't right click, left click then you will see a wrench at the bottom of the slider window.

From the wrench menu things are fine afaic tell. Volumes change etc. From the right click and when i use the mouse srollwheel nothing happens.

Offline

#9 2012-12-27 15:40:06

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [Solved]Enlightenment E17 questions.

when you are in the wrench menu, at least for me, you have to change the channel to front.


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#10 2012-12-27 16:02:39

metak
Member
Registered: 2009-09-27
Posts: 128

Re: [Solved]Enlightenment E17 questions.

3. When you're running certain program in certain workspace, chose from window menu "Remember" so that that the next time the program will be opened where it was closed.

Offline

#11 2012-12-27 16:16:09

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

metak wrote:

3. When you're running certain program in certain workspace, chose from window menu "Remember" so that that the next time the program will be opened where it was closed.

cool thanks

Offline

#12 2012-12-27 18:07:35

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Another question.

What package should i install to have video previews. It opens the preview but nothing happens. Also it shows no thumbnail.

The mixer thing seems to happen only to me. hmm

Offline

#13 2012-12-27 20:32:56

metak
Member
Registered: 2009-09-27
Posts: 128

Re: [Solved]Enlightenment E17 questions.

@89c51

I think 'ethumb' generates thumbnails and you'll need 'emotion' installed to get video previews. That works for me.

Offline

#14 2012-12-27 21:15:02

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

metak wrote:

@89c51

I think 'ethumb' generates thumbnails and you'll need 'emotion' installed to get video previews. That works for me.

ethumb and emotion are up to date and i don't get video thumbnails for neither .ogv nor .mp4. hmm

Also do you use pulseaudio?

Offline

#15 2012-12-27 21:37:48

metak
Member
Registered: 2009-09-27
Posts: 128

Re: [Solved]Enlightenment E17 questions.

No pulseaudio. I always had problems with it, so I use only alsa.
The only other thing that comes to my mind would be to check if you have installed 'evas_generic_loaders'.

Offline

#16 2012-12-27 21:49:11

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Yes i installed the evas loaders. I have thumbnails in pics but not on videos. hmm

I suspect that the version 3 of pulse is causing the mixer trouble but i don't think i can check for that.

Also has anyone noticed any failed logouts or shutdowns? It sometimes stops with a blank screen and a cursor and i have to move to a different tty to do anything with it.

Offline

#17 2012-12-27 22:01:29

metak
Member
Registered: 2009-09-27
Posts: 128

Re: [Solved]Enlightenment E17 questions.

I've installed gstreamer-0.1 and all other gstreamer plugins (base, good, bad, ugly,..) and than compiled whole enlightenment17-svn from aur.

Yes. I've had some issues when I used kdm to log into the e17. Disabling kdm and starting e17 from .xinitrc solved that.

Offline

#18 2012-12-27 22:45:45

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

metak wrote:

I've installed gstreamer-0.1 and all other gstreamer plugins (base, good, bad, ugly,..) and than compiled whole enlightenment17-svn from aur.

Yes. I've had some issues when I used kdm to log into the e17. Disabling kdm and starting e17 from .xinitrc solved that.

OK i see. Maybe the maintainer should add optional dependencies.

Offline

#19 2012-12-28 08:25:08

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,900

Re: [Solved]Enlightenment E17 questions.

89c51, you're right. I've updated the emotion-svn PKGBUILD, but you should probably open a feature request to get it into the main packages.

I haven't had any login/logout problems with KDM.

Online

#20 2012-12-28 09:18:58

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Scimmia wrote:

89c51, you're right. I've updated the emotion-svn PKGBUILD, but you should probably open a feature request to get it into the main packages.

I haven't had any login/logout problems with KDM.

I am not using svn stuff. Its up to the maintainer of the official package to add stuff.


And maybe add terminology in the official too. tongue

On the DM thing i use GDM and only had troubles on shutdowns and when i tried to logout. But it doesn't do it all the time. I ll have to test it a bit more.

Last edited by 89c51 (2012-12-28 09:22:13)

Offline

#21 2012-12-29 06:51:22

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

One more thing.

I cannot launch gparted. It displays a popup (pic).

uiXvt.png

Offline

#22 2012-12-29 07:35:35

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,900

Re: [Solved]Enlightenment E17 questions.

89c51, you need to have a polkit agent running. Most people will just use polkit-gnome and set it to run in your startup programs. The native EFL one, empower, seems to work as a backend agent, but is kind of hit or miss when graphical logins are needed.

If it still doesn't work, it could be the fault of your display manager. I don't think GDM has this issue, but I can't remember for sure. See my comment here: https://bugs.archlinux.org/task/26268

You can always just do gksu gparted and avoid the polkit issues altogether.

Last edited by Scimmia (2012-12-29 07:36:48)

Online

#23 2012-12-29 07:56:11

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Polkit.service is running and polkit gnome is installed. hmm

And it is ticked in the startup application menu (The gnome one). Am i missing something?

Offline

#24 2012-12-29 08:04:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,900

Re: [Solved]Enlightenment E17 questions.

Polkit-gnome has to be running in e17, the gnome menu doesn't mean anything. Go to the Startup Application under Apps in the settings panel and set PolicyKit Authentication Agent to run at startup.

Last edited by Scimmia (2012-12-29 08:08:24)

Online

#25 2012-12-29 08:23:34

89c51
Member
Registered: 2012-06-05
Posts: 648

Re: [Solved]Enlightenment E17 questions.

Thanks that fixed it smile


Now only the mixer thing remains neutral

Offline

Board footer

Powered by FluxBB