You are not logged in.

#1 2012-12-25 11:47:18

Chill
Member
Registered: 2012-09-15
Posts: 6

[SOLVED] Headphone out not working in W7 after installing Arch

Hello everyone,

The problem is that I can't use my headphones in Windows, I just plugin my headphones and no sound comes from it. But when using Arch, it all works.

I first installed Windows 7, and my headphone output was working perfectly fine. And after using Arch linux and then rebooting into Windows, no sound would come from it.

A have an Asus K53SV and this is the audio device:

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

The first thing would come to mind is that it would be a Windows problem, but I tried re-installing all the drivers etc. Clicked through all the screens I could find about muted headphones, but nothing worked.

It's a bit of a strange problem, but does anyone here have an idea? If there is more information needed just ask smile


Chill

Last edited by Chill (2012-12-29 10:27:48)

Offline

#2 2012-12-28 13:09:57

efz
Member
Registered: 2012-12-28
Posts: 3

Re: [SOLVED] Headphone out not working in W7 after installing Arch

Hello,

I'm facing the same problem here on 2 computers (Asus G53S and G53J) after an archlinux update yesterday.

Any help appreciated.

Last edited by efz (2012-12-28 13:19:52)

Offline

#3 2012-12-28 13:59:34

efz
Member
Registered: 2012-12-28
Posts: 3

Re: [SOLVED] Headphone out not working in W7 after installing Arch

Hey Chill,

I solved the problem which seemed to be related to pulseaudio.

You should try this :
nano /etc/pulse/client.conf

Uncomment the "autospawn" parameter and set it to "no", like this :
autospawn = no

Hope this will work for you too. If it does, please consider this thread as [SOLVED] wink

Cya

Last edited by efz (2012-12-28 14:01:06)

Offline

#4 2012-12-28 16:53:04

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: [SOLVED] Headphone out not working in W7 after installing Arch

If Linux is putting the soundcard in a configuration that the Windows driver doesn't expect, then this should clear it:

Unplug the computer's power, including removing a laptop's battery.

Not a good solution, but useful to test wink

Offline

#5 2012-12-29 10:26:40

Chill
Member
Registered: 2012-09-15
Posts: 6

Re: [SOLVED] Headphone out not working in W7 after installing Arch

Thanks for your solutions guys!

The battery solution works as a charm! I'm currently not using pulseaudio so that fix currently doesn't apply to me. Maybe I will setup pulse today, so I can use that more permanent solution.

Offline

#6 2013-01-09 00:17:50

conley
Member
Registered: 2013-01-09
Posts: 18

Re: [SOLVED] Headphone out not working in W7 after installing Arch

This is happening to me too. It may have been going on for a while because I haven't used Windows in quite some time. Anyway, is there any solution to this other than shutting down or removing the battery? Disabling autospawn didn't fix it for me.

Last edited by conley (2013-01-09 00:18:12)

Offline

#7 2013-01-22 09:14:46

efz
Member
Registered: 2012-12-28
Posts: 3

Re: [SOLVED] Headphone out not working in W7 after installing Arch

FYI, I did not fix the problem, it was just a coincidence since I rebooted without power cable...

Bad luck smile

Offline

#8 2015-03-29 09:50:35

sado1
Member
Registered: 2011-06-13
Posts: 3

Re: [SOLVED] Headphone out not working in W7 after installing Arch

This is quite an old topic, but to anyone that might be googling it: a simpler trick is to put your laptop to sleep while on Windows.

Offline

#9 2015-03-29 10:44:34

Chill
Member
Registered: 2012-09-15
Posts: 6

Re: [SOLVED] Headphone out not working in W7 after installing Arch

I've mode a simple script called: wreboot. Which unloads the kernel module for Intel audio. This makes the audio work in Windows.

rmmod -f snd_hda_intel
reboot

Offline

Board footer

Powered by FluxBB