You are not logged in.

#1 2012-12-25 00:04:23

bbm21
Member
Registered: 2012-12-24
Posts: 27

radeon hd 5470 problems

I cannot for the life on me get my graphics card working with proprietary drivers. I have the 5470hd on my laptop with switchable graphics with the onboard card. In am on 64bit, so I install catalyst-dkms and lib32-catalyst-utils. Then I run aticonfig --initial, and reboot and then try startx, it gets stuck on "loading extension glx" and I can't use CTRL-ALT-F2 to get to the command line. When I reboot, there is no /var/log/Xorg.0.log. when I first installed it (right after fresh installation) startx would completely fail, and the log would say I needed to turn off switchable graphics in the BIOS (which I can't do considering I'm on a laptop). I don't care about getting switchable graphics working, I just want my 5470 HD working. Thanks

Offline

#2 2012-12-29 03:32:52

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: radeon hd 5470 problems

Sorry but what do you mean by "switchable graphics"? I thought you might mean something like Optimus but then I'm not sure why being on a laptop is relevant.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2012-12-29 09:00:09

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: radeon hd 5470 problems

Hello,

I had the same problem. Uninstalling amd-ucode solved it for me.

pacman -Rs amd-ucode

Offline

Board footer

Powered by FluxBB