You are not logged in.

#1 2012-12-24 22:00:21

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 185

[Resolved] KVM disabled by bios, how to enable?

Hi all, wasn't sure where to put this since I believe it is more of a hardware issue than an Archlinux issue. I have been looking into KVM and following the wiki instructions but end up hitting a roadblock (KVM is disabled by bios). The command lscpu gives this line as part of the output: Virtualization: VT-x. Also the command grep -E "(vmx|svm)" --color=always /proc/cpuinfo gives some output as well, making me believe that my hardware does indeed support hardware virtualization.

If I enter sudo modprobe kvm_intel it gives the feedback: modprobe: ERROR: could not insert 'kvm_intel': Operation not supported. I am thinking I need to set it up the kernel to load at boot as it states here?

I've also went into my BIOS menu on boot, but can't find anything related to virtualization at all. I am running Arch on a Gateway LT3803h netbook with 2G of ram if that is relevent at all...

Last edited by felixculpa (2012-12-29 06:46:58)

Offline

#2 2012-12-27 03:16:47

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: [Resolved] KVM disabled by bios, how to enable?

What CPU do you have?

Yes, like every computer I have see had VT-x and VT-d disabled in BIOS by default. I really have no idea why they do that?

Go into BIOS settings and look around. It will in be there somewhere.


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#3 2012-12-27 16:43:27

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 185

Re: [Resolved] KVM disabled by bios, how to enable?

This is the output of lscpu:

Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 28
Stepping:              10
CPU MHz:               1000.000
BogoMIPS:              3326.89
Virtualization:        VT-x
L1d cache:             24K
L1i cache:             32K
L2 cache:              512K

...and this is what I get for grep -E "(vmx|svm)" --color=always /proc/cpuinfo

[32m[K24[m[K[36m[K:[m[Kflags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl [01;31m[Kvmx[m[K est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm tpr_shadow vnmi flexpriority
[32m[K54[m[K[36m[K:[m[Kflags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl [01;31m[Kvmx[m[K est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm tpr_shadow vnmi flexpriority
[32m[K84[m[K[36m[K:[m[Kflags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl [01;31m[Kvmx[m[K est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm tpr_shadow vnmi flexpriority
[32m[K114[m[K[36m[K:[m[Kflags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl [01;31m[Kvmx[m[K est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm tpr_shadow vnmi flexpriority

I believe the CPU is an Intel N570 with a GPU - GMA 3150, and if I had to guess...that is not good enough for virtualization? I flashed my BIOS to the latest version and there is still nothing that I can see that hints at virtualization, or any advanced options.

Offline

#4 2012-12-29 05:46:57

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 185

Re: [Resolved] KVM disabled by bios, how to enable?

Through research, I have discovered my netbook has a InsydeH20 Bios which means I have no option for advanced features such as virtualization. So I guess that limits my options, unless I install a new Bios completely, which I am not prepared to do. As such, I am marking this thread [Closed] I guess.

Offline

#5 2012-12-29 06:20:57

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,829
Website

Re: [Resolved] KVM disabled by bios, how to enable?

Please don't use [Closed] as, on FluxBB, it denotes a locked thread. It is sufficient to mark it Solved, or Resolved if you feel that the thread is done.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#6 2012-12-29 06:46:37

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 185

Re: [Resolved] KVM disabled by bios, how to enable?

jasonwryan wrote:

Please don't use [Closed] as, on FluxBB, it denotes a locked thread. It is sufficient to mark it Solved, or Resolved if you feel that the thread is done.

Alrighty. My bad.

Offline

Board footer

Powered by FluxBB