You are not logged in.

#1 2012-12-28 20:24:04

Potomac
Member
Registered: 2011-12-25
Posts: 343

[SOLVED] Unable to boot X after upgrading glibc in virtualbox

I use archlinux 32 bits under virtualbox 4.2.6

today I made a "pacman -Syu" ( I do system updates every day ), glibc was upgraded to 2.17-1 version, no error message were shown,

then I reboot, I can see systemd messages, then I see a black screen and then nothing, I can't go further, unable to login, unable to select a tty console, Slim ( my boot manager ) doesn't show, I see only a black screen,

do you know the solution to fix this problem ?

I don't understand why I have this problem, it seems that glibc could be the culprit

Last edited by Potomac (2012-12-28 23:16:38)

Offline

#2 2012-12-28 22:40:09

Potomac
Member
Registered: 2011-12-25
Posts: 343

Re: [SOLVED] Unable to boot X after upgrading glibc in virtualbox

I found the culprit :

virtualbox-guest-modules 4.2.6-3 and virtualbox-guest-utils 4.2.6-1, these packages seems to have a problem with glibc ( or something related to X ), that's why I have a black screen,

I disable the virtualbox modules in  /etc/modules-load.d/ and disable the virtualbox service with systemctl, then I can now start KDE,

if you use SLIM or KDM you have to do a "chroot" in order to disable the SLIM and KDM service, otherwise you will be trapped with the black screen on boot,

a bug report is open here :

https://bugs.archlinux.org/task/33229?p … &sort=desc

Last edited by Potomac (2012-12-28 23:17:03)

Offline

#3 2012-12-29 18:24:12

mityukov
Member
Registered: 2010-10-10
Posts: 66

Re: [SOLVED] Unable to boot X after upgrading glibc in virtualbox

I don't have virtualbox installed, but have the same symptoms, i.e., few systemd messages, then blackscreen..

Offline

#4 2012-12-29 20:46:27

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: [SOLVED] Unable to boot X after upgrading glibc in virtualbox

Since the culprits in this case were virtualbox related and since this thread is now marked [solved], I suggest you open a new thread and explain your issue there. But notice that nobody will be able to help you unless you can provide more information than you have here.

If the issue followed pacman -Syu what was updated (see pacman.log)? Did you see any errors and did you follow any directions in the output?

*What* messages do you see?

Please see the links in my signature for help asking informative questions which are likely to gain you both a warmer reception and more effective, quicker help.

Last edited by cfr (2012-12-29 20:47:44)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB