You are not logged in.

#1 2012-12-28 15:40:55

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Desktop won't start after latest update

After my most recent update, my gnome desktop no longer loads.  I'm running Arch in VirtualBox 4.2.6 on an OS X 10.7.5 host.  The latest guest additions are installed through the Arch repository.  The system boots just fine, but gnome won't launch.  The screen goes black and hangs, the resolution never changes either.  I'm using "~/.xinitrc:exec gnome-session" and 'startx' to launch gnome, rather than gdm.  The list of packages upgraded in the last update is here (http://pastie.org/5589541), the /var/log/Xorg.0.log output is here (http://pastie.org/5589544).  The dmesg output is here, if it helps (http://pastie.org/5589548).

Feel free to move this topic to "Applications & Desktop Environments" or tell me to repost it there, but I figured I'd start in "Newbie Corner" since I'm not yet an Arch power user.  Many thanks!

EDIT: replaced Pastebin links with a more reputable service.

Last edited by wideaperture (2012-12-28 17:31:50)

Offline

#2 2012-12-28 17:25:35

thehatusa
Member
From: DfG
Registered: 2010-01-19
Posts: 15

Re: Desktop won't start after latest update

Indeed, i have the same problem now after yesterday upgrade. I have a "real" arch instalation (not in an emulator). When i login in slim, the screen goes black (X never fails, only black screen) and send me again to the login screen (fact: i'm writing this from a tty using elinks, so i can log normally in tty). Don't know what's wrong or broken. I never use the -f option when i do "pacman -Syu".
Don't know how to paste my Xorg.0.log and mi .xinitrc in pastebin in console. Regards.

Offline

#3 2012-12-28 17:28:22

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

If you can put them online via FTP, I will be happy to put them up on pastie.org for you.

Offline

#4 2012-12-28 17:48:52

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,689

Re: Desktop won't start after latest update

thehatusa wrote:

Indeed, i have the same problem now after yesterday upgrade. I have a "real" arch instalation (not in an emulator). When i login in slim, the screen goes black (X never fails, only black screen) and send me again to the login screen (fact: i'm writing this from a tty using elinks, so i can log normally in tty). Don't know what's wrong or broken. I never use the -f option when i do "pacman -Syu".
Don't know how to paste my Xorg.0.log and mi .xinitrc in pastebin in console. Regards.

Install "wgetpaste" and use it to create paste links, then post the paste links from elinks (type them in by hand if you have to).

Offline

#5 2012-12-28 17:53:11

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

This has something to do with the glibc, gcc, gcc-libs and binutils update. My X wouldn't start:

Fatal server error:
[  2131.165] xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[  2131.166] 
[  2131.166] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  2131.166] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2131.166] (EE) 
[  2131.166] (EE) 
[  2131.166] (EE) Backtrace:
[  2131.167] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81e4a89]
[  2131.167] (EE) 1: /usr/bin/X (0x8048000+0x1a0976) [0x81e8976]
[  2131.167] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb775140c]
[  2131.167] (EE) 3: ?? [0x9abf75b]
[  2131.167] (EE) 
[  2131.167] (EE) Segmentation fault at address 0xbccb2cfa
[  2131.167] 
FatalError re-entered, aborting
[  2131.167] Caught signal 11 (Segmentation fault). Server aborting

I'm not sure what that means. The system boots just fine -- X is "broken" though. For now I've rolled back to the previous versions of glibc and so on, which I keep nicely in my cache for just such occasions as these.

Note that this is with a 32-bit Arch running on a Mac Pro in VirtualBox:

Linux kurosawa 3.7.1-2-ARCH #1 SMP PREEMPT Thu Dec 20 19:35:59 CET 2012 i686 GNU/Linux

My 64-bit Atom-based Arch took the updates with no problems.

Offline

#6 2012-12-28 17:59:52

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Antoine, pardon a newbie question here: how did you go about downgrading?  When I first experienced the breakage, I tried rolling back various packages (cloog, dasher) just to see if one of them would quickly fix the problem.  But when I tried using the...

# pacman -U /var/cache/pacman/pkg/pkgname-olderpkgver.pkg.tar.gz

...method to downgrade glibc, gcc, gcc-libs and binutils, I kept getting dependency-related error messages, presumably stemming from the fact that the packages' dependencies required everything to be rolled back simultaneously, rather than one at a time.

Edit: grammar

Last edited by wideaperture (2012-12-28 18:00:48)

Offline

#7 2012-12-28 18:45:00

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Sorry for the silly question, Antoine—I answered it myself and (temporarily) fixed the issue.  To simultaneously downgrade glibc, gcc, gcc-libs, binutils, and libaccounts-glib:

# sudo pacman -U /var/cache/pacman/pkg/glibc-2.16.0-5-i686.pkg.tar.xz /var/cache/pacman/pkg/libaccounts-glib-1.3-1-i686.pkg.tar.xz /var/cache/pacman/pkg/binutils-2.23.1-1-i686.pkg.tar.xz /var/cache/pacman/pkg/gcc-libs-4.7.2-2-i686.pkg.tar.xz /var/cache/pacman/pkg/gcc-4.7.2-2-i686.pkg.tar.xz 

Rolling back to previous versions of these packages gets X and the gnome desktop up and running for me.  I guess we'll have to wait and see if the larger issue is resolved the next time these packages or Guest Additions are updated, or if someone comes up with a more nuanced fix in the interim.

Thanks again, Antoine!

Last edited by wideaperture (2012-12-28 18:46:27)

Offline

#8 2012-12-28 18:49:17

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

wideaperture wrote:

Antoine, pardon a newbie question here: how did you go about downgrading?  When I first experienced the breakage, I tried rolling back various packages (cloog, dasher) just to see if one of them would quickly fix the problem.  But when I tried using the...

EDIT: Sorry, I posted this before I saw your newer message.

The only packages I rolled back were

binutils-2.23.1-2 -> binutils 2.23-1 
gcc-4.7.2-3 -> gcc 4.7.2-2
gcc-libs-4.7.2-3 -> gcc-libs 4.7.2-2
glibc-2.17-1 -> glibc 2.16.0-5 

which brought my X back.

You have to do it in the right order. The last time, I had to actually remove gcc (pacman -Rs gcc, which removes cloog, e.g.) and then re-install  rom the cache (which will bring back its dependencies). Also had to remove libtool, and dkms, I'm genuinely sorry, I'm a newbie here too, so I didn't keep a "diary" (if you want). I'm loooking through my .bash_history to see what I did.

sudo pacman -R virtualbox-guest-dkms
sudo pacman -R dkms
sudo pacman -R libtool
sudo pacman -Rs gcc
sudo pacman -U gcc-libs-4.7.2-2-i686.pkg.tar.xz
sudo pacman -U gcc-4.7.2-2-i686.pkg.tar.xz
sudo pacman -U binutils-2.23-1-i686.pkg.tar.xz
sudo pacman -U glibc-2.16.0-5-i686.pkg.tar.xz
sudo pacman -S libtool

and my next entry is "startx" (which I usually do from .bashrc). I haven't re-installed the dkms stuff.

Last edited by Antoine (2012-12-28 18:50:43)

Offline

#9 2012-12-28 18:52:30

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Thanks for your detailed response, Antoine, we crossed in the mail!  I got it working and my rollback command is above.  If it's any help in the future, I discovered that when you add multiple packages to the 'pacman -U' command, pacman takes care of the ordering issue by itself.

Last edited by wideaperture (2012-12-28 18:54:05)

Offline

#10 2012-12-28 19:05:37

thehatusa
Member
From: DfG
Registered: 2010-01-19
Posts: 15

Re: Desktop won't start after latest update

Hi. This is my Xorg.0.log: http://pastebin.com/50hJBu8S
The only EE: 

[    54.692] (EE) Failed to load module "modesetting" (module does not exist, 0)

And it's not like the other Xorg.0.log posted here.

Regards

Last edited by thehatusa (2012-12-28 19:08:56)

Offline

#11 2012-12-28 19:12:57

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Incidentally, one last newbie question.  If I or we were to file a formal bug report on this issue, to whom should it be reported?  The maintainers of the packages we rolled back?  The Oracle/VirtualBox community?  X.org?  Or Arch?

Edit: Filed a bug report on archlinux.org.  Despite my attempt to provide helpful information, you can definitely tell it was written by a newbie.  Nonetheless, the kind folks on the #archlinux IRC channel suggested I'd better file something if I preferred to be part of the solution, rather than part of the problem.  So that's what I've done.  Please vote on the issue if you're experiencing similar problems.

Last edited by wideaperture (2012-12-28 20:02:44)

Offline

#12 2012-12-28 20:50:46

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

wideaperture wrote:

Thanks for your detailed response, Antoine, we crossed in the mail!  I got it working and my rollback command is above.  If it's any help in the future, I discovered that when you add multiple packages to the 'pacman -U' command, pacman takes care of the ordering issue by itself.

Thanks for that -- it's good to know. EDIT: I'll take a look at your bug report, too. Thanks for the diligence.

Last edited by Antoine (2012-12-28 20:53:20)

Offline

#13 2012-12-28 21:05:47

múna
Member
Registered: 2012-12-28
Posts: 3

Re: Desktop won't start after latest update

I experienced the same problem today after updating the system (I am running Arch in a VirtualBox environment and using MATE, KDE and Fluxbox via .xinitrc and startx, too), so I was glad to almost instantly stumble upon a thread like this when I tried searching the forums.

After using `startx` on the tty, this is the screen that I get to see:
arch_linux_buggy_x.png
The beam/underline cursor thingy also seems to freeze (it stops flashing).


Slightly OT: Do I have to register a new/different account in order to be able to vote on the bug that wideaperture filed?

Offline

#14 2012-12-28 23:42:57

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

múna wrote:

I
After using `startx` on the tty, this is the screen that I get to see:

I consider that SPAM, connard,  It brings up some Kraut game window that won't close without taking over my browser.

If you don't like me calling him on that crap, boot me off your forums.

Offline

#15 2012-12-29 04:28:42

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

Update: There's further discussion of this in this thread in the "Package and Pacman" forum. I'm not sure of the, er, "protocol" for putting the two threads together.

EDIT: I think that disabling the virtualbox guest modules might not be the best way around this. I'd rather stay with "downgraded" packages for now.

Last edited by Antoine (2012-12-29 04:30:27)

Offline

#16 2012-12-29 04:43:23

Potomac
Member
Registered: 2011-12-25
Posts: 342

Re: Desktop won't start after latest update

it's me who have posted this thread, same problem :

https://bbs.archlinux.org/viewtopic.php?id=155334

for me the solution is to disable the loading of virtualbox modules in  "/etc/modules-load.d/" and disable the virtualbox service with systemctl, and wait for a new rebuild of the virtualbox modules packages

Offline

#17 2012-12-29 05:41:40

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Desktop won't start after latest update

Antoine wrote:
múna wrote:

I
After using `startx` on the tty, this is the screen that I get to see:

I consider that SPAM, connard,  It brings up some Kraut game window that won't close without taking over my browser.

If you don't like me calling him on that crap, boot me off your forums.

Hit the square in the window title bar, rather than the "X" to close the window.

ps "kraut" is rather offensive & "connard" is not very complimentary.

be nice smile

Last edited by flipper T (2012-12-29 05:45:25)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#18 2012-12-29 12:25:13

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

flipper T wrote:

Hit the square in the window title bar, rather than the "X" to close the window.

I don't think I should have to jump through Windows-centric hoops or pass some silly  test.

flipper T wrote:

ps "kraut" is rather offensive & "connard" is not very complimentary.

be nice smile

Spam is not nice. I call 'em as I see 'em. He could paste his logs into a code block.

Offline

#19 2012-12-29 13:00:33

múna
Member
Registered: 2012-12-28
Posts: 3

Re: Desktop won't start after latest update

Umm. I'm new to Arch Linux and was just trying to be helpful. Imagebanana is an ordinary free image-hoster, so advertising is to be expected (and with Adblock Plus and NoScript, I don't even get to see that stuff). I would have pasted my Xorg.*.log, but the file is on my virtual machine and I don't know how to do this in a non-GUI browser like lynx.

No need to be so exceedingly rude :-(

Offline

#20 2012-12-29 13:04:49

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Desktop won't start after latest update

Some people, encountering a pop-up window for the first time, do struggle.

Apparently.

Despite tooltips explaining which button to press.

Oh hum.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#21 2012-12-29 17:08:22

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Antoine wrote:

I'll take a look at your bug report, too. Thanks for the diligence.

NP.

múna wrote:

Slightly OT: Do I have to register a new/different account in order to be able to vote on the bug that wideaperture filed?

Yep, the bug tracker requires a separate account.

Potomac wrote:

it's me who have posted this thread, same problem

Thanks for the additional information, and for contributing to the bug report.

múna wrote:

the file is on my virtual machine and I don't know how to do this in a non-GUI browser like lynx.

Even while X was crashing on my system, Guest Additions still successfully provided the ability to mount a shared folder from the host system.  So one way to get your log files up is to copy them to a shared folder, to which the host has access, and then open the files in the host OS.  At that point you can cut and paste them into a browser in the host system.

It's also possible to use 'wgetpaste' to create pastebin links, as 2ManyDogs suggested above.

Offline

#22 2012-12-30 16:23:58

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Desktop won't start after latest update

wideaperture wrote:

Even while X was crashing on my system, Guest Additions still successfully provided the ability to mount a shared folder from the host system.  So one way to get your log files up is to copy them to a shared folder, to which the host has access, and then open the files in the host OS.  At that point you can cut and paste them into a browser in the host system.

On a related note: I see you're using OS X 10.7.5 as a host, as am I. I've installed the excellent SMBUp which "just works"  to replace Apple's broken Samba. Then, in Arch, with smbclient (from the Extra repo) I can access stuff from the command line (or with Thunar, when X is up) without using the VB "shared folders" which I've always had problems with. Umm ... get your filenames just right with xmbclient; that should go without saying, but I have an enlarged idiocy gene ...

Offline

#23 2012-12-30 16:30:04

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

Antoine wrote:

I've installed the excellent SMBUp which "just works"  to replace Apple's broken Samba. Then, in Arch, with smbclient (from the Extra repo) I can access stuff from the command line (or with Thunar, when X is up) without using the VB "shared folders" which I've always had problems with.

Thanks much.  So far VBox shared folders are working well for me.  But I've bookmarked the link and should I need a more extensive solution, I'll be sure to try it out!

P.S. I can post my shared folder configuration elsewhere if it's helpful, though I feel like it might be OT for this thread

Offline

#24 2012-12-30 17:29:12

múna
Member
Registered: 2012-12-28
Posts: 3

Re: Desktop won't start after latest update

wideaperture wrote:

P.S. I can post my shared folder configuration elsewhere if it's helpful, though I feel like it might be OT for this thread

That would be nice because I'm also having trouble getting shared folders to work with Virtualbox (if this is too off-topic and it isn't too much hassle for you, you can also PM me).

Offline

#25 2012-12-30 19:48:45

wideaperture
Member
Registered: 2012-03-29
Posts: 18

Re: Desktop won't start after latest update

múna wrote:

That would be nice because I'm also having trouble getting shared folders to work with Virtualbox (if this is too off-topic and it isn't too much hassle for you, you can also PM me).

As I can't find a better place on the forums to do this, I'll briefly discuss the configuration here.

  1. Create a folder on your host OS to be shared with your Arch Linux guest.  Note that this folder has to be in a location that's not "owned" by a particular user of your host OS.  There's some weirdness to this, as it appears to be about more than just the permissions assigned to a particular folder.  I've found that on OS X, creating a folder either in the ~/Public folder (<--this is where I put my shared folder) or on the Desktop works, while creating a folder in the ~/Documents directory does not, despite the fact that the permissions for some of these different directories are similar.  Also, at this stage, place a text file or some other file in the folder—later on, if you can see and view the contents of this file from within Arch you'll know the folder's been shared successfully

  2. Identify the shared folder in your VM's VirtualBox settings. In the VirtualBox Manager window, prior to booting your VM, select your Arch Linux guest and go to "Settings > Shared Folders".  Click the folder icon with a plus on it to add a shared folder.  For "Folder Path" open the dropdown menu and select "Other..." to launch your host OS' file browser.  Select the folder you created on your host OS in step one.  For "Folder Name", if it's not autofilled, enter a name for the folder to identify it to the Arch Linux guest—to avoid dealing with escape characters and so forth later on, I generally make this something simple, like "Shared", and avoid spaces or special characters.  For simplicity's sake, I also usually make this name the same as the name of the folder I created in step one.  "Read Only" should be left unchecked, assuming you want to be able to add files to the shared folder from within Arch.  Also, leave "Auto-mount" unchecked—there's an alternative configuration in which you leave this checked, but for present purposes it shouldn't be.  Finally, check "Make Permanent" to have the folder available every time the Arch guest is booted.  When you've filled out the form and clicked 'OK' your new folder-to-be-shared should appear in the "Settings > Shared Folders" window under the list of "Machine Folders".

  3. Boot your Arch Linux VM.   Log in with your normal user account (i.e., not as root).

  4. Create a mount point in Arch for the shared folder. By this, I mean create a folder in Arch where you want the contents of the shared folder on the host OS to appear.  I usually create this folder in my home (~) directory and, for consistency, name it the same thing I named the folder on the host OS, which is also the same "Folder Name" name I gave when identifying it in the VM settings.

  5. Test the availability of the shared folder by manually mounting it.  Momentarily, we'll automate this process, but before we do it's a good idea to make sure everything's working correctly.  This is an example of the command to run, which I'll explain subsequently:

    # sudo mount -t vboxsf -o gid=1000,uid=1000 Shared /home/josh/Shared

    In the above command,

    • sudo is obviously to invoke administrative privileges, which are needed to mount the folder;

    • mount is the mount command;

    • -t is a flag specifying the type of thing to be mounted, which is a Virtual Box shared folder ('vboxsf');

    • -o is the options flag, which is there so we can invoke the option to make the folder writable for the users in the group with the number 1000 (gid=1000) and the particular user with id number 1000 (uid=1000).  Assuming this is a personal install and you created only one non-root user account for yourself, user 1000 in group 1000 will be you, however if you've got multiple user accounts or have set up weird group privileges, you may need to look up the group and user id that apply to you;

    • 'Shared' is the name you gave as "Folder Name" in step two;

    • '/home/josh/Shared' is the absolute path to the folder you created in step four (my username is 'josh').  Note that you have to give this filepath without any shortcuts or symlinks (i.e., '~/Shared' will not work).

    Note that if you want to temporarily share a folder between your guest and host in the future, you can use this same 'mount' command in conjunction with VirtualBox's "Devices > Shared Folders" menu while the VM is running.  The only difference is that the folder you share using "Devices > Shared Folders" will be added to a list of "Transient Folders" rather than the "Machine Folders" list, meaning that it will only be available for the current VM session.

  6. Test the shared folder.  Once you've run this command, you should be able to see and view the contents of any files you've placed in the shared folder on the host OS by navigating to the mount-point folder you created from within Arch.  You should also try copying a file from your Arch system into the shared folder to see if it shows up on the host OS.  If not, you may not have write privileges for the folder, and you should check (1) the folder permissions on the host, as well as (2) the uid/gid you used in your command to make sure they correctly apply to your user account.

  7. Add instructions for mounting the folder to /etc/fstab.  If everything's worked up 'til now, you can go ahead and add instructions for mounting to the folder to your /etc/fstab file.  This will automatically mount the shared folder in the future when Arch boots.  At the end of my /etc/fstab file, I placed the following:

    # VirtualBox Shared Folder
    Shared /home/josh/Shared vboxsf uid=1000,gid=1000 0 0

    While the order is slightly different, you'll see that all of the options set here are identical to the ones used in the 'mount' command above, so you should set them to whatever the personal equivalents are that you used previously.  The only exceptions are the last two zeroes, which you should just leave as is.  These turn off Linux's file system backup ('dump') and file system check ('fsck') for the shared folder, neither of which is needed here.

  8. Reboot Arch. At this point, you should be able to reboot Arch and, if everything's worked correctly, the shared folder should be automatically mounted for you.

Lastly, I should mention how the method I've described here is different from alternatives that some other people use, so there's no confusion if or when you encounter a forum thread at some point in which people have done it differently.  Some other folks will use much the same process I've outlined, but instead of having 'fstab' mount their shared folder will instead create a systemd configuration file to do the same thing.

Still other folks will check "Auto-mount" in step two above, and omit my steps 4–7.  Instead, they create user privileges for Guest Additions within Arch that allow the Guest Additions software to mount volumes by itself.  Guest Additions will then automatically mount the shared folder as an external drive that shows up under the '/media' directory.  I've never tried this method personally, but if you wanted to, you could find instructions on doing so with a bit of Googling.

Note that if you use my configuration, you should leave 'Auto-mount' unchecked—if you leave it checked, things will work just fine when you boot and while you're working, but will cause problems when you try to shut down the VM.  At that point, VirtualBox's ongoing attempt at connecting to the VM as a removable device, hitherto harmless, causes Arch to wig out as it's unmounting and closing down all the virtual hardware.  This usually induces a slew of error messages ending in a kernel panic, and the need for a hard shutdown of the machine.

Hope this helps, and sorry for the long, somewhat OT post.  Hopefully it helps by making it easier for people to export error logs to their host systems while this bug is ongoing.

Last edited by wideaperture (2012-12-30 19:53:53)

Offline

Board footer

Powered by FluxBB