You are not logged in.

#1 2012-12-30 21:27:15

creatid
Member
From: Netherlands
Registered: 2009-12-19
Posts: 75
Website

[SOLVED] udev messages cluttering tty

I recently re-installed Arch on both my computers to get grid of cruft and to transition to systemd. On my netbook, udev displays a number of messages on the tty as soon as the wireless interface connects to the router, cluttering the boot prompt. On both the desktop and the netbook, additional messages appear when I connect a usb drive.

Searching the forum and Google, the only solution I could find was to put 'dmesg -n 3' in rc. local. Does anyone know how to accomplish the same in a pure systemd setup?

Last edited by creatid (2012-12-30 22:25:29)

Offline

#2 2012-12-30 21:43:54

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: [SOLVED] udev messages cluttering tty

It is likely the kernel and not udev that prints these messages (but hard to tell without seeing the messages ;-) ). In that case you can adjust the loglevel by passing "loglevel=" on the kernel commandline.

Offline

#3 2012-12-30 21:46:38

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,966
Website

Re: [SOLVED] udev messages cluttering tty

I have loglevel=3 on my kernel line.  I don't know if there are "cleaner" ways of doing this with systemd now, but this works great for me and got rid of similar wireless interface messages.

EDIT: those messages (below) look exactly like those that "loglevel=3" prevents for me.

Last edited by Trilby (2012-12-30 22:10:37)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-12-30 22:03:31

creatid
Member
From: Netherlands
Registered: 2009-12-19
Posts: 75
Website

Re: [SOLVED] udev messages cluttering tty

Forgot to mention in my original post that I already have 'loglevel=3' in syslinux.cfg.

As for the messages themselves:

[   11.095116] ieee80211 phy0: brcsmac: brmsc_ops_bss_info_changed: associated
[   11.095364] ieee80211 phy0: brmsc_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[   11.095665] ieee80211 phy0: brmsc_ops_bss_info_changed: qos enabled: true, (implement)
[   17.971565] ieee80211 phy0: brmsc_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)

Offline

#5 2012-12-30 22:11:43

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,966
Website

Re: [SOLVED] udev messages cluttering tty

Just to be sure, that loglevel=3 is on the APPEND line, right (and you've tripple checked for any typos)?  I hope that doesn't sound too obvious, but those do look just like the messages that that setting prevents for me.

Last edited by Trilby (2012-12-30 22:12:03)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2012-12-30 22:24:26

creatid
Member
From: Netherlands
Registered: 2009-12-19
Posts: 75
Website

Re: [SOLVED] udev messages cluttering tty

Trilby wrote:

Just to be sure, that loglevel=3 is on the APPEND line, right (and you've tripple checked for any typos)?

Checked, double checked and triple checked. On the APPEND line and no typos. But your reply got me thinking because I had 'quiet' after 'loglevel=3'. If I swap them around the message are gone. Thanks chaps!

Offline

Board footer

Powered by FluxBB