You are not logged in.

#1 2012-12-30 17:54:40

Linkas
Member
Registered: 2011-12-28
Posts: 25

Awesome WM is slower after upgrade

I think Awesome is slower after upgrade, which was today. Now it can't keep up with focusing on windows when I moving my mouse or if I press modKey + j twice, focus only move one window forward. I disabled few vicious widgets but I still have a problem. Anybody has similar feelings?

Last edited by Linkas (2012-12-30 17:57:31)

Offline

#2 2012-12-30 17:57:25

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,636

Re: Awesome WM is slower after upgrade

Same here with nvidia driver. Much better with nouveau driver. Still slower than before. My Ati driven notebook is fast. There's a thread on the Awesome devel mailing list.

Offline

#3 2012-12-30 17:58:04

Linkas
Member
Registered: 2011-12-28
Posts: 25

Re: Awesome WM is slower after upgrade

I have a nvidia driver too

Offline

#4 2012-12-30 18:00:24

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Awesome WM is slower after upgrade

Linkas wrote:

I think Awesome is slower after upgrade, which was today. Now it can't keep up with focusing on windows when I moving my mouse or if I press modKey + j twice focus only move one window forward. I disabled few vicious widgets but I still have a problem. Anybody has similar feelings?

Ha! That upgrade to 3.5 completely broke awesome for me. It won't  load its default config file. (This isn't an Arch problem -- Arch is designed to provide the most recent versions of all the software you use, and 3.5 is the most recent version of awesome). Anyway, I rolled it back and now I'm setting up Pekwm; it doesn't seem as malleable, but it's configuration isn't based on Lua.

Offline

#5 2012-12-31 14:53:52

y4mz
Member
Registered: 2007-06-16
Posts: 16

Re: Awesome WM is slower after upgrade

I'm finding 3.5 significantly slower than 3.4.13 using its default configuration, at least with the Intel (Sandybridge) graphics driver.

Offline

#6 2012-12-31 15:23:43

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Awesome WM is slower after upgrade

Didn't notice any slowness but I've had it crash on me 3 times now. Don't have time for that tom-foolery at the moment so I am back to 3.4 for a while. nvidia driver.

Offline

#7 2012-12-31 21:41:17

loathingkernel
Member
Registered: 2012-01-14
Posts: 2

Re: Awesome WM is slower after upgrade

Have you tried using the patched cairo library for the NVIDIA binary blob?
It has the old "disable gradients" patch that seems to help with the slowness.
You can find it in AUR under the name cairo-nvidiablob.

That being said, personally,  I am having issues with xterm flickering whenever the window focus changes.

Last edited by loathingkernel (2012-12-31 22:10:11)

Offline

#8 2013-01-01 13:45:52

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,636

Re: Awesome WM is slower after upgrade

For me with nouveau moving mouse over some terminal window doesn't always give the window the focus. Not sure if this is also speed related or something different.

Offline

#9 2013-01-01 23:37:12

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: Awesome WM is slower after upgrade

I didn't have any problems until just this last update.  The config file syntax changed.  Copied the new config file under .config/awesome.
Before the update, I was trying to get some of the vicious widgets to work, but all I got was another virtual desktop bar across the top.  Maybe some of the problems the same?  The vicious widgets would work if I manually typed them into awesome-client.  Awesome just updated again.

Last edited by nomorewindows (2013-01-02 18:50:25)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#10 2013-01-04 17:03:51

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: Awesome WM is slower after upgrade

The redraw function seems to have been removed from the rc.lua, but the Mod4+o is still in the file, but doesn't seem to be working.  Using dvorak layout, an is using Mod4+o on qwerty layout, not dvorak layout...that's strange.

Last edited by nomorewindows (2013-01-04 17:14:09)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#11 2013-01-04 19:53:49

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,636

Re: Awesome WM is slower after upgrade

nomorewindows wrote:

The redraw function seems to have been removed from the rc.lua, but the Mod4+o is still in the file, but doesn't seem to be working.  Using dvorak layout, an is using Mod4+o on qwerty layout, not dvorak layout...that's strange.

Awesome doesn't honor any (Xorg) kbd layout. That's an upstream bug it seems. I'm also affected when using Mod+"r" it's using en-US not my DE layout.

https://awesome.naquadah.org/bugs/index … sk_id=1077

Offline

#12 2013-01-05 01:09:29

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: Awesome WM is slower after upgrade

AndyRTR wrote:
nomorewindows wrote:

The redraw function seems to have been removed from the rc.lua, but the Mod4+o is still in the file, but doesn't seem to be working.  Using dvorak layout, an is using Mod4+o on qwerty layout, not dvorak layout...that's strange.

Awesome doesn't honor any (Xorg) kbd layout. That's an upstream bug it seems. I'm also affected when using Mod+"r" it's using en-US not my DE layout.

https://awesome.naquadah.org/bugs/index … sk_id=1077

Hmm...well it working from the dvorak layout the other day just fine.  Wonder what changed?


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#13 2013-01-05 15:13:32

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: Awesome WM is slower after upgrade

It has transpired into another forum as far as the keyboard layout: https://bbs.archlinux.org/viewtopic.php?id=155588


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#14 2013-01-05 22:48:09

divide
Member
Registered: 2012-09-23
Posts: 5

Re: Awesome WM is slower after upgrade

try starting awesome with "-no-argb":  https://awesome.naquadah.org/bugs/index … sk_id=1071

I've tried it and seems to have fixed all the flickering issues when switching between windows

Last edited by divide (2013-01-05 22:48:28)

Offline

#15 2013-01-06 19:55:15

Old user, new ID
Member
Registered: 2012-09-18
Posts: 13

Re: Awesome WM is slower after upgrade

divide wrote:

try starting awesome with "-no-argb":  https://awesome.naquadah.org/bugs/index … sk_id=1071

I've tried it and seems to have fixed all the flickering issues when switching between windows

--no-argb (don't know if -no-argb is valid) fixed the issues I had with Awesome 3.5.

mplayer2 is usable again for me.

Offline

Board footer

Powered by FluxBB