You are not logged in.

#1 2012-12-31 19:54:27

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

[Solved] Locale?

Hi everyone! I'm a bit new to the community and am having some problems with my locale.conf file or at least I suspect that's what the problem is. You see, every-time I open Nemo or Perl I get a similar message in both,

Nemo:

(nemo:14810): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

Perl:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_MONETARY = "en_US",
    LC_NUMERIC = "en_US",
    LC_MEASUREMENT = "en_US",
    LC_TIME = "en_US",
    LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

locale.conf:

LANG=en_US.UTF-8
LANGUAGE=en_US.UTF-8

And my locale.gen file is all uncommented except for this line,

en_US.UTF-8 UTF-8

Refer to, #10

Output of locale:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC=en_US
LC_TIME=en_US
LC_COLLATE="en_US.utf8"
LC_MONETARY=en_US
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT=en_US
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

Output of locale -a:

C
en_US.utf8
POSIX

Any help would be much appreciated. Thanks in advance. (n_n)

Last edited by WhiteHatHacker1 (2013-05-02 22:38:46)

Offline

#2 2012-12-31 19:59:34

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Solved] Locale?

Welcome to Arch!

Please use [code ][/code ] tags.

What is the output of locale -a?

Did you generate the locales as described in the wiki?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2012-12-31 20:03:26

mariusmeyer
Member
From: Norway
Registered: 2009-04-25
Posts: 244

Re: [Solved] Locale?

Also, check the quotation marks in locale.conf. If you posted your literal file then it looks strange.

Offline

#4 2012-12-31 20:06:33

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

cfr wrote:

Welcome to Arch!

Please use [code ][/code ] tags.

What is the output of locale -a?

Did you generate the locales as described in the wiki?

Oh sorry I didn't know there were such things I'll add them now.

Offline

#5 2012-12-31 20:12:49

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

mariusmeyer wrote:

Also, check the quotation marks in locale.conf. If you posted your literal file then it looks strange.

Sorry what I really should've done was use the code tags as cfr suggested instead of quoting it. I have fixed it.

Last edited by WhiteHatHacker1 (2012-12-31 20:13:10)

Offline

#6 2012-12-31 21:11:51

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Locale?

So how about the output of "locale" and "locale -a".  Mine look like this:

$ locale -a
C
en_US
en_US.iso88591
en_US.utf8
POSIX

and

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Offline

#7 2012-12-31 21:17:57

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

WonderWoofy wrote:

So how about the output of "locale" and "locale -a".  Mine look like this:

$ locale -a
C
en_US
en_US.iso88591
en_US.utf8
POSIX

and

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Okay post is updated with the information.

Offline

#8 2012-12-31 21:24:21

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] Locale?

I think for the ease of readability, it might be better to post the answers to questions in the new post.  Then if you feel it is necessary, edit the first post indicating the post number containing more info.

Is there are reason you didn't enable both en_US.UTF-8 UTF-8 as well as en_US ISO-8859-1?  Can you try uncommenting the ISO-8859-1 line as well, then regenerating with locale-gen?

Offline

#9 2012-12-31 23:02:58

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Solved] Locale?

I would also uncomment the plain en_US line.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#10 2013-01-01 00:41:50

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

WonderWoofy wrote:

I think for the ease of readability, it might be better to post the answers to questions in the new post.  Then if you feel it is necessary, edit the first post indicating the post number containing more info.

Is there are reason you didn't enable both en_US.UTF-8 UTF-8 as well as en_US ISO-8859-1?  Can you try uncommenting the ISO-8859-1 line as well, then regenerating with locale-gen?

Okay I enabled en_US ISO-8859-1 and thanks for the pointers.

Offline

#11 2013-01-01 00:43:00

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

cfr wrote:

I would also uncomment the plain en_US line.

I don't see any plain en_US line in locale.gen.

Offline

#12 2013-01-01 01:32:26

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,359
Website

Re: [Solved] Locale?

Is UTF supposed to be capitalized in locale.conf?  Mine is as follows:

$ cat /etc/locale.conf 
LANG=en_US.utf8

InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#13 2013-01-01 01:33:53

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,709

Re: [Solved] Locale?

Never uncomment anything but utf8, or you will soon start to pull out your hair trying to view the unicode symbol for a pile of shit. (Or the letters æøå)

The errors looked more like a broken enviroment than locale, but try regenning anyway.

Last edited by Mr.Elendig (2013-01-01 01:34:12)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#14 2013-01-01 01:58:33

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Solved] Locale?

WhiteHatHacker1 wrote:
cfr wrote:

I would also uncomment the plain en_US line.

I don't see any plain en_US line in locale.gen.

Sorry. I'm confusing it with what I have in locale.conf:

LANG=cy_GB.UTF-8
LANGUAGE=cy_GB:cy:en_GB:en
LC_COLLATE=C

How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#15 2013-01-01 12:44:11

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,709

Re: [Solved] Locale?

switch your locale.conf to en_US.utf8


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#16 2013-01-01 15:11:23

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Solved] Locale?

Mr.Elendig wrote:

switch your locale.conf to en_US.utf8

Isn't this what the OP has?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#17 2013-01-01 15:44:07

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,359
Website

Re: [Solved] Locale?

en_US.utf8 != en_US.UTF8

They may both work.  But I've only have the former.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#18 2013-01-01 17:00:07

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Solved] Locale?

Oh, I see. The wiki uses the capitalised version, though (in the Beginner's Guide) so I was assuming that aspect of it was OK. (But maybe the wiki is wrong on this.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#19 2013-01-01 17:30:53

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,359
Website

Re: [Solved] Locale?

Nope, more likely I am - and either can be used.  I was just trying to brainstorm what *might* be going wrong.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#20 2013-01-11 04:49:39

WhiteHatHacker1
Member
Registered: 2012-12-22
Posts: 37

Re: [Solved] Locale?

Mr.Elendig wrote:

switch your locale.conf to en_US.utf8

Sorry I wasn't on in a while, family stuff, anyway I switched it and still get the error.

Offline

Board footer

Powered by FluxBB