You are not logged in.

#1 2013-01-01 20:33:34

kaprikawn
Member
Registered: 2011-09-23
Posts: 12

Logitechmediaserver preventing system upgrade

Hi, I haven't been able to do a full system update in a while because a package that I have installed from the AUR, logitechmediaserver, requires an earlier version of perl than what pacman wants to upgrade it to.  When I try to upgrade i get:

[user@arch ~]$ sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace dbus-core with core/dbus? [Y/n] 
:: Replace libusb with core/libusbx? [Y/n] 
:: Replace procps with core/procps-ng? [Y/n] 
:: Replace udev with core/systemd? [Y/n] 
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: logitechmediaserver: requires perl<5.15

Firstly, is it even a good idea for me to upgrade my system?  If I upgrade without upgrading perl, which presumably is what I need to do, will that potentially cause me problems if other packages rely on the current version of perl?

Secondly, if I can upgrade without breaking stuff, how exactly do I go about doing that?  I've added the following to my /etc/pacman.conf file:

IgnorePkg=logitechmediaserver
IgnoreGroup=logitechmediaserver

In hindsight, I doubt this was a good idea (it's warned against in the wiki), but either way it does not seemed to have worked anyway.

I'm just looking for options really.  Can I have a separate instance of perl installed just for logitechmediaserver and link that package to that, while the rest of my system has the latest version of perl in the standard location?

Just so you know, uninstalling the package and doing without it is not an option because it's one of the major reasons I have my Arch system, I'd rather leave the install as is rather than uninstall it just to have the latest system.

Thanks in advance.

Offline

#2 2013-01-01 20:40:43

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,837
Website

Re: Logitechmediaserver preventing system upgrade

This procedure works for all AUR packages:

1. Uninstall AUR package
2. Fully update system
3. Reinstall AUR package || nag maintainer to update their package*


* I use that package and the maintainer is extremely diligent about updating it...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-01-01 20:42:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,991

Re: Logitechmediaserver preventing system upgrade

Have you tried upgrading logitechmediaserver?

Offline

#4 2013-01-01 21:10:04

kaprikawn
Member
Registered: 2011-09-23
Posts: 12

Re: Logitechmediaserver preventing system upgrade

jasonwryan wrote:

This procedure works for all AUR packages:

1. Uninstall AUR package
2. Fully update system
3. Reinstall AUR package || nag maintainer to update their package*


* I use that package and the maintainer is extremely diligent about updating it...

Thanks for your reply, but will I definitely be able to reinstall the package after I've done the update?  Perl will upgrade to a version beyond ver 5.17 and the package says it needs a version less than that.  I'm a bit nervous that I won't be able to use the program if I do this.

Scimmia wrote:

Have you tried upgrading logitechmediaserver?

This is what I'm getting:

[user@arch ~]$ yaourt logitechmediaserver
1 aur/logitechmediaserver 7.7.2-5 [installed: 7.7.2-1] (0)
    Streaming audio server supported by Logitech
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==> 1


==> Downloading logitechmediaserver PKGBUILD from AUR...
x PKGBUILD
x conf.d
x install
x perl-recent.patch
x rc.d
x service



logitechmediaserver 7.7.2-5 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> logitechmediaserver dependencies:
 - perl<5.17 (already installed)
 - nasm (already installed)
 - yasm (already installed)
 - rsync (already installed)
 - wget (already installed)
 - perl>5.15 (package found)


==> Edit install ? [Y/n] ("A" to abort)
==> -----------------------------------
==> n

==> Continue building logitechmediaserver ? [Y/n]
==> ---------------------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for logitechmediaserver:
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: logitechmediaserver: requires perl<5.15
==> Restart building logitechmediaserver ? [y/N]
==> --------------------------------------------
==> 

Offline

#5 2013-01-01 21:19:49

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,991

Re: Logitechmediaserver preventing system upgrade

https://www.archlinux.org/packages/core/x86_64/perl/

How is 5.16 beyond 5.17?

Just follow the procedure jasonwryan gave you.

Offline

#6 2013-01-02 09:49:44

kaprikawn
Member
Registered: 2011-09-23
Posts: 12

Re: Logitechmediaserver preventing system upgrade

I've done that but I'm getting other errors now with other stuff.

I'll work on it.

Many thanks for the help.

Offline

Board footer

Powered by FluxBB