You are not logged in.

#1 2012-12-25 15:17:34

ramirezrubio92
Member
Registered: 2012-11-06
Posts: 7

No sound using internal speakers, but I have sound using headphones

I just finished installing archlinux with GNOME3 on a laptop, everything were perfect until I detected a problem: I only have sound using headphones, the internal speakers of the computer doesn't work. I followed the official wiki step by step and I never had this problem using other linux distributions.
Any idea?

Offline

#2 2012-12-25 15:26:57

zwinnyzz
Member
From: PL
Registered: 2012-12-25
Posts: 14

Re: No sound using internal speakers, but I have sound using headphones

If you are using Alsa try:

$ alsamixer

and unmute channels by 'm' button.

Offline

#3 2012-12-25 16:55:17

ramirezrubio92
Member
Registered: 2012-11-06
Posts: 7

Re: No sound using internal speakers, but I have sound using headphones

zwinnyzz wrote:

If you are using Alsa try:

$ alsamixer

and unmute channels by 'm' button.

Thank you for your help but I installed gnome-alsamixer, and configure the channels, the sound started working until I reboot the computer, then the sound still mute and I need to configure everything again. I have the same problem using the command alsamixer

Offline

#4 2012-12-25 17:49:45

dif
Member
From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 117

Re: No sound using internal speakers, but I have sound using headphones

Try using

sudo alsactl store

But read the ArchWiki for Alsa and

man alsactl

before.

Offline

#5 2012-12-25 22:48:29

ramirezrubio92
Member
Registered: 2012-11-06
Posts: 7

Re: No sound using internal speakers, but I have sound using headphones

dif wrote:

Try using

sudo alsactl store

But read the ArchWiki for Alsa and

man alsactl

before.

Thanks but it doesn't work for me sad
I read the archwiki about alsa and nothing

Last edited by ramirezrubio92 (2012-12-25 22:48:43)

Offline

#6 2012-12-30 02:23:30

dif
Member
From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 117

Re: No sound using internal speakers, but I have sound using headphones

First use alsamixer to unmute the channels and set the volumes. Then use

alsactl store

in order to store these settings. You may need to repeat it after some system updates unless you store the settings in our own file. This should normally work. If id doesn't, I can't help you, I'm afraid.

Offline

#7 2012-12-31 01:42:57

ramirezrubio92
Member
Registered: 2012-11-06
Posts: 7

Re: No sound using internal speakers, but I have sound using headphones

dif wrote:

First use alsamixer to unmute the channels and set the volumes. Then use

alsactl store

in order to store these settings. You may need to repeat it after some system updates unless you store the settings in our own file. This should normally work. If id doesn't, I can't help you, I'm afraid.

My problem is that the configuration doesn't get saved for the next reboot, then I have to repeat the process everytime I want to get the sound working. But thanks for the help

Offline

#8 2012-12-31 09:50:26

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: No sound using internal speakers, but I have sound using headphones

Then you have to enable alsa-store.service and alsa-restore.service in systemd.

Offline

#9 2013-01-02 10:59:21

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 684

Re: No sound using internal speakers, but I have sound using headphones

Army wrote:

Then you have to enable alsa-store.service and alsa-restore.service in systemd.

You could, but will get this message;

The unit files have no [Install] section. They are not meant to be enabled using systemctl.

So, don't try to enable this services by hand, they are enabled by default, justcheck,)

ls /usr/lib/systemd/system

-Not all ladders are to be climbed on-

Offline

#10 2013-01-12 13:19:01

kmiernik
Member
From: Poland
Registered: 2009-10-20
Posts: 39

Re: No sound using internal speakers, but I have sound using headphones

I'm having the very same issue. Each time I boot computer I have to unmute the speaker in order to have sound. Only the headphones are unmuted by default. From what I understand alsa-store and alsa-restore are supposed to run automatically on boot and shutdown only (normally they appear in inactive/dead state).

I have tried to run 'alsactl store', but this won't help.

The whole thing start happening only recently (late December). I have arch on this laptop for over 3 years and it was fine as far as I remember.

EDIT:
I have just found that this issue is due to pulseaudio 2.1 -> 3.0 upgrade. After downgrading to 2.1 it works as expected.

EDIT2:
Maybe you will find that useful, a temporary "fix". I have added to startup applications (in my case in gnome-session-properties):

amixer -c 0 sset Speaker Playback 95%

which just simply sets the speaker volume to 95% each time I log in.

Last edited by kmiernik (2013-01-14 12:17:57)

Offline

#11 2013-03-17 13:35:59

alfadude
Member
Registered: 2007-05-17
Posts: 4

Re: No sound using internal speakers, but I have sound using headphones

Its an old thread but I have the same issue with my recent arch install and found following workaround for this problem on the PCLinuxOS forums.

As root, open the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf

Locate the following section:

[Element Speaker]
switch = mute
volume = off

Change the "volume" value so it reads like this:

[Element Speaker]
switch = mute
volume = merge

You may have to edit the entry [Element Desktop Speaker] in the same way.

NOTE: as the file that is being edited is under the /usr/share folder, this change affects all users on the same machine.

Last edited by alfadude (2013-03-17 13:36:28)

Offline

Board footer

Powered by FluxBB