You are not logged in.

#1 2013-01-02 23:18:44

White girl
Member
Registered: 2012-12-24
Posts: 32

MPD won't start.

When I attempt to start MPD, I get this error:

listen: bind to '0.0.0.0:6600' failed: Address already in use (continuing anyway, because binding to '[::]:6600' succeeded)
daemon: cannot init supplementary groups of user "dana": Operation not permitted
Found db_file setting without music_directory - disabling database

What should I do?

Offline

#2 2013-01-02 23:23:00

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,825
Website

Re: MPD won't start.

Sounds like you need to fix your mpdconf... Start by posting it.  Also, are you running it as the mpd user or as another system user?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2013-01-02 23:28:37

White girl
Member
Registered: 2012-12-24
Posts: 32

Re: MPD won't start.

graysky wrote:

Sounds like you need to fix your mpdconf... Start by posting it.  Also, are you running it as the mpd user or as another system user?

Yes, I modified the config file to my name.

listen: bind to '0.0.0.0:6600' failed: Address already in use (continuing anyway, because binding to '[::]:6600' succeeded)
Failed to stat directory "/home/dana/Music/playlists": No such file or directory
Found db_file setting without music_directory - disabling database

My mpd.conf: http://pastebin.com/MEtt3Hze

Last edited by White girl (2013-01-02 23:29:23)

Offline

#4 2013-01-03 00:13:46

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,862
Website

Re: MPD won't start.

2 options:

a) run the mpd command as root
b) remove the user line alltogether

Last edited by Rasi (2013-01-03 00:14:02)


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#5 2013-01-03 00:25:46

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,825
Website

Re: MPD won't start.

...hope you're kidding about option a.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#6 2013-01-03 00:33:10

White girl
Member
Registered: 2012-12-24
Posts: 32

Re: MPD won't start.

Rasi wrote:

2 options:

a) run the mpd command as root
b) remove the user line alltogether

Still exactly same error.

Offline

#7 2013-01-03 00:40:27

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: MPD won't start.

Top to bottom:

listen: bind to '0.0.0.0:6600' failed: Address already in use (continuing anyway, because binding to '[::]:6600' succeeded)

This is perfectly normal.

daemon: cannot init supplementary groups of user "dana": Operation not permitted

Remove the user "dana" line (and start mpd as dana, not root).

Found db_file setting without music_directory - disabling database

You have your music_directory line commented.

Failed to stat directory "/home/dana/Music/playlists": No such file or directory

Create the directory yourself.

Offline

#8 2013-01-03 16:50:29

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,862
Website

Re: MPD won't start.

graysky wrote:

...hope you're kidding about option a.

ehm, no? I was still referring to the first post smile The user that is actually used it defined in config.... what do you think what user starts your system daemons (including mpd.service)?
Anyway, that issue has been resolved already and the remaining issues have been explained in detail above

Last edited by Rasi (2013-01-03 16:54:13)


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

Board footer

Powered by FluxBB