You are not logged in.

#1 2013-01-05 05:32:01

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,309

Investigating users

Hi,

I'm a single user of a single KDE desktop. For some reason, with KDE I've always been logged in twice (always once, as long as my conscious act is concerned, which is my point). Today there are three of me:

$ users
llama llama llama

Is there a way to uncover the entities which keep on logging in in my name?

Offline

#2 2013-01-05 05:33:41

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,814
Website

Re: Investigating users

$ who

??


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2013-01-05 05:41:27

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,309

Re: Investigating users

$ who
llama   :0           2013-01-05 07:58
llama   pts/0        2013-01-05 07:58 (:0)
llama   pts/1        2013-01-05 07:58 (:0)

pts has something to do with remote connections. What are they in my case? None of my conscious activities, sure.

Last edited by Llama (2013-01-05 06:11:02)

Offline

#4 2013-01-05 06:03:27

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,814
Website

Re: Investigating users

Dunno what to tell you.  KDM? KDE? I use lxdm and only see one:

% who
facade  pts/0        2013-01-05 01:02 (:0.0)

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2013-01-05 06:25:04

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Investigating users

I use lxdm

jk[~]$ who
jk       pts/0        Jan  5 06:22 (:0)
jk       pts/1        Jan  5 06:24 (:0)
jk[~]$ 

[edit: only user on a laptop / wireless network]

Last edited by flipper T (2013-01-05 06:28:59)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#6 2013-01-05 06:31:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Investigating users

I use a systemd service and I get nothing smile

Offline

#7 2013-01-05 07:02:51

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Investigating users

If it helps anyone here to diagnose the "problem", when i kill X

systemctl stop lxdm.service

and log into tty, only 1 user showing.

Restart lxdm:

jk[~]$ who
jk       tty1         Jan  5 06:59
jk       pts/0        Jan  5 07:00 (:0)

Reboot:

jk[~]$ who
jk       pts/0        Jan  5 07:24 (:0)

oh hum...

Last edited by flipper T (2013-01-05 07:26:47)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#8 2013-01-05 07:30:58

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Investigating users

...Open 2nd terminal (I use gnome-terminal)

jk[~]$ who
jk       pts/0        Jan  5 07:24 (:0)
jk       pts/1        Jan  5 07:27 (:0)

...Open 3rd

jk[~]$ who
jk       pts/0        Jan  5 07:24 (:0)
jk       pts/1        Jan  5 07:27 (:0)
jk       pts/2        Jan  5 07:27 (:0)

closing a terminal reduces number of user by 1

smile

So mystery solved for me, hope it helps OP.

Last edited by flipper T (2013-01-05 08:01:26)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#9 2013-01-05 08:11:54

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Investigating users

Interesting that gnome-terminal opens as a login shell.  Makes me wonder if this occurs with other terminal emulators.  Can you try others?

Offline

#10 2013-01-05 08:15:04

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: Investigating users

Exactly same behavior with lxterminal.

I use i3wm, if that is of any relevance (not sure why it would be)

Last edited by flipper T (2013-01-05 08:16:45)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#11 2013-01-05 08:35:28

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Investigating users

No it isn't.  What I am trying to say is that typically when you open a terminal (at least this is what I have experienced), it is not a login shell.  A login shell starts up slightly differently, configuration wise, and usually happens when you log in (imagine that!).

You can achieve a login by issuing something like

$ bash -l 

or

$ zsh -l 

if you prefer.

I am not so familiar with vte terminals though, so I am not sure if it has to do with that, or possibly the settings within those terminals.

Offline

#12 2013-01-05 14:33:37

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,662

Re: Investigating users

Both KDE konsole and xterm do the same, and i'm not using a display manager.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#13 2013-01-14 21:12:15

demize
Trusted User (TU)
From: Stockholm, Sweden
Registered: 2012-10-23
Posts: 20
Website

Re: Investigating users

WonderWoofy wrote:

Interesting that gnome-terminal opens as a login shell.  Makes me wonder if this occurs with other terminal emulators.  Can you try others?

IIRC it's an option in gnome-terminal

Offline

#14 2013-01-15 17:07:38

Leonid.I
Member
From: Aethyr
Registered: 2009-03-22
Posts: 972

Re: Investigating users

Llama wrote:

$ who
llama   :0           2013-01-05 07:58
llama   pts/0        2013-01-05 07:58 (:0)
llama   pts/1        2013-01-05 07:58 (:0)

pts has something to do with remote connections. What are they in my case? None of my conscious activities, sure.

No, "pts/X" are pseudo ttys which are open when you use a terminal emulator (and of course remote sessions as well). The reason why you see multiple logged in users is because your konsole (you use KDE, right?) updates utmp entry. You need to scout its config to set the corresponding setting to false.


Arch Linux is more than just GNU/Linux -- it's an adventure

Offline

#15 2013-01-15 23:00:29

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,029

Re: Investigating users

Every time a terminal is open, it opens a new user shell, but some of the actual logging in that would be redundant doesn't have to be done over and over again.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#16 2013-01-15 23:44:50

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: Investigating users

There are twelve of me.

I can't see an easy way to prevent this in Konsole's config...


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#17 2013-01-16 09:56:27

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: Investigating users

I have KDE with KDM (i am using zsh). When i open a konsole i get the same output as previous posts:

saso     :0           2013-01-16 10:45
saso     pts/0        2013-01-16 10:45 (:0)
saso     pts/1        2013-01-16 10:55 (:0)

Last edited by Shark (2013-01-16 09:56:52)


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

Board footer

Powered by FluxBB