You are not logged in.

#1 2004-01-11 15:14:09

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

cdrtools-devel needs provides=(cdrtools)

not ftp, but installation related:

cdrtools-devel needs provides=(cdrtools)

[root@Asteraceae damir]# pacman -Sf cdrtools-devel
:: cdrtools-devel conflicts with cdrtools. Remove cdrtools? [Y/n]

Remove:  cdrtools

Targets: cdrtools-devel-2.01a24-1

Proceed with upgrade? [Y/n]

checking package integrity... done.
error: this will break the following dependencies:
  cdrtools: is required by xcdroast
  cdrtools: is required by cdw
  cdrtools: is required by k3b
  cdrtools: is required by gcombust

upgrade aborted.

The impossible missions are the only ones which succeed.

Offline

#2 2004-01-11 16:14:51

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: cdrtools-devel needs provides=(cdrtools)

It already does :

$ cd /var/abs/unstable/system/cdrtools-devel 
$ grep provides PKGBUILD
provides=('cdrtools')

it also 'conflicts' with cdrtools. Maybe you need to upgrade pacman to the latest version first or if you already did so, file a bug report about pacman (not cdrtools-devel...).

Offline

#3 2004-01-11 21:12:47

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: cdrtools-devel needs provides=(cdrtools)

my pacman is up-to-date (always, because crond checks every 2 - 3 days for pacman -S pacman :-) )

sorry, didnt check the PKGBUILD ... actually i never had problems with "provides" option in makepkg ...

cant figure out if this is actually a bug --- what do think authors of pacman?


The impossible missions are the only ones which succeed.

Offline

#4 2004-02-18 00:55:53

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: cdrtools-devel needs provides=(cdrtools)

Yea, this is a bug in pacman.  I'm working on it for the 2.7.4 release.

Offline

#5 2004-02-18 01:30:17

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: cdrtools-devel needs provides=(cdrtools)

toastmix wrote:

i had this same problem.
and since i last updated k3b, cdburning has not worked at all so i was hoping the dev package would fix this, but i couldn't install it.  did you ever figure this out dp?

i forced the uninstall first:

pacman -Rd cdrtools

// and then

pacman -Sf cdrtools-devel

not really nice, but working :-)


The impossible missions are the only ones which succeed.

Offline

#6 2004-02-18 01:59:30

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: cdrtools-devel needs provides=(cdrtools)

Bugfix is in.  It'll go out with 2.7.4 (soon).

Offline

Board footer

Powered by FluxBB