You are not logged in.

#1 2013-01-05 19:41:01

ghborrmann
Member
Registered: 2012-05-01
Posts: 9

Can't Get snmp to work

I've installed a printer using CUPS, and indicated during the installation I wanted to share this printer.  On a separate Linux box, I attempted to add this printer via CUPS, but found that it was not listed as a network printer.  From the CUPS documentation, I found that CUPS requires snmp to be working in order to discover printers over the network.  I found the snmpd ArchWiki page and attempted to follow its instructions:
        pacman -S net-snmp
        systemctl enable snmpd
        mkdir /etc/snmp
        echo rocommunity read_only_public >> /etc/snmp/snmpd.conf
        systemctl start snmpd
Again, the other Linux box failed to detect the printer.  Following the Testing instructions in the ArchWiki, I executed
       snmpwalk -v 1 -c public localhost | less
which returned:  "Timeout: No Response from localhost"

Searching for this problem in the Arch Linux Forums, I found two previous posts indicating a solution by adding an entry to the /etc/hosts.allow file, but then found a notice that Arch Linux is deprecating that file.

Offline

#2 2013-01-05 22:48:57

awkwood
Member
From: .au <=> .ca
Registered: 2009-04-23
Posts: 91

Re: Can't Get snmp to work

Did you check the CUPS printer sharing settings after the installation?

The CUPS Printer Sharing wiki page shows how to access the CUPS web interface and how to edit the cupsd.conf file to give access to certain IP addresses.

Offline

#3 2013-02-08 07:04:04

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 772
Website

Re: Can't Get snmp to work

ghborrmann wrote:

I've installed a printer using CUPS, and indicated during the installation I wanted to share this printer.  On a separate Linux box, I attempted to add this printer via CUPS, but found that it was not listed as a network printer.  From the CUPS documentation, I found that CUPS requires snmp to be working in order to discover printers over the network.  I found the snmpd ArchWiki page and attempted to follow its instructions:
        pacman -S net-snmp
        systemctl enable snmpd
        mkdir /etc/snmp
        echo rocommunity read_only_public >> /etc/snmp/snmpd.conf
        systemctl start snmpd
Again, the other Linux box failed to detect the printer.  Following the Testing instructions in the ArchWiki, I executed
       snmpwalk -v 1 -c public localhost | less
which returned:  "Timeout: No Response from localhost"

Searching for this problem in the Arch Linux Forums, I found two previous posts indicating a solution by adding an entry to the /etc/hosts.allow file, but then found a notice that Arch Linux is deprecating that file.


I'm facing the same problem but no one seems to know the cause or the solution sad

Did you fix it?

Offline

Board footer

Powered by FluxBB