You are not logged in.

#1 2013-01-03 13:05:54

Ambrevar
Trusted User (TU)
Registered: 2011-08-14
Posts: 145
Website

[SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Keyboard layout was OK on 3.4.
For 3.5 and git version, Awesome defaults to english layout. Calling awesome.restart() (e.g. with SUPER+SHIFT+R) will correctly set the layout according to Xorg config. That's quite annoying indeed.

Only Awesome is affected, i.e. all other applications will use the Xorg config. So basically the affected parts are
* key bindings
* Run command
* Run lua code

Using
* up to date x86_64 system
* blank user session
* startx and 'exec awesome' as the sole command.

I couldn't find any related issue on the web, seems strange to me since I shouldn't be the only one using a non-english keyboard layout ! hmm

Any idea ?

Last edited by Ambrevar (2013-08-02 20:01:32)

Offline

#2 2013-01-04 02:03:47

shox
Member
Registered: 2012-06-20
Posts: 47

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Same problem here...

Offline

#3 2013-01-05 09:28:21

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 225

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Same here hmm

Also tried playing around with the POSIX lua modules but didn't have any effect.

Offline

#4 2013-01-05 11:35:32

aatiis
Member
From: Bajmok, Serbia
Registered: 2013-01-05
Posts: 3
Website

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Same here.

I tried changing the system keyboard layout but that did not help.

Unfortunately even reloading the config file does not help in my case, as I have a per-user keyboard layout (though .Xmodmap mappings seem to work).

Very frustrating indeed.

EDIT: I was wrong, reloading the config does fix the issue.

Last edited by aatiis (2013-01-11 09:36:02)

Offline

#5 2013-01-05 15:12:20

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

I had the switch screens Mod4+o quit on me (using dvorak), I had to use Mod4+o on the qwerty layout to get it to work.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#6 2013-01-06 23:36:59

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,944

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

I restarted everything and now it's back to behaving with Mod4+o.  Intermittent I guess.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#7 2013-01-07 04:42:01

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

The layout seems fine here behind lxdm but keeps broken when using plain startx+xinitrc.

Offline

#8 2013-01-07 09:51:38

aatiis
Member
From: Bajmok, Serbia
Registered: 2013-01-05
Posts: 3
Website

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

AndyRTR wrote:

The layout seems fine here behind lxdm but keeps broken when using plain startx+xinitrc.

Thanks for the hint, let me try that here too.

Offline

#9 2013-01-10 14:41:32

cephalopoid
Member
Registered: 2009-08-05
Posts: 21

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Same here, but as with nomorewindows case, I just need to restart awesome, but I need to do it every time I boot. Both my console and X are configured to dvorak, but in X it's set through .xinitrc.

I'm going to try and see whether putting

echo "awesome.restart()" | awesome-client

into my .xinitrc will help.
By the way, my .xinitrc starts awesome in the following way:

awesome & wmpid=$!

[whole bunch of misery involving mpd, urxvt and setting the keymap in X]
[above for restarting awesome]

wait $wmpid

Offline

#10 2013-02-03 20:53:22

shox
Member
Registered: 2012-06-20
Posts: 47

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

I have to :
- Make a Mod4 + O
- Restart Awesome

Each time I reboot to make it work.. Like cephalopoid !
Did you succed to solve it ?

Offline

#11 2013-02-03 20:57:02

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [SOLVED] Awesome 3.5 using english keyboard layout instead of Xorg's

Upstream has pushed a commit to fix this issue. It works fine here.

Offline

Board footer

Powered by FluxBB