You are not logged in.

#1 2013-01-08 15:52:41

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

[SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Has anyone successfully compiled this?

Last edited by Demon (2013-01-09 10:16:34)

Offline

#2 2013-01-09 10:04:19

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,207

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Yes, I just compiled a qtwebkit-2.3 git snapshot. You need to:

export QTDIR=/usr/lib/qt
install gperf & ruby
somehow trick the system into thinking that 'python' is python2: an alias doesn't work, make a symlink called 'python' pointing to python2 in some dir and put it at the beginning of your PATH

and then run Tools/Scripts/build-webkit --qt

If it fails at some point, just run it again, it will continue from where it stopped. I had to do that 2 or 3 times until it finished compiling.

Last edited by arojas (2013-01-09 10:04:53)

Offline

#3 2013-01-09 10:16:09

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

HIi, thanks for your reply. I forgot about this topic, I should have set this as solved. I did something simillar, here's my pkgbuild for future reference:

# $Id$
# Contributor: Mladen Pejaković <pejakm@gmail.com>

pkgname=qtwebkit
pkgver=2.3
pkgrel=1
arch=('i686' 'x86_64')
url='http://gitorious.org/+qtwebkit-developers/webkit/qtwebkit-23'
pkgdesc='An open source web browser engine (Qt port)'
license=('LGPL2.1' 'GPL3')
depends=('qt' 'gstreamer0.10-base' 'qtmobility')
makedepends=('python2' 'mesa' 'gperf' 'chrpath' 'ruby')
conflicts=('qt<4.8')
source=("http://gitorious.org/webkit/${pkgname}-23/archive-tarball/${pkgname}-${pkgver}")
sha1sums=('38135b6a9157e00c941be6c4957e51a38d1da944')

build() {
  cd "${srcdir}"/webkit-${pkgname}-23
  cd Tools/Scripts/

  QTDIR=/usr/share/qt ./build-webkit --prefix=/usr --qt --no-webkit2
# flags not enabled by default (unsafe, possible build fail):
# 	  --accelerated-2d-canvas \
# 	  --animation-api \
# 	  --battery-status \
# 	  --csp-next \
# 	  --css3-background \
# 	  --css3-conditional-rules \
# 	  --css3-text \
# 	  --css-grid-layout \
# 	  --css-hierarchies \
# 	  --css-image-orientation \
# 	  --css-image-resolution \
# 	  --css-shaders \
# 	  --css-variables \
# 	  --dashboard-support \
# 	  --datagrid \
# 	  --data-transfer-items \
# 	  --directory-upload \
# 	  --download-attribute \
# 	  --file-system \
# 	  --fullscreen-api \
# 	  --high-dpi-canvas \
# 	  --indexed-database \
# 	  --input-speech \
# 	  --input-type-date \
# 	  --input-type-datetime \
# 	  --input-type-datetimelocal \
# 	  --input-type-month \
# 	  --input-type-time \
# 	  --input-type-week \
# 	  --legacy-css-vendor-prefixes \
# 	  --link-prefetch \
# 	  --link-prerender \
# 	  --mathml \
# 	  --media-source \
# 	  --media-statistics \
# 	  --media-stream \
# 	  --microdata \
# 	  --navigator-content-utils \
# 	  --network-info \
# 	  --proximity-events \
# 	  --quota \
# 	  --scripted-speech \
# 	  --shadow-dom \
# 	  --style-scoped \
# 	  --svg-dom-objc-bindings \
# 	  --svg-fonts \
# 	  --text-autosizing \
# 	  --text-notifications-only \
# 	  --touch-icon-loading \
# 	  --vibration \
# 	  --video-track \
# 	  --web-audio \
}

package() {
  cd "${srcdir}"/webkit-${pkgname}-23
  make INSTALL_ROOT="${pkgdir}" -C WebKitBuild/Release install
}

Still need to tweak this so I don't have to symlink python2 to python.
I'm trying now with additional build flags (--accelerated-2d-canvas --css-shaders --download-attribute --directory-upload --fullscreen-api), with default flags I don't have webgl and css shader (although this blog post here says these should be working).

Offline

#4 2013-01-09 11:50:16

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

arojas, does webgl working for you with qtwebkit 2.3?

Last edited by Demon (2013-01-09 11:50:25)

Offline

#5 2013-01-09 14:39:49

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,207

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

No, webgl doesn't work, even when compiling with the --3d-rendering flag

Offline

#6 2013-01-09 15:20:12

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

I'm pushing qtwebkit 2.3git to [testing] right now. It should have webgl support (you need the whole gstreamer0.10-plugins group installed), please check it and let me know.

Offline

#7 2013-01-09 17:00:01

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,207

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

webgl still doesn't work here with qtwebkit from [testing]. Works in firefox and chromium, so it is definitely supported for my graphics card

Offline

#8 2013-01-09 17:03:48

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

arojas wrote:

webgl still doesn't work here with qtwebkit from [testing].

Demon told me the same.

Long catch: did you reboot/logout?

EDIT: how are you testing it?
I can listen/see videos on youtube, and I've no flashplugin installed.

Offline

#9 2013-01-09 18:28:43

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,207

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

ascarpino wrote:

EDIT: how are you testing it?
I can listen/see videos on youtube, and I've no flashplugin installed.

I think you're confusing webGL with HTML5 video.
HTML5 video also works fine here (it worked with qtwebkit 2.2 too). To test webGL go to http://get.webgl.org/. If it works, you'll see a cube rotating.

Offline

#10 2013-01-09 18:30:38

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

I'm getting this:

Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

which leds me to think I'm missing something very simple...

Offline

#11 2013-01-09 18:32:29

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

arojas wrote:

I think you're confusing webGL with HTML5 video.

Auch!

arojas wrote:

To test webGL go to http://get.webgl.org/. If it works, you'll see a cube rotating.

Ok, I don't have it neither...

Offline

#12 2013-01-10 02:05:19

abveritas
Member
Registered: 2012-05-04
Posts: 29

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

This is my webgl test site:
http://oos.moxiecode.com/js_webgl/snake/
I've been getting sound with all qtwebkit builds I've tried the last 3 months, no video, tried staging git, stable git, nightly tars from a few different weeks, set --enable all video options (or non), and compiled with all gstreamer-plugin packages, no luck.  Last qtwebkit with working webgl was 2.2.1.
Any suggestions welcome, there has to be a way to get this working again.

Same issue for Qt5 builds, webgl should just be part of it......
http://gitorious.org/chakra-packages/pl … 5/PKGBUILD

Last edited by abveritas (2013-01-10 02:10:24)

Offline

#13 2013-01-10 11:53:24

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Is Qt 4.8.4 in extra compiled with openGL? It appears that qtwebkit requires Qt to be configured with OpenGL for webgl to work.

Offline

#14 2013-01-10 12:02:40

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Btw, ascarpino, there's a new commit in qtwebkit-2.3 branch:

http://gitorious.org/webkit/qtwebkit-23 … 86a17be595

It's about those css shaders we spoked last night. Allan Sandfeld (carewolf) fixed it.

Offline

#15 2013-01-10 12:05:24

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Demon wrote:

Is Qt 4.8.4 in extra compiled with openGL? It appears that qtwebkit requires Qt to be configured with OpenGL for webgl to work.

Yes, it should have opengl support.

Demon wrote:

Btw, ascarpino, there's a new commit in qtwebkit-2.3 branch:

http://gitorious.org/webkit/qtwebkit-23 … 86a17be595

It's about those css shaders we spoked last night. Allan Sandfeld (carewolf) fixed it.

Ok, I'll rebuilt this later (say in the next 10 hours). If I don't, please file a bug report so I don't forget about it.

Offline

#16 2013-01-10 15:52:15

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

ascarpino wrote:

Ok, I'll rebuilt this later (say in the next 10 hours). If I don't, please file a bug report so I don't forget about it.

I apologize, I see now this is in qtwebkit-2.3-staging, so there's no need to recompile yet. Once again, sorry for this oversight.

Offline

#17 2013-01-10 16:48:21

abveritas
Member
Registered: 2012-05-04
Posts: 29

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Offline

#18 2013-01-10 16:51:58

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

abveritas, can you test, please?

Offline

#19 2013-01-10 18:37:53

abveritas
Member
Registered: 2012-05-04
Posts: 29

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Build qtwebkit 2.3 from the staging branch, still no working webgl, though at compile time, all is now set to enable (webgl_enable=1), plus the css_filters=1

Offline

#20 2013-01-11 18:54:48

abveritas
Member
Registered: 2012-05-04
Posts: 29

Re: [SOLVED] qtwebkit-2.3 compilation (PKGBUILD included)

Offline

Board footer

Powered by FluxBB