You are not logged in.

#1 2013-01-07 21:53:53

Druedain
Member
From: Poland
Registered: 2011-12-27
Posts: 50

Fan control

After upgrade today, CPU is constantly warmer and warmer, but one sensor shows 45, and fan is not working hmm

[wicu@arch:pkg]$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +45.0°C  (crit = +127.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +66.0°C  (high = +80.0°C, crit = +85.0°C)
Core 0:         +58.0°C  (high = +80.0°C, crit = +85.0°C)
Core 1:         +65.0°C  (high = +80.0°C, crit = +85.0°C)

I've upgraded today:
udisk2
upower
polkit
enca
lib32-nss

I thought that maybe downgrading upower will help for awhile, but after downgrading and restart, fan is still not working faster when cpu is hotter.

I'm sure that fan is ok. My laptop is quite new, and before KDE loads fan start working faster for a few seconds.

Offline

#2 2013-01-08 01:53:08

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Fan control

Perhaps try the steps here:

https://wiki.archlinux.org/index.php/Fan_Speed_Control

If it works, you can change the temperature at which the fan changes speed.

Offline

#3 2013-01-08 12:30:56

Druedain
Member
From: Poland
Registered: 2011-12-27
Posts: 50

Re: Fan control

I've suspended my laptop yesterday. Now everything is fine again without any action from me. Strange…

Now I'm afraid about upgrade. If I'll have any more problems, I'll write here again.

Offline

#4 2013-01-09 11:45:54

qinohe
Member
From: A Dutch location..)
Registered: 2012-06-20
Posts: 649

Re: Fan control

Druedain wrote:

I've suspended my laptop yesterday. Now everything is fine again without any action from me. Strange…

Now I'm afraid about upgrade. If I'll have any more problems, I'll write here again.

Things like this could happen..

The other day.. I switched into suspend to ram (day 6).. after waking, fan was going full speed..
Switched off my laptop, booted up and everything was fine again, nothing in the logs, so shoot me..;)
After days everything is still fine..
Wouldn't worry to much about it and do your upgrades, if things go wrong, you can troubleshoot afterwards!
Keep on rolling..


-I can give you a ladder, but you need to climb it yourself-

Offline

#5 2013-02-15 11:41:23

camwebb
Member
Registered: 2012-12-19
Posts: 3

Re: Fan control

Druedain wrote:

After upgrade today, CPU is constantly warmer and warmer, but one sensor shows 45, and fan is not working

Having the same issue after a large upgrade (Thinkpad X220, .Intel Core i5-2430M; to kernel 3.7.7-1). After wake from suspend, sometimes the fan cools the CPU, sometimes it doesn't. From scanning the Forum, looks like this may be a kernel issue: here, here, and here. Downgrading the kernel may help.

Last edited by camwebb (2013-02-15 11:51:53)

Offline

Board footer

Powered by FluxBB