You are not logged in.

#1 2013-01-05 17:59:40

drhannibal
Member
Registered: 2011-01-04
Posts: 7

Pulseaudio, Skype and VLC

Hi everyone wink
I recently acquired a RaspberryPi and wanted to use it as a remote sound server. As I could achieve this only by using PulseAudio, I installed and configured it. Now, I can easily switch from using the remote server and the local one with pax11publish.
However, now, neither VLC nor Skype makes any sound, although the issues may be different, because skype does produce sound when I use the remote server, while VLC never does.
I can manage the VLC issue by using mplayer which does work, but Skype is sadly not that easy to let go (friends and family, you know how it is…)

So here's the pulseaudio log from when I make a test sound in Skype. I can't see anything wrong in there (no errors), that's why I'm getting desperate here, everything seems to go fine, except I don't hear anything sad

Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c: Trying to change sample rate
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: Forcing resampler 'copy', because of fixed, identical s... rates.
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: Channel matrix:
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c:        I00
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c:     +------
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: O00 | 1.000
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: O01 | 1.000
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] remap_sse.c: Using SSE mono to stereo remapping
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: Using resampler 'copy'
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] resampler.c: Using s16le as working format.
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, bas...ewind=0
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=335544...ewind=0
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c: Created input 6 "Event Sound" on alsa_output.pci-0000_...ap mono
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     window.icon_name = "skype"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.icon_name = "skype"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     media.role = "event"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     media.name = "Event Sound"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.name = "Skype"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     native-protocol.peer = "UNIX socket client"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     native-protocol.version = "27"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.id = "27528"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.user = "drhannibal"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.host = "skaro"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.binary = "skype"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.language = "en_US.UTF-8"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     window.x11.display = ":0"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.machine_id = "e088edb7ac65ad44...000458"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     application.process.session_id = "1"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] sink-input.c:     module-stream-restore.id = "sink-input-by-media-role:event"
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] protocol-native.c: Requested tlength=20.02 ms, minreq=20.00 ms
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] protocol-native.c: Adjust latency mode enabled, configuring sink lat...atency.
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] protocol-native.c: Requested latency=0.00 ms, Received latency=0.50 ms
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] memblockq.c: memblockq requested: maxlength=4194304, tlength=3888, b...ewind=0
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=4194304, tlength=3888, b...ewind=0
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] protocol-native.c: Final latency 41.00 ms = 0.50 ms + 2*20.00 ms + 0.50 ms
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c: Requested volume: 0: 130% 1: 130%
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c:            in dB: 0: 6.87 dB 1: 6.87 dB
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c: Got hardware volume: 0: 100% 1: 100%
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c:               in dB: 0: 0.00 dB 1: 0.00 dB
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c: Calculated software volume: 0: 130% 1: 130% (accurate-enough=no)
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] alsa-sink.c:                      in dB: 0: 6.87 dB 1: 6.87 dB
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] sink.c: Volume not changing
Jan 05 18:52:31 skaro pulseaudio[24985]: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Stream added for obj...stream6
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] sink-input.c: Requesting rewind due to uncorking
Jan 05 18:52:31 skaro pulseaudio[24985]: [alsa-sink] protocol-native.c: Requesting rewind due to end of underrun.

Do you have and idea ?
Many thanks in advance wink

PS: I should mention that I usually use skype on paranoid mode with a different limited user and so on, but it doesn't work on my regular user either. If I could at least get the voice communication working with the regular user, it would be a minor pain than none at all tongue

Last edited by drhannibal (2013-01-05 18:04:43)

Offline

#2 2013-01-09 08:18:30

zanny
Member
Registered: 2012-10-05
Posts: 70

Re: Pulseaudio, Skype and VLC

Just some quick facepalms:

* Make sure Skype / VLC is using Pulseaudio as the sink.
* Make sure in pavu that Skype / VLC is outputting on your network sound device (they might default to the onboard audio or headphones).
* Make sure that pulse isn't muting on a per application basis either of them.

In /etc/pulse/default.pa, try setting on the line for udev:

load-module module-udev-detect tsched=0

Or if you don't use udev to detect audio devices, you can still turn off tsched on any hardware module. Skype and VLC always take issue.

Does it work if you plug in hdmi onto the RBP and try outputting on the digital channel?

Last edited by zanny (2013-01-09 08:19:06)

Offline

#3 2013-01-09 18:41:53

drhannibal
Member
Registered: 2011-01-04
Posts: 7

Re: Pulseaudio, Skype and VLC

zanny wrote:

Just some quick facepalms:

* Make sure Skype / VLC is using Pulseaudio as the sink.

How can I check that ? I checked the pulse log, and it seems Skype does talk to pulse.

zanny wrote:

* Make sure in pavu that Skype / VLC is outputting on your network sound device (they might default to the onboard audio or headphones).

That's the weird thing, Skype does output sound on the network server, but not on the local, which is the one I want to use it on (to plug a headset). VLC outputs only on the local one, though, but a tcpdump and the logs on the remote show that everything seems to go normally tongue

zanny wrote:

* Make sure that pulse isn't muting on a per application basis either of them.

In /etc/pulse/default.pa, try setting on the line for udev:

load-module module-udev-detect tsched=0

Or if you don't use udev to detect audio devices, you can still turn off tsched on any hardware module. Skype and VLC always take issue.

Does it work if you plug in hdmi onto the RBP and try outputting on the digital channel?

I kinda temporarily gave up on using VLC with the remote server, mplayer does the trick, actually. However, I'd like to get Skype on the local. I do

pax11publish -e -r

to make sure I'm using the local server (so basically, only the tcp module line has changed from stock config file)…

Thanks for your reply, I was getting desperate (I could use another computer to skype, though, but I don't understand why I can't manage to get with pulse what I had with alsa tongue . And I don't like to not understand…)

Offline

#4 2013-01-16 18:30:52

drhannibal
Member
Registered: 2011-01-04
Posts: 7

Re: Pulseaudio, Skype and VLC

I finally kinda gave up on that issue, but I thought I'd mention how : I wrote a bit of a script (basically a mv line) that allows me to switch between alsa and pulse, by moving the .asoundrc file. This way I can get my deported pulse server when I'm watching a movie, and the local alsa for Skype or when I'm away from home.

Dirty fix, I know…

Offline

#5 2013-01-17 01:44:40

haidut
Member
Registered: 2012-03-13
Posts: 16

Re: Pulseaudio, Skype and VLC

Perhaps you should just remove pulseaudio? My sound used to disappear sometimes and that solved it for me, can't say I miss it.

Offline

#6 2013-01-17 20:35:17

drhannibal
Member
Registered: 2011-01-04
Posts: 7

Re: Pulseaudio, Skype and VLC

The thing is I need pulseaudio to send sound to a remote server (on a rPi big_smile ), but sometimes, I don't want to, like with Skype, or if I'm away from home, in which cases I want the sound to come (and be captured) from the integrated card in my laptop

Offline

Board footer

Powered by FluxBB