You are not logged in.

#1 2013-01-08 22:03:46

Snark1994
Member
From: Wales
Registered: 2011-06-09
Posts: 30

[SOLVED] Problem after upgrade to Anki 2.0.4-1

Hiya,

Today pacman upgraded anki from 2.0.3-1 to 2.0.4-1, which seems to have broken anki.

When try to run Anki, I get a message saying

Please build and install the PortAudio Python bindings first.

(which I got before, when Anki worked correctly) and a popup saying

Error during startup:
Traceback (most recent call last):
  File "/usr/share/anki/aqt/main.py", line 42, in __init__
    self.setupAddons()
  File "/usr/share/anki/aqt/main.py", line 500, in setupAddons
    import aqt.addons
  File "/usr/share/anki/aqt/addons.py", line 13 in <module>
    from aqt.downloader import download
  File "/usr/share/anki/aqt/downloader.py", line 7, in <module>
    from anki.sync import httpCon
  File "/usr/share/anki/anki/sync.py", line 22, in <module>
    _proxy_info_from_environment =
httplib2.ProxyInfo.from_environment
AttributeError: 'module' object has no attribute 'ProxyInfo'

EDIT: Sorry, should I have made a bug report for this instead? I'll file one now.

Regards,

Last edited by Snark1994 (2013-01-09 22:13:48)


Snark1994

Offline

#2 2013-01-08 23:13:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

Offline

#3 2013-01-08 23:57:37

creatorlarryli
Member
Registered: 2012-09-03
Posts: 3

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

I confirm this is a bug. It has nothing to do with pyaudio. It seems there is some problem with sync.py. The problematic code quoted in the error messages runs without problem independently but fails when called by anki. We probably should file the bug in anki.

In the meantime, a dirty fix is to comment out the following to lines
  from anki.sync import httpCon
  import aqt.sync # monkey-patches httplib2
in /usr/share/anki/aqt/downloader.py.

After this, anki is usable but the sync function will be temporarily disabled.

Offline

#4 2013-01-09 07:26:32

Maxr
Member
From: Germany
Registered: 2011-02-04
Posts: 6

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

Same here. Using your workaround anki starts.

Offline

#5 2013-01-09 09:33:36

Snark1994
Member
From: Wales
Registered: 2011-06-09
Posts: 30

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

I reported the bug yesterday: https://bugs.archlinux.org/task/33340

I don't know what the procedure is, but I assume that an upstream bug will be opened if necessary...

python-pyaudio doesn't fix the problem, as already noted - and the message had appeared without an error in the previous version.

Last edited by Snark1994 (2013-01-09 10:07:50)


Snark1994

Offline

#6 2013-01-09 21:12:44

Hwesta
Member
Registered: 2013-01-09
Posts: 2

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

Turns out to be a packaging bug.  If you chmod /usr/share/anki/thirdparty/httplib2 to 644 instead of 640 it works again.  Should be fixed in the next release. smile

Offline

#7 2013-01-09 22:14:14

Snark1994
Member
From: Wales
Registered: 2011-06-09
Posts: 30

Re: [SOLVED] Problem after upgrade to Anki 2.0.4-1

As Hwesta said, fixed in Anki 2.0.4-2.


Snark1994

Offline

Board footer

Powered by FluxBB