You are not logged in.

#1 2013-01-09 19:10:43

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

xscreensaver errors when exiting X [Solved]

I'm using XFCE with no DM (starting it with just a exec startxfce4 in my .xinitrc). When I log out of XFCE and return to tty1, the console output from the session ends with this:

xinit: connection to X server lost
xscreensaver: 12:53:00: SIGHUP received: restarting...
xscreensaver: 12:53:00: running as mrkline/users (1000/100)


waiting for X server to shut down xscreensaver: 12:53:00: Can't open display: :0.0
xscreensaver: 12:53:00: running as mrkline/users (1000/100)

xscreensaver: 12:53:00: Errors at startup are usually authorization problems.
              But you're not logging in as root (good!) so something
              else must be wrong.  Did you read the manual and the FAQ?

              http://www.jwz.org/xscreensaver/faq.html
              http://www.jwz.org/xscreensaver/man.html

It seems as though either X or XFCE is sending it SIGHUP to indicate that X is shutting down, but instead of closing, xscreensaver attempts to restart itself! What could cause this behavior?

Last edited by slavik262 (2013-01-10 15:08:07)

Offline

#2 2013-01-09 23:01:58

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: xscreensaver errors when exiting X [Solved]

A signal catcher. For some reason Xscreensaver was made to always restart itself when you send it SIGHUP. I've been seeing this message for as long as I can remember but I never considered it a problem.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#3 2013-01-09 23:15:12

brebs
Member
Registered: 2007-04-03
Posts: 3,424

Re: xscreensaver errors when exiting X [Solved]

xscreensaver 5.20's README says:

Changes since 4.00:
...
* Made SIGHUP restart the daemon process

Weird.

Offline

#4 2013-01-10 11:40:28

brebs
Member
Registered: 2007-04-03
Posts: 3,424

Re: xscreensaver errors when exiting X [Solved]

A while ago I used this patch, to make it less annoying:

diff -Naur xscreensaver-5.19.orig/driver/xscreensaver.c xscreensaver-5.19/driver/xscreensaver.c
--- xscreensaver-5.19.orig/driver/xscreensaver.c	2012-08-25 04:49:42.002221871 +0700
+++ xscreensaver-5.19/driver/xscreensaver.c	2012-08-25 04:50:44.810882540 +0700
@@ -457,32 +457,6 @@
 
   describe_uids (si, stderr);
 
-  if (si->orig_uid && !strncmp (si->orig_uid, "root/", 5))
-    {
-      fprintf (stderr, "\n"
-          "%s: This is probably because you're logging in as root.  You\n"
-"              shouldn't log in as root: you should log in as a normal user,\n"
-"              and then `su' as needed.  If you insist on logging in as\n"
-"              root, you will have to turn off X's security features before\n"
-"              xscreensaver will work.\n"
-               "\n"
-"              Please read the manual and FAQ for more information:\n",
-               blurb());
-    }
-  else
-    {
-      fprintf (stderr, "\n"
-          "%s: Errors at startup are usually authorization problems.\n"
-"              But you're not logging in as root (good!) so something\n"
-"              else must be wrong.  Did you read the manual and the FAQ?\n",
-           blurb());
-    }
-
-  fprintf (stderr, "\n"
-          "              http://www.jwz.org/xscreensaver/faq.html\n"
-          "              http://www.jwz.org/xscreensaver/man.html\n"
-          "\n");
-
   fflush (stderr);
   fflush (stdout);
   exit (1);

Offline

Board footer

Powered by FluxBB