You are not logged in.

#1 2013-01-05 18:14:32

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Awesome Fullscreen

When I run a window in full screen in Awesome 3.5, there's always a bar across the bottom. This is true in every program I've tried, including chrome, firefox, smplayer, dolphin and vlc. Any ideas on how to fix this? It's very distracting while watching videos.

Thanks

Offline

#2 2013-01-05 18:20:04

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: Awesome Fullscreen

Can you give us a screenshot? Might help to figure out what that bar is.

Offline

#3 2013-01-05 22:07:39

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

It's a solid bar, and it's always the background color used in the menu bar of the app . . . for example, in Chome, it's that blue color, and with QT apps it's a gray color (matching the default Oxygen theme).

Offline

#4 2013-01-05 23:56:11

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Awesome Fullscreen

Are you using the program's built-in fullscreen function or awesome's fullscreen layout?

Offline

#5 2013-01-06 02:33:49

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

Not the fullscreen layout, but I have a key mapped to make windows fullscreen:

awful.key({ modkey,           }, "q",      function (c) c.fullscreen = not c.fullscreen  end),

I've also tried the builtin fullscreen functions in the video players and browsers. They behave the same way. Since you suggested, I tried the awesome fullscreen layout. It doesn't behave quite the same way, since it doesn't really make the programs full screen . . . just maximizes them and hides the awesome bar thing. So, I still have the problem either way.

Thanks for the suggestion

Offline

#6 2013-01-08 18:20:55

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

Is anyone seeing this problem besides me? Can anyone using awesome 3.5 confirm or deny that this occurs . . . it's driving me a bit crazy. Almost enough to switch window managers.

Offline

#7 2013-01-08 18:29:39

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Awesome Fullscreen

Using awesome 3.5 and fullscreen works fine here. I tried both the awesomewm keybind and the builtin program shortcut.

Offline

#8 2013-01-08 18:31:42

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

Damn. I guess I'll try going back to a default config and theme again, and see if that fixes anything. Thanks for the sanity check.

Offline

#9 2013-01-08 20:20:55

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: Awesome Fullscreen

I'm also on awesome 3.5 and don't have any problems.

Some random thoughts:

  1. Is there any kind of interaction possible with the bar? Does it do something when clicked, or show something?

  2. What about programs, which don't use qt/gtk? Like pure mplayer or urxvt?

  3. Anything special about your rc.lua? Does it also happen with the default rc.lua? If not, post your rc.lua and theme.lua

  4. Downgrading to 3.4.x solves your problem?

  5. Have you checked the awesome bugtracker, if someone has already reported this?

Offline

#10 2013-01-08 20:36:38

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

1. There doesn't seem to be anything interactive about the bar
2. All programs are affected, gtk, qt, and my beloved urxvt . . . although urxvt doesnt' bother me, because it's just additional black space
3. When 3.5 came out, I switched to the default rc.lua conf, and then added the features I wanted from my 3.4 rc.lua file . . . just keybindings, and disabling layouts I don't use. Nothing too special, but I will try it with the default setup when I get home
4. Haven't tried downgrading yet, but will also do that
5. I don't see anything in the awesome bugtracker . . . if the problem still occurs with default theme.lua and rc.lua, I'll report the bug.

Thanks

Offline

#11 2013-01-08 21:09:29

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: Awesome Fullscreen

Try xprop on that bar. Maybe it doesn't even belong to the actual program running in fullscreen.
You should also check if awesome is really causing this. Run an affected program without any window manager and put it to fullscreen.

Offline

#12 2013-01-11 03:47:19

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

The problem went away with the default config . . . looks like I should start from scratch (again). Thanks for the tips.

Offline

#13 2013-01-11 04:00:46

deadrabbit
Member
Registered: 2008-04-26
Posts: 118

Re: Awesome Fullscreen

After stepping through the default config, and applying my  changes one by one, I found that this line was the problem:

local titlebars_enabled = true

The default setting is false. Changing it to true causes the problem. I'm not entirely sure whether this is a bug, or something else in the config I don't understand, but I'm going to file a bug in any case.

Offline

Board footer

Powered by FluxBB