You are not logged in.

#1 2013-01-11 10:50:19

Registered: 2013-01-08
Posts: 7

Power saving issues on Lenovo X220

I have recently installed arch x86_64 on Lenovo X220 and I have some power saving issue (on both current core kernel and lts kernlel but different issues on each).

- I have pcie_aspm=force i915.i915_enable_rc6=1 in my kernel line

On core kernel
- although ondemand governor is loaded cpu it seems that frequency is not changing (according to /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq and power consumption)
- powertop is saying scalling works
- temperature is quite high (usually over 60 degree celsius)
- phc-intel is not showing any vids (/sys/devices/system/cpu/cpu0/cpufreq/phc_vids cotains 0 0 0 0 0 0 0 0 0 0)
- cpufreq module is loaded and powertop shows scaling should work
- battery time is around 2 hours (on Win it is 4-6 hours)
- powertop is idicating discharge rate around 22 W

On LTS kernel from core repo
- cpufreq does not load:

$ sudo modprobe acpi_cpufreq
modprobe: ERROR: could not insert 'acpi_cpufreq': Device or resource busy
modprobe: ERROR: Error running install command for acpi_cpufreq
modprobe: ERROR: could not insert 'acpi_cpufreq': Operation not permitted

   - even if I add it to modules-load.d it fails with device or resource busy
- phc-intel module loads (manually) but is not showing any vids
- frequency is scaling (it seems to be scaling according to bios setting: 800Mhz on battery and full scalling with AC power)
   - it can be detected (probably) correnty by powertop and /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq
- battery time is indicated to be around 4 hours
- powertop is indicating discharge rate 10-12 W
- tp_smapi module does not load (it does in core kernel, though I'm not sure if it works properly)
- teperature is around 48 degree celsius in idle which is I believe comparable to windows.

Does anyone have any idea how to solve those issues?
(I'm not really depending on new kernel so I can stay with lts as it works though it seems wierd to me that cpufreq cannot be loaded)


#2 2013-01-11 16:09:14

Registered: 2012-03-01
Posts: 22

Re: Power saving issues on Lenovo X220

See this thread:

I've personally rolled back to 3.5.6 and have no issues. Alternatively, you can try some of the fixes noted in here (installing some of these patched kernels). If I recall correctly, there are people in this thread with the same machine as you.


#3 2013-01-11 17:01:18

Registered: 2013-01-08
Posts: 7

Re: Power saving issues on Lenovo X220

Thank you very much, I should have searched whole formum not just Laptop issues...

Downgrade to 3.5.6 seems to fix this to work at least as good as on lts but without problems I had with lts (3.0) except for vids which are probably whole different problem.


Board footer

Powered by FluxBB