You are not logged in.

#1 2013-01-12 13:42:25

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,844
Website

urxvt mouse selection is driving me insane

hi... for months now i am struggling to get mouse selection in urxvt to work reliably. Its just totally frakked.
have a look what it always does for me:

http://paste.xinu.at/PTnahG/


Anyone a clue what this is? can it be fixed? Blockselect works fine, just normal selecting is not.


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#2 2013-01-12 14:36:53

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: urxvt mouse selection is driving me insane

I've got that as well, pretty annoying indeed!
I haven't got the time yet to try and solve it myself though...

Offline

#3 2013-01-12 16:03:10

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,810
Website

Re: urxvt mouse selection is driving me insane

That's odd.  That looks like the right mouse button behavior, not left.  Do you get something different with the other button?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-01-13 04:08:04

rockin turtle
Member
From: Montana, USA
Registered: 2009-10-22
Posts: 218

Re: urxvt mouse selection is driving me insane

You probably have somethink like

URxvt.url-launcher: firefox

In your .Xresources/.Xdefaults file.  I see in your video that you were trying to 'select' a URL.

urxvt is probably confused as to whether you want to click on a link for your web browser or select some text.  I just fixed this for myself by adding the following to my .Xresources file.

URxvt.matcher.button: 2

Now I can use mouse button 1 to select text, and the middle button to launch a web browser for a URL.  I always thought that the middle button was button 3, but my .Xresources is as above and my middle button launches so whatever is going on is ok by me.

Note: I also have

URxvt.perl-ext-common: default,matcher

in .Xresources as well.

Offline

Board footer

Powered by FluxBB