You are not logged in.

#1 2005-11-03 04:09:08

From: Berlin
Registered: 2005-10-27
Posts: 419

Problem with my IDE controller card (PCI Silicon Image...)

Hey smile

my IDE controller causes me headaches, perhaps someone can help me?

First my config:
hda: Harddisk with WinXP, Arch, swap
hdb: Harddisk with NFS-Files
hdc: DVD-ROM
hdd: NEC ND1300A

PCI IDE ATA controller: 1 Harddisk with NTFS-Files

i installed Arch on hda2 with the IDE controller + HDD plugged in and everything went fine. But with the migration to udev came the problems: if i let the ide controller plugged in the PCI-Slot, no matter if with or without HDD, the kernel can't boot my rootpartition (hda2)... i also tried with hdb, hdc etc but nothing worked. If i pull out the ide controller everything works fine without a change...

Ok so its obvious, that the card is messing up sth with the HDD-config but how can i fix that?

Do I have to use the scsi kernel and define my root-partition as sda2? (it hangs on IDE channel ONE) or is it possible to simply load a scsi-module or sth like that?

As long as i used devfs there was no problem (i had ignorepkg=kernel26 in my pacman.conf for some time) just with the first boot on udev there was sth no more working correctly, which leads me also to the conclusion with the scsi-things...

Opinions, Suggestions?

Good Night smile

hellwoofa aka jakob

edit: What i forgot to write yesterday was, that when i had the card with the HDD plugged in and was using devfs, my menu.lst looked like that:

title Arch
root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/discs/disc1/pacrt2 ro

Sounds strange but this was the only way i could boot up with this controller


Board footer

Powered by FluxBB