You are not logged in.

#1 2013-01-15 14:12:50

Ztjuh
Member
Registered: 2011-05-30
Posts: 40

Webcam can only run as root and has white screen.

When I start guvcview as a normal user I get:

video device: /dev/video0
ERROR opening V4L2 interface for /dev/video0
unable to detect video devices on your system (0)
ERROR opening V4L interface: Permission denied
Init video returned -1
VIDIOC_REQBUFS - Failed to delete buffers: Invalid argument (errno 22)
cleaned allocations - 100%
Closing portaudio ...OK

I've added my username to video with:

gpasswd -a ztjuh video

But when I type groups my username is only in users?

/etc/group

video:x:91:ztjuh

Also done:

chgrp video /dev/video0
chmod 660 /dev/video0

When I run guvcview as root it starts but I only see a white screen...

dmesg:

[116575.225069] usb 2-1: new full-speed USB device number 2 using ohci_hcd
[116575.585463] Linux media interface: v0.10
[116575.605460] Linux video capture interface: v2.00
[116575.617026] gspca_main: v2.14.0 registered
[116575.632533] gspca_main: pac207-2.14.0 probing 093a:2460
[116575.646211] input: pac207 as /devices/pci0000:00/0000:00:03.0/usb2/2-1/input/input8
[116575.649322] usbcore: registered new interface driver pac207
[120867.876828] usbcore: registered new interface driver uvcvideo
[120867.876838] USB Video Class driver (1.1.1)
[121241.639963] gspca_main: ISOC data error: [25] len=0, status=-18
[121243.579750] gspca_main: ISOC data error: [22] len=0, status=-18
[121243.963692] gspca_main: ISOC data error: [30] len=0, status=-18
[121244.475635] gspca_main: ISOC data error: [26] len=0, status=-18
[121246.587545] gspca_main: ISOC data error: [25] len=0, status=-18
[121249.499155] gspca_main: ISOC data error: [20] len=0, status=-18
[121255.866594] gspca_main: ISOC data error: [28] len=75, status=-70
[121259.610257] gspca_main: ISOC data error: [30] len=0, status=-18
[121262.010000] gspca_main: ISOC data error: [20] len=0, status=-18
[121264.025833] gspca_main: ISOC data error: [24] len=0, status=-18
[121265.593715] gspca_main: ISOC data error: [30] len=0, status=-18
[121265.657674] gspca_main: ISOC data error: [19] len=0, status=-18
[121270.393230] gspca_main: ISOC data error: [19] len=0, status=-18
[121272.633014] gspca_main: ISOC data error: [14] len=61, status=-70

lsmod | grep gspca:

gspca_pac207            5689  0
gspca_main             21713  1 gspca_pac207
videodev              100860  4 uvcvideo,gspca_pac207,gspca_main,videobuf2_core
usbcore               150472  5 uvcvideo,gspca_pac207,ohci_hcd,ehci_hcd,gspca_main

Someone know some direction?

Last edited by Ztjuh (2013-01-15 14:16:53)

Offline

#2 2013-01-15 18:35:19

Ztjuh
Member
Registered: 2011-05-30
Posts: 40

Re: Webcam can only run as root and has white screen.

I followed this and installed the new modules without recomping the kernel, rebooted and it works, now im in the video group too all of the sudden, but the

gspca_main: ISOC data error: [25] ln=0, status =-18

remains.

http://git.linuxtv.org/media_build.git

Last edited by Ztjuh (2013-01-15 18:36:45)

Offline

Board footer

Powered by FluxBB