You are not logged in.

#1 2013-01-14 23:11:19

forshark
Member
Registered: 2013-01-03
Posts: 34

[SOLVED] libreoffice "loading document after login takes 30+ sec"

I have an arch install running xfce and lxdm as my login manager I have installed libreoffice per wiki instructions and configured memory optimizations as follows:

Under Memory:
  - Reduced the number of Undo steps 20 steps.
  - Under Graphics cache, I set Use for LibreOffice to 128 MB.
  - I Set Memory per object to 20MB.
  - I Checked LibreOffice Quickstarter.

However, It still takes about 45 seconds to load any document, spreadsheet, or presentation after logging in. However when I load a second or third... document, spreadsheet, or presentation they load near instantly. Furthermore, if I open a terminal and type "libreoffice --writer /path/to/doc," I receive no errors or any verbose message. Has anyone encountered this? Any help would be greatly appreciated.

Last edited by forshark (2013-01-16 01:21:48)

Offline

#2 2013-01-15 01:11:06

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] libreoffice "loading document after login takes 30+ sec"

This could be as simple as it loads modules as you need them, such as the module for opening documents. If so, there is no way around it, but I may be wrong. The only way to diffidently find out is to browse the sourcecode to see about it's module loading.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#3 2013-01-15 12:36:29

forshark
Member
Registered: 2013-01-03
Posts: 34

Re: [SOLVED] libreoffice "loading document after login takes 30+ sec"

Possibly, but how due I trace what libreoffice is doing at load time?

Offline

#4 2013-01-15 16:50:54

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,321

Re: [SOLVED] libreoffice "loading document after login takes 30+ sec"

I use LXDE/openbox, and there's no option for quickstarter under memory on my system.

typical loadtime for me at first time is 15-20 seconds, and later starts are lightningfast.
Try disabling quickstarter to see if it makes any difference.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#5 2013-01-16 01:20:54

forshark
Member
Registered: 2013-01-03
Posts: 34

Re: [SOLVED] libreoffice "loading document after login takes 30+ sec"

Ok, I have solved libreoffice's unacceptable behavior on my machine by:

appending "/etc/hosts" with the following:

127.0.0.1 $HOSTNAME localhost $HOSTNAME.(none)

with $HOSTNAME actually spelled out

ex "127.0.0.1 archden localhost archden.(none)"

With this miracle cure your libreoffice installation will fall within an acceptable standard of behavior.

PS. praying libreoffice is far more glorious in this respect.

Offline

Board footer

Powered by FluxBB