You are not logged in.

#1 2013-01-16 18:44:04

prab
Member
From: Chennai
Registered: 2012-04-29
Posts: 14
Website

[SOLVED] Pacman upgrade issue due to Intellij Idea

Here is the error

[root@RAS ~]# pacman -Syu
:: Synchronizing package databases...
 core                                                                 106.0 KiB  51.3K/s 00:02 [#######################################################] 100%
 extra                                                               1441.9 KiB   136K/s 00:11 [#######################################################] 100%
 community                                                           1893.2 KiB   137K/s 00:14 [#######################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: intellij-idea-community-edition: requires intellij-idea-libs=12.0.1
[root@RAS ~]# 
[root@RAS ~]# uname -a
Linux RAS 3.6.11-1-pae #1 SMP PREEMPT Fri Jan 4 12:53:00 IST 2013 i686 GNU/Linux
[root@RAS ~]# 

Please help.
If you need any other information about the system, please ask.

Last edited by prab (2013-01-17 03:00:44)

Offline

#2 2013-01-16 18:58:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,326

Re: [SOLVED] Pacman upgrade issue due to Intellij Idea

Try again with a different mirror? Looks like there is about 40 minutes between the the "Last Updated" times of the two packages, your mirror probably last synced in that gap.

Last edited by Scimmia (2013-01-16 18:59:37)

Offline

#3 2013-01-16 19:20:07

tdy
Member
From: Sacremende
Registered: 2008-12-14
Posts: 438

Re: [SOLVED] Pacman upgrade issue due to Intellij Idea

Just to expand on that, you can see that intellij-idea-community-edition is always tied to a very specific version of the libs (intellij-idea-libs=12.0.1, intellij-idea-libs=12.0.2, etc). The likely situation is that your mirror has gotten the intellij-idea-libs-12.0.2 sync, but is still on intellij-idea-community-edition-12.0.1. pacman won't let you upgrade the libs to 12.0.2 if you're still on 12.0.1 of the IDE, hence Scimmia's suggestion to switch mirrors, or just wait it out.

Offline

#4 2013-01-17 02:59:40

prab
Member
From: Chennai
Registered: 2012-04-29
Posts: 14
Website

Re: [SOLVED] Pacman upgrade issue due to Intellij Idea

Thanks Scimmia and tdy!
I changed the mirror to Japan's ftp.jaist.ac.jp one but after that, running pacman -Syu said core up to date, community up to date, extra up to date.
Then I did

# mv /var/lib/pacman/sync /var/lib/pacman/sync.bak

Afterwards pacman -Syu worked correctly and upgraded Intellij Idea to 12.0.2-1!!!
Hopefully the second step I posted will help someone :-)

Offline

#5 2013-01-17 03:22:39

tdy
Member
From: Sacremende
Registered: 2008-12-14
Posts: 438

Re: [SOLVED] Pacman upgrade issue due to Intellij Idea

Just fyi, you don't need to do this manually. You add an extra 'y' to force a refresh of the package db:

# pacman -Syyu

Glad you got it sorted out.

Last edited by tdy (2013-01-17 03:23:06)

Offline

#6 2013-01-17 10:49:51

prab
Member
From: Chennai
Registered: 2012-04-29
Posts: 14
Website

Re: [SOLVED] Pacman upgrade issue due to Intellij Idea

tdy wrote:

Just fyi, you don't need to do this manually. You add an extra 'y' to force a refresh of the package db:

# pacman -Syyu

Glad you got it sorted out.

Thanks tdy!! Learnt a new thing today :-)

Offline

Board footer

Powered by FluxBB