You are not logged in.

#1 2013-01-15 23:15:28

innocent_rifle
Member
Registered: 2013-01-07
Posts: 5

Speakers do not work but headphones do

I've just installed alsa and other necessary tools. But i can't make my speakers work. When plugging headphones everything is ok. The OS is running on Acer Aspire 1410. I've already tried different settings in alsamixer without any help. What should I do to make my speakers work?

lsmod | grep snd

snd_hda_codec_hdmi     22049  1 
snd_hda_codec_realtek    52472  1 
snd_hda_intel          22257  5 
snd_hda_codec          83678  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               4843  1 snd_hda_codec
snd_pcm                61958  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          5902  2 snd_pcm,snd_hda_intel
snd_timer              14903  1 snd_pcm
snd                    45098  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               4379  1 snd

amixer

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 11142 [17%] [off]
  Front Right: Capture 11142 [17%] [off]

Offline

#2 2013-01-17 02:49:13

Bandit Bowman
Member
Registered: 2010-08-25
Posts: 18

Re: Speakers do not work but headphones do

Obvious question: are you sure it's not a hardware problem, do the speakers actually work?
I'm using an Acer Aspire A110 and I have snd-pcm-oss in /etc/modules-load.d for some reason. I don't remember why I put it there, but you could try modprobing it.

lsmod |grep snd

snd_hda_codec_realtek    52472  1 
snd_hda_intel          22257  4 
snd_hda_codec          83678  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4843  1 snd_hda_codec
snd_pcm_oss            33446  0 
snd_mixer_oss          12960  1 snd_pcm_oss
snd_pcm                61958  4 snd_pcm_oss,snd_hda_codec,snd_hda_intel
snd_page_alloc          5902  2 snd_pcm,snd_hda_intel
snd_timer              14903  2 snd_pcm
snd                    45098  14 snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel,snd_mixer_oss
soundcore               4379  1 snd

Offline

#3 2013-01-17 03:10:51

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: Speakers do not work but headphones do

Offline

Board footer

Powered by FluxBB