You are not logged in.

#1 2013-01-17 14:01:35

zero-giulio
Member
Registered: 2010-01-23
Posts: 70

LXDM start on wrong monitor

I have Arch Linux on my laptop, and I have a LCD connected to such laptop.
99% of the time, LCD is not used (i.e., it's used, but as TV, not connected to the laptop), so that I work only on laptop's monitor.

The problem is that LXDM always appears on the LCD, and this is a problem: laptop's monitor remain black, while LCD is either turned off or set to TV (so that I have to change source on LCD, logging in, then rechange the source of LCD).

This is annoying.
Why LXDM want to start on LCD?

I set correctly my xorg.conf, enabling only one monitor: in fact, after login everything works fine.
Also, every further login/logout works fine: LXDM starts on laptop's monitor.
Is only the very first (i.e., after reboot) login starts on LCD and it's making me crazy.

How can I force LXDM to IGNORE the connected LCD?

Offline

#2 2013-01-18 00:49:45

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 168

Re: LXDM start on wrong monitor

My first thought is that LXDM has a configuration that makes it do that out of convienance, for example if you smashed your laptop's screen and wanted to use it, you would want that to happen, correct? You could try browsing it's configuration files, or do a bit of googling on it.

Well enough of my ranting. My first thought would be to disable automatic detection of external monitors, then have your DE start the external monitor.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#3 2013-01-18 17:30:49

zero-giulio
Member
Registered: 2010-01-23
Posts: 70

Re: LXDM start on wrong monitor

How to do that?
(disable automatic detection)

Offline

Board footer

Powered by FluxBB