You are not logged in.

#4651 2013-01-13 09:35:25

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

So does anyone have recent results with the 7970?  I am building a new system this week and I'll be installing Arch.  Hopefully fglrx won't give me too much shit...

Offline

#4652 2013-01-13 11:46:53

appleworm
Member
Registered: 2013-01-10
Posts: 18

Re: The AMD/ATI Bar & Grill

I am quite new to Arch. I have a problem with getting my catalyst drivers working properly. Dual GPU (APU + 6650M) on my laptop, Xorg 1.13, Catalyst 12.11 beta from AUR, kernel 3.6.11-1 and this is the result (Xorg.0.log) : https://gist.github.com/4521646. Should I try linux-lts kernel ? Or older Xorg, for example 1.12 ?
Output from glxgears :

BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

With "aticonfig --initial" xorg.conf the screen is black. When I remove it, it works on VESA. This is the config file : http://pastebin.com/x2USnzjN

Thank you for replies, I will provide any useful information.

Offline

#4653 2013-01-13 11:59:47

ChemBro
Member
Registered: 2008-10-22
Posts: 668

Re: The AMD/ATI Bar & Grill

Did you set "nomodeset" in your grub or syslinux or so as a boot parameter?

Offline

#4654 2013-01-13 12:24:00

appleworm
Member
Registered: 2013-01-10
Posts: 18

Re: The AMD/ATI Bar & Grill

ChemBro wrote:

Did you set "nomodeset" in your grub or syslinux or so as a boot parameter?

Yes, of course :-)

Edit : YES !! The ALMIGHTY package "catalyst-total" has solved it !!! Thanks for this package !!! :-)

Last edited by appleworm (2013-01-13 14:44:13)

Offline

#4655 2013-01-14 13:50:33

andesho91
Member
From: London, UK
Registered: 2011-11-20
Posts: 71

Re: The AMD/ATI Bar & Grill

appleworm wrote:

I am quite new to Arch. I have a problem with getting my catalyst drivers working properly. Dual GPU (APU + 6650M) on my laptop, Xorg 1.13, Catalyst 12.11 beta from AUR, kernel 3.6.11-1 and this is the result (Xorg.0.log) : https://gist.github.com/4521646. Should I try linux-lts kernel ? Or older Xorg, for example 1.12 ?
Output from glxgears :

BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

With "aticonfig --initial" xorg.conf the screen is black. When I remove it, it works on VESA. This is the config file : http://pastebin.com/x2USnzjN

Thank you for replies, I will provide any useful information.

I have the 6480G and I use catalyst-hook and xorg from Vi0l0's repo, same kernel and and I have linux-headers installed. How is it working with xorg 1.13? I've never manage to get X to work with catalyst and zorg 1.13


Laptop: AMD A4-3305M, 4GB RAM, Archlinux 64bit with XFCE4 and Linux Mint Maya with MATE.

Offline

#4656 2013-01-15 20:35:47

mannemerak
Member
Registered: 2010-03-03
Posts: 14

Re: The AMD/ATI Bar & Grill

I have a Dell Vostro 3560, hybrid Intel - AMD Radeon HD 7600M

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Trying to get the PowerXpress working with AUR package <catalyst-total-pxp 12.11-2>

Have the following packages installed (intel and xorg-server kept back as per wiki)
linux 3.6.11-1
linux-headers 3.6.11-1
xorg-server 1.12.4-1
xorg-server-common 1.12.4-1
xorg-server-utils 7.6-3
catalyst-total-pxp 12.11-2
xf86-video-intel 2.20.2-2

<fglrx> module loads fine, <nomodeset> in grub.conf
[   10.220881] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[   10.225071] <6>[fglrx] Maximum main memory to use for locked dma buffers: 5654 MBytes.
[   10.225223] <6>[fglrx]   vendor: 1002 device: 6840 count: 1
[   10.225395] <6>[fglrx] ioport: bar 4, base 0x4000, size: 0x100
[   10.225457] <6>[fglrx] Kernel PAT support is enabled
[   10.225468] <6>[fglrx] module loaded - fglrx 9.1.11 [Oct 18 2012] with 1 minors

<xorg.conf> generated by aticonfig --initial
------------------------------
Section "ServerLayout"                                                                                                                         
        Identifier     "aticonfig Layout"                                                                                                     
        Screen      0  "aticonfig-Screen[0]-0" 0 0                                                                                             
EndSection     

Section "Module"                                                                                                                               
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
------------------------------

When starting X I get segfault:

X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.4.8-1-ARCH x86_64
Current Operating System: Linux hanslinuxbox 3.6.11-1-ARCH #1 SMP PREEMPT Tue Dec 18 08:57:15 CET 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=7d66bfff-6254-4eb4-a38b-e5ad6b7f97da ro init=/usr/lib/systemd/systemd quiet nomodeset
Build Date: 27 August 2012  08:04:39AM

Current version of pixman: 0.28.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 16 01:26:38 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"

Backtrace:
0: X (xorg_backtrace+0x36) [0x560366]
1: X (0x400000+0x1640c9) [0x5640c9]
2: /usr/lib/libpthread.so.0 (0x7f1fe86c3000+0xf1e0) [0x7f1fe86d21e0]
3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxFreeScreen+0xed) [0x7f1fe4ffa92d]
4: X (xf86DeleteScreen+0x7c) [0x479d4c]
5: X (InitOutput+0x9f4) [0x473224]
6: X (0x400000+0x23476) [0x423476]
7: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7f1fe7553a15]
8: X (0x400000+0x238ed) [0x4238ed]

Segmentation fault at address 0x38

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Offline

#4657 2013-01-18 07:33:50

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

catalyst 13.1
was just released. There's a couple of bugfixes here and there, also for powerXpress support.
I will test it and update after getting back from work


Edit:
Ok, 13.1 seems fine - affter few tests i can say that it's working pretty good and stable (better than 12.11 betas).
I've updated packages in both AUR and repo, also added my testing patch to bring 3.8 kernel support (patch was working up to rc3, im compiling rc4 right now, edit: yep, works on rc4).


ChrisXY wrote here that pxp package can now work with xf86-video-intel-git, this also meens that pxp users should be able to work on xserver 1.13. Chris also wrote that he had to make a symlink to /usr/lib64 to get pxp to work.
I have moved switching scripts into /usr/lib months ago, because amd has removed it's hard paths from binary, it's possible that i must to put those scripts into /usr/lib64 once again. Will check it soon.

Last edited by Vi0L0 (2013-01-18 17:53:02)

Offline

#4658 2013-01-18 20:48:12

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,469
Website

Re: The AMD/ATI Bar & Grill

^ It's also in [community-testing] (and [multilib-testing]) and I just updated to it. Everything is running smoothly so far, animations are fluent and window movement is too (albeit with export CLUTTER_VBLANK=none in ~/.xprofile).


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4659 2013-01-18 21:58:44

ChemBro
Member
Registered: 2008-10-22
Posts: 668

Re: The AMD/ATI Bar & Grill

Reading through the pacman output... What is atieventsd?

Offline

#4660 2013-01-18 22:27:00

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,469
Website

Re: The AMD/ATI Bar & Grill

ChemBro wrote:

Reading through the pacman output... What is atieventsd?

http://www.linuxcertif.com/man/8/atieventsd/

That's all I can give you tongue I asked the same a while back but never really understood much of its purpose. I think it's safe to ignore this, at least I have never bothered with it.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4661 2013-01-18 23:13:58

ChemBro
Member
Registered: 2008-10-22
Posts: 668

Re: The AMD/ATI Bar & Grill

Thanks Unia.

@13.1: Man, this driver is such a dissapointment. "Resolved performance for Valve Linux games" my ass. TF2 is now unplayable for me. And Serious Sam 3 is (slightly) worse than with the beta driver. What the hell has AMD done?

Offline

#4662 2013-01-19 16:27:21

pYrO1v1aniac
Member
Registered: 2011-11-03
Posts: 46

Re: The AMD/ATI Bar & Grill

Just installed Catalyst-total, did a purge of all ATI related configs, files, etc, glad to say the pesky watermark is gone.

I'll test over the next few days, benchmark, etc. For now, looks like  a safe upgrade.

Thanks Vi0L0

Offline

#4663 2013-01-21 11:26:04

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

Using legacy drivers, catalyst-hd234k repo. I am getting :

pacman -Syu

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.7

Offline

#4664 2013-01-21 12:07:00

andesho91
Member
From: London, UK
Registered: 2011-11-20
Posts: 71

Re: The AMD/ATI Bar & Grill

omeringen wrote:

Using legacy drivers, catalyst-hd234k repo. I am getting :

pacman -Syu

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.7

You could either hold it for a bit until 3.7 comes to stable, or upgrade linux to the version in [testing] or a kernel repository which updates quicker. Do the latter at your own risk.

In this case, I would go into /etc/pacman.conf and add linux to the packages to update first (if you're lazy, just sudo pacman -S linux). That way you update linux, and then can update catalyst.

Last edited by andesho91 (2013-01-21 12:11:10)


Laptop: AMD A4-3305M, 4GB RAM, Archlinux 64bit with XFCE4 and Linux Mint Maya with MATE.

Offline

#4665 2013-01-21 13:19:07

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

omeringen wrote:

Using legacy drivers, catalyst-hd234k repo. I am getting :

pacman -Syu

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.7

catalyst package was precompiled for 3.6 kernel, and so it won't work on 3.7
After getting back from work i will update it. edit: done

Last edited by Vi0L0 (2013-01-21 17:58:58)

Offline

#4666 2013-01-21 13:29:18

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 668

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
omeringen wrote:

Using legacy drivers, catalyst-hd234k repo. I am getting :

pacman -Syu

error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst: requires linux<3.7

catalyst package was precompiled for 3.6 kernel, and so it won't work on 3.7
After getting back from work i will update it.

Current build of catalyst-hook works great with linux 3.7 (tested with linux-ck).

Offline

#4667 2013-01-21 22:08:20

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

A friend of mine just share me the news:
13.1 legacy
http://support.amd.com/us/gpudownload/l … linux.aspx
Who would have thought?! cool
Too bad i gotta sleep, will update it tomorrow!

Offline

#4668 2013-01-22 04:42:03

Reded
Member
From: Manchester, England
Registered: 2012-02-21
Posts: 233

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

A friend of mine just share me the news:
13.1 legacy
http://support.amd.com/us/gpudownload/l … linux.aspx
Who would have thought?! cool
Too bad i gotta sleep, will update it tomorrow!

NOO! I WANT MY NEW LEGACY NOW! big_smile

Look forward to it, I just read the news and rushed here to see if we've gotten it yet! big_smile Thanks for  packaging when you do!


"Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying "End-of-the-World Switch. PLEASE DO NOT TOUCH", the paint wouldn't even have time to dry."

Offline

#4669 2013-01-22 05:54:38

siavashserver
Member
From: Tehran, Iran
Registered: 2011-02-11
Posts: 73

Re: The AMD/ATI Bar & Grill

Looking forward for proper xorg-server 1.13 support and ability to use kwin with direct GL rendering enabled! Thanks Vi0L0 smile

Offline

#4670 2013-01-22 06:04:31

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 674
Website

Re: The AMD/ATI Bar & Grill

siavashserver wrote:

Looking forward for proper xorg-server 1.13 support and ability to use kwin with direct GL rendering enabled! Thanks Vi0L0 smile

I couldn't get it to work with xorg-server 1.13; we're still stuck with 1.12.

Error when running with xorg-server 1.13:

[    16.416] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    16.857] (EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

Offline

#4671 2013-01-22 06:57:23

siavashserver
Member
From: Tehran, Iran
Registered: 2011-02-11
Posts: 73

Re: The AMD/ATI Bar & Grill

foutrelis wrote:
siavashserver wrote:

Looking forward for proper xorg-server 1.13 support and ability to use kwin with direct GL rendering enabled! Thanks Vi0L0 smile

I couldn't get it to work with xorg-server 1.13; we're still stuck with 1.12.

Error when running with xorg-server 1.13:

[    16.416] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    16.857] (EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

I've read similar reports in other forums too; This is so disappointing, after six months they didn't even cared/managed to get legacy drivers working with xorg-server 1.13; Probably it will get working with 1.13 , when 1.15 is out hmm

At the moment I'm using open source drivers, there is OpenGL3.0 support (There should be 3.3 support on mesa 9.1 release), kinda working dynamic power management with occasional screen flickers (I've set it to low profile for daily use).

EDIT 1 : Sounds like only noticeable change is adding gl_ext_texture_srgb_decode OpenGL extension support for people playing Valve's Source engine powered games on Linux, nothing more.

Last edited by siavashserver (2013-01-22 11:15:09)

Offline

#4672 2013-01-22 16:18:45

andmars
Member
Registered: 2012-03-13
Posts: 153

Re: The AMD/ATI Bar & Grill

is anyone else noticing glitches in thumbnails, preview-pics, and other images with catalyst 13.1 when browsing the web? I'm using an HD6950 and it looks like this;

2013_01_22_163236_1920x1080_scrot.jpg


EDIT: latest cairo version 1.12.10-3 fixed it!

Last edited by andmars (2013-01-24 21:45:31)

Offline

#4673 2013-01-22 17:08:34

Gooler
Member
Registered: 2009-11-01
Posts: 14

Re: The AMD/ATI Bar & Grill

@andmars Yup, same here, and not just on the browser, happens everywhere: kate and amarok have also shown artifacts.

Offline

#4674 2013-01-22 17:13:28

andmars
Member
Registered: 2012-03-13
Posts: 153

Re: The AMD/ATI Bar & Grill

Gooler wrote:

@andmars Yup, same here, and not just on the browser, happens everywhere: kate and amarok have also shown artifacts.

for me I can pin this one down to dwb (webkit) as browser. It doesn't happen with firefox when opening the same urls. KDE apps work fine here (k3b, kdenlive) using monsterwm as...well as wm :-)

Offline

#4675 2013-01-22 18:15:12

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 375

Re: The AMD/ATI Bar & Grill

Offline

Board footer

Powered by FluxBB