You are not logged in.

#1 2013-01-18 21:08:07

sharkbyte
Member
Registered: 2013-01-18
Posts: 4

[SOLVED] setting font for tty

Hey,

I need a different font in the login console, e.g. tty.

Tried several things. I created a /etc/vconsole.conf with "FONT=ter-218b" which works quite fine with "setfont". Now when I set the hook in mkinitcpio.conf "consolefont" and build I get the error "No font found". ???

I the added the module "i915" because i use a thinkpad x200 and the only google-result which suggested help said so. No effect. Removing the "consolefont" hook just eliminates the Error message but nothing else.

Asked for help in IRC but no one has any further suggestions. Hope you do!  THX

Last edited by sharkbyte (2013-01-18 22:09:01)

Offline

#2 2013-01-18 21:11:27

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,031
Website

Re: [SOLVED] setting font for tty

Can you please paste your vconsole.conf?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-01-18 21:21:21

sharkbyte
Member
Registered: 2013-01-18
Posts: 4

Re: [SOLVED] setting font for tty

FONT=ter-218b

Offline

#4 2013-01-18 21:23:53

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,031
Website

Re: [SOLVED] setting font for tty

I can generate an image with that in my vconsole.conf without any errors. Have you grepped /usr/share/kbd/consolefonts to check that the file is present?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2013-01-18 21:26:25

sharkbyte
Member
Registered: 2013-01-18
Posts: 4

Re: [SOLVED] setting font for tty

Yes it is present. Installed it with pacman -Syu terminus as far as i remembered the command well.

It is also possible to set it with "setfont". Looks nice wink

Last edited by sharkbyte (2013-01-18 21:27:09)

Offline

#6 2013-01-18 22:07:38

sharkbyte
Member
Registered: 2013-01-18
Posts: 4

Re: [SOLVED] setting font for tty

The problem was that i made a file called console,conf. Using a kommat and not a point. Sorry noob failure.

Offline

Board footer

Powered by FluxBB