You are not logged in.

#1 2013-01-19 13:49:17

nuc
Member
Registered: 2012-04-26
Posts: 115

[NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

Hi!
Since the latest updates I've got silly glitches in texts. I often encounter it when doing copy and paste.
It happens on both, my PC and laptop (both on radeon drivers). The interesting part is that it doesn't happen for all texts but is always reproducible for certain texts (kinda scary - code injection?). I assume that it is either related to the open source radeon graphics driver or freetype 2.4.11.

You should be able to reproduce this, so please try! This needs to be fixed as fast as possible!

Here's how to reproduce:
1. Copy the code from the Codebox below. Don't worry this is just some code I posted today on the forum and the glitch occured. This also happens for other code but I caught this one "in the act". So if you're affected this will make it glitch big_smile

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <!-- Replace generic bitmap font names by generic font families.
         These font-families will get replaced by other rules and
	 default to scaled ones. -->
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>Helvetica</string>
        </test>
        <edit mode="assign" name="family">
            <string>Arial</string>
            <string>Liberation Sans</string>	    
            <string>sans-serif</string>
        </edit>
    </match>
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>Courier</string>
        </test>
        <edit mode="assign" name="family">
            <string>Courier New</string>
            <string>Liberation Mono</string>
            <string>monospace</string>
        </edit>
    </match>
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>Times</string>
        </test>
        <edit mode="assign" name="family">
            <string>Times New Roman</string>
            <string>Liberation Serif</string>
            <string>serif</string>
        </edit>
    </match>
</fontconfig>

2. Now attempt to make a new post by clicking "Post reply" in this forum and paste the code into the text field.
3. Type some random letters.
4. The glitch should occur.

This is of course only one example! However I didn't investigate further in this issue so far.

Here's a picture how it looks on my computers:
dsc00102pnjuq.jpg dsc00103t5jsj.jpg

My graphic cards: ATI Radeon HD 4770 and ATI Mobility Radeon HD 5650

If you experience the same, please post. Don't forget some graphics hardware info wink


best regards
nuc


EDIT: I think this Thread might actually fit better into the Kernel & Hardware-category. Would be nice if a mod moved it
the correct sub forum. [Moved. Thanks!]

EDIT 2: Might it be connected with this glitch https://bbs.archlinux.org/viewtopic.php?id=156460 ?

EDIT 3: I'm using xfce with xfwm. Now also tried OpenBox but the problem persists, so it's not the window managers fault.

Last edited by nuc (2013-02-05 19:45:59)

Offline

#2 2013-01-23 21:35:20

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,116
Website

Re: [NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

Moving to Kernel & Hardware...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-01-25 18:07:13

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

bump

Offline

#4 2013-02-05 19:51:21

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

Ok, I found out that it's related to firefox. Maybe it's connected to the current font rendering troubles in firefox 18 https://bugzilla.mozilla.org/show_bug.cgi?id=828206 ?

If someone can reproduce this, please post.


UPDATE:
Yep, firefox 17 isn't affected!

Last edited by nuc (2013-02-05 19:56:01)

Offline

#5 2013-03-03 16:33:30

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

ff19 still affected.

Offline

#6 2013-03-29 13:48:02

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [NOT SOLVED] Glitches since freetype 2.4.11 / latest radeon drivers?

Offline

Board footer

Powered by FluxBB