You are not logged in.

#1 2013-01-19 20:05:37

trollger
Member
Registered: 2012-06-20
Posts: 9

trying to mount a singe raid 1 partition

Hi all

I am having some trouble trying to mount a single raid drive, I have tried to use the mount command to no avail

mount /dev/sdb6 /media/sdb/
mount: unknown filesystem type 'linux_raid_member'

here is the partition table of the drive

fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 40.0 GB, 40000000000 bytes, 78125000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1    78124999    39062499+  ee  GPT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes, 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2ffa7f1a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63      514079      257008+  83  Linux
/dev/sdb2          514080     1028159      257040   83  Linux
/dev/sdb3         1028160     1542239      257040   82  Linux swap / Solaris
/dev/sdb4         1542240   976768064   487612912+   5  Extended
/dev/sdb5         1542303     2554334      506016   83  Linux
/dev/sdb6         2554398   976768064   487106833+  fd  Linux raid autodetect
lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0  37.3G  0 disk 
`-sda1   8:1    0  37.3G  0 part /
sdb      8:16   0 465.8G  0 disk 
|-sdb1   8:17   0   251M  0 part 
|-sdb2   8:18   0   251M  0 part 
|-sdb3   8:19   0   251M  0 part 
|-sdb4   8:20   0     1K  0 part 
|-sdb5   8:21   0 494.2M  0 part 
`-sdb6   8:22   0 464.6G  0 part 

I dont know what to try next, I have searched on the internet but everything I try doesnt work, could some one please help me out, I need the data on this harddrive.

Offline

#2 2013-01-20 01:13:58

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: trying to mount a singe raid 1 partition

I'm pretty sure you can't. You have to assemble it first: https://wiki.archlinux.org/index.php/RA … _a_Live_CD


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#3 2013-01-20 05:02:20

trollger
Member
Registered: 2012-06-20
Posts: 9

Re: trying to mount a singe raid 1 partition

hmm. yes I did a lot of research today since I posted this and it would appear that it is already assebled, however, it is assembled at /dev/md127.

Since it is already assembled I get mdadm: /dev/sdb6 is busy - skipping when trying to assemble it.

So assuming it is assebled properly, which I don't know how to test, then how whould I go about mounting it now?

Offline

#4 2013-01-20 09:18:25

dicktater
Member
Registered: 2013-01-20
Posts: 1

Re: trying to mount a singe raid 1 partition

Did you build it? Is it a software raid? What RAID type is it?

Use this to see if you have any software RAID devices available:

ls -l /dev/md*

 
And this for good measure to see what devices you already have mounted where:

df -h

 
You may not be able to mount it until you activate it with mdadm, in which case it'll become a new device, /dev/md*, (which I do not see).

What does mdadm find?

mdadm --detail --scan

It should find something like this:

ARRAY /dev/md/md0 metadata=1.2 name=machinehead:md0 UUID=7bdd75d3:4825e0ed:109d2005:5dba7b17

Does that match  /etc/mdadm.conf ?

What is the filesystem? Sample to mount a RAID device from the command line:

mount /dev/md0 /mnt/raid

Here is an sample mount line for fstab:

/dev/md0      /mnt/raid     ext4    defaults    1 2

Here are two good sources of in depth info:

https://wiki.archlinux.org/index.php/RAID

Quick HOWTO : Ch26 : Linux Software RAID
http://www.linuxhomenetworking.com/wiki … w_RAID_Set

Offline

#5 2013-01-20 19:23:07

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: trying to mount a singe raid 1 partition

trollger wrote:

hmm. yes I did a lot of research today since I posted this and it would appear that it is already assebled, however, it is assembled at /dev/md127.

Since it is already assembled I get mdadm: /dev/sdb6 is busy - skipping when trying to assemble it.

So assuming it is assebled properly, which I don't know how to test, then how whould I go about mounting it now?

Have you tried to mount /dev/md127?


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#6 2013-01-21 08:29:52

nowahn
Member
From: elsewhere
Registered: 2008-12-05
Posts: 75

Re: trying to mount a singe raid 1 partition

Hi,

trollger wrote:

So assuming it is assembled properly, which I don't know how to test, […]

cat /proc/mdstat

to see which arrays are currently assembled and what is their states.


take time to daydream, inspiration comes ...

Offline

Board footer

Powered by FluxBB