You are not logged in.

#51 2005-11-03 13:37:40

swiergot
Member
From: Kraków, Poland
Registered: 2005-01-08
Posts: 145

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

It would be helpful if you attached your /etc/fstab, /etc/mkinitrd.conf and /boot/initrd26.img (you can use the bugtracker).

Offline

#52 2005-11-03 14:13:11

orjanp
Member
From: Tromsoe, Norway
Registered: 2004-07-03
Posts: 337

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

fstab

# 
# /etc/fstab: static file system information 
# 
# <file system>        <dir>         <type>    <options>          <dump> <pass> 
none                   /dev/pts      devpts    defaults            0      0 
none                   /dev/shm      tmpfs     defaults            0      0 
tmpfs                  /tmp          tmpfs     defaults            0      0 
usbfs                  /proc/bus/usb usbfs     defaults            0      0
/dev/hda11   swap swap defaults 0 0
/dev/hda8    / ext3 defaults 0 1
/dev/hda6    /boot ext3 defaults 0 1
/dev/hda7    /home ext3 defaults 0 1
/dev/hda9    /usr ext3 defaults 0 1


mkinitrd.conf

REMOVE_IDE=
REMOVE_SCSI=1
REMOVE_SATA=1
REMOVE_CDROM=
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_CRYPT=1
REMOVE_FS=

# Define which modules are needed by adding "moduleX moduleY"
# empty means all modules are included if they are not disabled above!
HOSTCONTROLLER_IDE=piix
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

# Define Crypt device here
CRYPT_DEVICE=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

Ørjan Pettersen

Offline

#53 2005-11-03 14:39:28

swiergot
Member
From: Kraków, Poland
Registered: 2005-01-08
Posts: 145

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

You haven't provided your /boot/initrd26.img. Have you rebuilt it with the latest mkinitrd? Have you tried running mkinitrd with empty HOSTCONTROLLER_IDE?

Offline

#54 2005-11-03 16:02:27

Chestah
Member
From: Schoorl, The Netherlands
Registered: 2005-02-08
Posts: 16

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

edit:

New initrd package; my ext2-fs warning is gone!  smile

Offline

#55 2005-11-03 21:20:40

gujeroo
Member
From: didjabringabeeralong
Registered: 2005-03-23
Posts: 17
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Hi there.

Just tried to install mkinitrd.

Uncommented the 'Testing' entries in my /etc/pacman.d/servers.conf, but a 'pacman -S mkinitrd' returns: mkinitrd: not found in sync db'.

Am I just silly?

my servers.conf just looks like this one: http://wiki.archlinux.org/index.php/Ser … erver_file

Cheers
Gujeroo


$>man woman
no manual entry for woman

Offline

#56 2005-11-03 21:28:03

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

use this server instead:
Server = ftp://ftp.archlinux.org/testing/os/i686

That wiki page looks outdated/unusual.

EDIT: Did you sync your db? Try

pacman -Sy mkinitrd

Offline

#57 2005-11-03 22:39:18

gujeroo
Member
From: didjabringabeeralong
Registered: 2005-03-23
Posts: 17
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Hi.

Snowman wrote:

use this server instead:
Server = ftp://ftp.archlinux.org/testing/os/i686

This did it. Thanks.

As far as I understood the server.conf was intended to reduce traffic on the main arch servers.

I will now try to reboot and see what happens.

Cheers
Gujeroo


$>man woman
no manual entry for woman

Offline

#58 2005-11-04 07:46:05

niqo
Member
From: Paris
Registered: 2005-11-04
Posts: 29

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

work fine for me since few days.
is possible to reactivate softwaresuspend ?

Offline

#59 2005-11-04 17:29:07

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Well, not all is good for me: I can mount a dvd and use it only for seconds, then I recieve messages I should mount the DVD (that is already mounted) and the system freezes completly. This happens also using CDs, both on a scsi and a sata device. Switched back to current kernel, removed initrd from grub and all is OK again. No other parts of the system have been changed during the initrd testing.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#60 2005-11-04 17:36:23

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

I have a question: how will this affect bootsplash, which already needs an initrd?  Can I specify multiple initrd's?

Offline

#61 2005-11-04 17:37:57

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Moo:
which kernel you boot?
-3 or -4?
-3 has no joliet support.
-4 has it again

Offline

#62 2005-11-04 18:18:37

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

aha ... it was -3, afaik. I did a test with -4 imediately. It failed, too.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#63 2005-11-05 10:52:36

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 622
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Okay, my turn

followed the mkinitrd wiki page up to mkinitrd.conf optimization.
Everything went up fine smile

Now about optimization, what IDE modules one should add to mkinitrd.conf when he's got that modules loaded :

# lshwd | grep IDE
00:05.1 IDE interface: Intel Corp.|82371AB PIIX4 IDE (ata_piix)
00:05.3 Bridge: Intel Corp.|82371AB PIIX4 ACPI - Bus Master IDE Controller (sonypi)
001:002 USB Mass Storage: Cypress Semiconductor Corp.|USB-2.0 IDE Adapter (usb-storage)

Will something like this works :

HOSTCONTROLLER_IDE=piix
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

or should I add 'sonypi' to 'piix' ?

Computer is a Toshiba Portégé 7200 Series with PIII 647MHz

I'm pretty interested on some optimization, as my AL config serve as a base for 6 Desktop PCs PIII 800MHz at our young workers association wink


PGP Key: 1C2A554EFF0157D9
Core i3 @3.30GHz | 4GB RAM | Arch linux-ck
Atom N450 2 gig RAM, Arch linux 4.6.0rc3 i686 (5+H battery smile) | ARM Tegra K1 4 gig RAM, Chrome OS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16.0-0.bpo.4-586 on SDHC

Offline

#64 2005-11-05 12:14:52

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

I think its sonypi but I would include them both in "double" quotes to be sure.

Offline

#65 2005-11-05 14:05:08

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 622
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Well Penguin, I'll give a try like this :

# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=1
REMOVE_SATA=1
REMOVE_CDROM=1
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=
REMOVE_CRYPT=1
REMOVE_FS=

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE="sonypi piix"
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS="ext2 ext3"

As /boot is on ext2 and / is on ext3, all on a single IDE drive.


PGP Key: 1C2A554EFF0157D9
Core i3 @3.30GHz | 4GB RAM | Arch linux-ck
Atom N450 2 gig RAM, Arch linux 4.6.0rc3 i686 (5+H battery smile) | ARM Tegra K1 4 gig RAM, Chrome OS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16.0-0.bpo.4-586 on SDHC

Offline

#66 2005-11-06 14:25:00

rdoggsv
Member
From: /home
Registered: 2005-06-24
Posts: 79
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

to stop from loading a lot of modules i did what u said about lshwd | grep IDE and its output was this

00:11.1 IDE interface: VIA Technologies|VT82C586 IDE [Apollo] (snd_via82xx)


so then i went to the mkinitrd.conf file and put it on the host controller ide , then i rebooted and *boom* im stuck after some messages.

so i started with some live cd and chrooted the enviroment and deleted the snd_via82xx module.

the rebooted back to my arch linux and i noticed that on the loaded modules was one that say via82cxxx so i put this instead. Then rebooted to the arhclinux and it worked fine with this addition.

So i just wanted to recall that lshwd | grep IDE didnt worked for me and lets hope anothers dont fall into this.

Offline

#67 2005-11-06 14:34:56

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

rdoggsv: You should report that on the "improving hwd and lshwd" in the user contributions forun (see first post) so it can be fixed.

Offline

#68 2005-11-06 16:14:30

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Hi everybody!

I have two questions about this new kernel
- All the modules are loaded (SCSI, USB, RAID) even if I modify /etc/mkinitrd.conf
- More important : my CPU load is very high (and it is strange because top does not show you which process is so heavy). I have the same pb with the kernel26 in current. However a home-made compiled kernel (2.6.14-rc5) with the acpi-dsdt-initrd-v0.7d-2.6.12.patch and nvidia.patch doesn't lead to such a problem. I wonder if there is another patch from Arch that makes the cpu load very high on i915 chipsets (don't have this problem on Ubuntu for example)

Any idea ?

Offline

#69 2005-11-06 16:50:59

rdoggsv
Member
From: /home
Registered: 2005-06-24
Posts: 79
Website

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

marmotte wrote:

Hi everybody!

I have two questions about this new kernel
- All the modules are loaded (SCSI, USB, RAID) even if I modify /etc/mkinitrd.conf
Any idea ?

instead of running mkinitrd auto , run mkinitrd auto -scsi -usb -raid , or something like that, maybe mkinitrd --help can give u more ideas.

Offline

#70 2005-11-07 19:10:31

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Thanks for the advice, I will test that.

No idea about the high cpu load ? Do I have to report it somewhere ?

Offline

#71 2005-11-07 19:20:27

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

got 2.6.14 running here (updated mkinitrd) so far so good ... 8)

o ... mkinitrd.conf I forgot to set it up ... just ran mkinitrd auto  :oops:

Now I'm thinking thats bad ...I'll edit mkinitrd.conf & run mkinitrd auto again ;-)

Got loads of modules loading now  :cry:


Mr Green

Offline

#72 2005-11-07 19:28:33

swiergot
Member
From: Kraków, Poland
Registered: 2005-01-08
Posts: 145

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

marmotte wrote:

No idea about the high cpu load ? Do I have to report it somewhere ?

I'd say it's not related to mkinitrd. I could be a bug in 2.6.14.

Offline

#73 2005-11-07 23:30:38

grail
Member
Registered: 2005-02-22
Posts: 70

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Well I tried kernel 2.6.14-4 from testing and mkinitrd. All worked well except that it no longer recognised my _NEC DVD+/-RW ND-6650A, ATAPI CD/DVD-ROM drive. I tried playing around with the /etc/mkinitrd.conf but could not get it to load the corrent driver for that IDE burner. It does however load my SATA HD ok. So does anyone have any suggestions on how to get both the IDE DVD and SATA HD to load and work with the new 2.6.14-4 and mkinitrd

Offline

#74 2005-11-08 06:12:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

sounds like you disabled cdrom in mkinitrd.conf.
if yes make sure that ide-cd modules is loaded in rc.conf, or enable it again in mkinitd.
greetings
tpowa

Offline

#75 2005-11-08 06:46:43

grail
Member
Registered: 2005-02-22
Posts: 70

Re: [kernel] 2.6.14 : IMPORTANT CHANGES - upgraders please read

Nope, this was my /etc/mkinitrd.conf:

# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=
REMOVE_SATA=
REMOVE_CDROM=
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_CRYPT=1
REMOVE_FS=

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE=
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

# If you have an encrypted root filesystem, set it here
CRYPT_DEVICE=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

Even if I ran 'mkinitrd full' and used that my IDE DVD player did not show up (no hdc in /dev)

Offline

Board footer

Powered by FluxBB