You are not logged in.

#1 2013-01-18 22:31:40

zrubi
Member
Registered: 2013-01-18
Posts: 1

Unable to use USB Microphone

Hey all,

I was trying to use my ZOOM H2 Recording device as USB Mic, but never managed to do that.
I know that it's working cause I can use it as mic in my windows.

When looking at "Sound Settings" I don't see it under Input tab but I do see that it exist under Output tab as "Analog Output - H2"

I googled it and I couldn't find any solution for that.

Here is the output from arecord -L

null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=Intel
    HDA Intel, ALC889A Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, ALC889A Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, ALC889A Digital
    IEC958 (S/PDIF) Digital Audio Output
sysdefault:CARD=H2
    H2, USB Audio
    Default Audio Device
front:CARD=H2,DEV=0
    H2, USB Audio
    Front speakers
surround40:CARD=H2,DEV=0
    H2, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=H2,DEV=0
    H2, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=H2,DEV=0
    H2, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=H2,DEV=0
    H2, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=H2,DEV=0
    H2, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=H2,DEV=0
    H2, USB Audio
    IEC958 (S/PDIF) Digital Audio Output

And the only log I get from dmesg after pluging it in and out

[1129446.040404] usb 8-2: new full-speed USB device number 2 using uhci_hcd
[1129446.963106] usbcore: registered new interface driver snd-usb-audio
[1129684.983748] usb 8-2: USB disconnect, device number 2
[1129697.047052] usb 8-2: new full-speed USB device number 3 using uhci_hcd
[1129715.733747] usb 8-2: USB disconnect, device number 3
[1129727.287045] usb 8-2: new full-speed USB device number 4 using uhci_hcd
[1129768.483737] usb 8-2: USB disconnect, device number 4
[1129793.230372] usb 8-2: new full-speed USB device number 5 using uhci_hcd
[1130000.983713] usb 8-2: USB disconnect, device number 5
[1130025.657014] usb 8-2: new full-speed USB device number 6 using uhci_hcd
[1130829.983632] usb 8-2: USB disconnect, device number 6
[1130840.433603] usb 8-2: new full-speed USB device number 7 using uhci_hcd

Thanks,
Zrubi

Offline

#2 2013-01-20 07:39:43

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Unable to use USB Microphone

Most USB headsets and stuff have their own built in sound card.
https://wiki.archlinux.org/index.php/Ad … ound_Cards

If this is the case then you need to change your sound card. You can use this GUI to do it.
https://aur.archlinux.org/packages/asoundconf/

You will also need to change it in like KDE settings... or maybe only in the KDE settings if it is just a microphone.... Also, in whatever application you are using you will probably also have to set the correct sound input.

Anyway, if you open alsamixer in a terminal and then hit F6 you can change the settings for that sound card.

Last edited by hunterthomson (2013-01-20 07:47:03)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

Board footer

Powered by FluxBB