You are not logged in.

#1 2013-01-20 08:14:35

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,801
Website

[SOLVED] Strange alsamixer problem: arrow keys don't work on Master

I have a laptop with an HDA Intel PCH hard. Until recently everything has worked as expected. I do not know when this problem appeared, but I think it was in the last week or two.

I'll just present what I know in a list:

  • I can change the volume of Master with "amixer set Master...".

  • The volume range has changed: before "60" was about 1/3 of the scale, now 140 is 0% and 255 is 100%.

  • I can still adjust the level by pressing number keys in alsamixer, but they are no longer level with even 10s (e.g. pressing 5 sets it to 47).

  • I can also change the volume over the full range with the page up and page down keys (keysym Next and Prior)

  • If I set the volume below 36, I can use the arrow keys to adjust it, but as soon as it hits 36, it stops responding to the arrow keys.

  • I can use q and z to adjust the sound. They increase and decrease the left channel by one step, then pull the right channel with it.

  • w and x work as the arrow keys (i.e. they don't, at least not above 36)

  • e and c do not work. Pressing either once changes the right channel by one step as expected, but pressing it again undoes the step.

  • I do not have ~/.asoundrc, /etc/asound or any other configuration file (and have not had any when it worked before)

  • I have not found any errors in journalctl or elsewhere (although I have disabled the syslog-ng server as recommended by the wiki... not sure if that might prevent some errors from being logged)

  • Incidentally, at 36 the dB gain is near 100... no idea if that is related: Master [dB gain: 99.75, 99.75]

Here are the loaded sound modules.

$ lsmod | grep '^snd' | column -t
snd_hda_codec_hdmi     24529  1
snd_hda_codec_realtek  61420  1
snd_hda_intel          26181  1
snd_hda_codec          98034  3  snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              6429   1  snd_hda_codec
snd_pcm                75735  3  snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         7218   2  snd_pcm,snd_hda_intel
snd_timer              18935  1  snd_pcm
snd                    60189  9  snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel

I have no idea wtf is going on but this is really annoying. Does anyone have any idea of what I can check or try? Any help would be appreciated.

Last edited by Xyne (2013-05-09 05:32:29)

Offline

#2 2013-04-13 01:55:53

shauder
Member
Registered: 2010-05-18
Posts: 21

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

I am not 100% sure when this started but I have recently noticed it. I don't change my volume through the OS often.  However I am unable to control the Master volume. 

* I found it stuck at 24% and using the arrow keys does not seem to change it at all. 
* I can mute the channel.
* I can control other channels such as PCM just fine
* I can use the number controls 1 = 9%, 2 = 24%, 4 = 40%, 6 = 63%, 8 = 100%
* I do not have ~/.asoundrc, /etc/asound
* I cannot use q and z or w and x or e and c
* It did used to work fine, possibly an upgrade messed with it.

[501]shauder@arch-desktop [~] $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
[502]shauder@arch-desktop [scr:1][~] $ lsmod | grep '^snd' | column -t
snd_hda_codec_hdmi     27793   4
snd_hda_codec_realtek  61415   1
snd_usb_audio          111097  0
snd_hda_intel          33786   4
snd_usbmidi_lib        19091   1   snd_usb_audio
snd_rawmidi            18870   1   snd_usbmidi_lib
snd_seq_device         5212    1   snd_rawmidi
snd_hda_codec          101730  3   snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              6332    2   snd_usb_audio,snd_hda_codec
snd_pcm                77212   5   snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         7298    2   snd_pcm,snd_hda_intel
snd_timer              18719   2   snd_pcm
snd                    59181   17  snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
[556]shauder@arch-desktop [scr:1][~] $ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default:CARD=SB
    HDA ATI SB, ALC888 Analog
    Default Audio Device
sysdefault:CARD=SB
    HDA ATI SB, ALC888 Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    HDMI Audio Output

This thread is almost an identical issue - mod edit: merged threads

Any help would be greatly appreciated.

Last edited by Xyne (2013-04-13 14:37:31)

Offline

#3 2013-04-13 02:00:18

shauder
Member
Registered: 2010-05-18
Posts: 21

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

Offline

#4 2013-04-13 14:33:56

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,801
Website

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

The problem is indeed nearly identical and very likely related, so I will merge this post with the previous thread.

Thanks for posting reference links in both.

Offline

#5 2013-05-08 23:55:19

shauder
Member
Registered: 2010-05-18
Posts: 21

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

Xyne wrote:

The problem is indeed nearly identical and very likely related, so I will merge this post with the previous thread.

Thanks for posting reference links in both.

I took the cheaters way out and did a reinstall. It is working normally now.

Offline

#6 2013-05-09 00:17:17

brebs
Member
Registered: 2007-04-03
Posts: 3,466

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

Xyne wrote:

The volume range has changed: before "60" was about 1/3 of the scale, now 140 is 0% and 255 is 100%.

This is specified in /var/lib/alsa/asound.state, e.g.:

    control.26 {
        iface MIXER
        name 'Master Playback Volume'
        value 38
        comment {
            access 'read write'
            type INTEGER
            count 1
            range '0 - 64'
            dbmin -6400
            dbmax 0
            dbvalue.0 -2600
        }
    }

Do you have a backup of that file, to compare?

Offline

#7 2013-05-09 05:41:36

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,801
Website

Re: [SOLVED] Strange alsamixer problem: arrow keys don't work on Master

Thanks for the replies. They both pointed me in the right direction and I have finally solved the problem with the following steps:

1) rm /var/lib/alsa/asound.state{,.lock}
2) pacman -R alsa-utils
3) reboot
4) pacman -S alsa-utils
5) alsactl store

The systemd services provided by alsa-utils are statically enabled, so I removed the package before rebooting to prevent the recreation of the deleted state file during shutdown. I didn't save a copy of the state file before removing it, but there were definitely some changes (e.g. dbvalue.0 for "Master Playback Volume" and  extra controls).

Offline

Board footer

Powered by FluxBB